1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the new DBSTalk community platform. We have recently migrated to a community platform called Xenfono and hope you will find this change to your liking. There are some differences, but for the most part, if you just post and read, that will all be the same. If you have questions, please post them in the Forum Support area. Thanks!

External Drive Not Attached - 622

Discussion in 'ViP612/622/722/722K DVR Support Forum' started by denkbar, Feb 1, 2012.

  1. denkbar

    denkbar Mentor

    39
    0
    Nov 10, 2005
    After removing a working 2 year old Maxtor MyTouch4 1TB external drive from my Windows PC (NTFS formatted), plugged it in to 622. Its ready light comes on., but no recognition message appears on the TV. When I access Menu 4: Multimedia, under "External USB Devices" it displays "No Device Attached". Did a Power Off/On reboot but no change.

    Dish tech support says the drive has to be in its "out of the box" state, i.e., has not been formatted for an operating system's use (FAT/NTFS, Linux, et. al.).

    When asked "Is there a way to get the 622 to format it", answer was "no".

    Aside from buying a new external drive, does anyone know of a way to get this drive to work?

    Thanks
     
  2. Ray C@DISH Network

    Ray C@DISH Network DISH Representative DISH Representative

    914
    1
    Dec 28, 2010
    The drive has to meet certain requirements. The drive must be 50 MB to 2 TB in size; must have its own power supply; must be single tiered, and can't be a flash drive. The receiver, once the EHD is recognized, will alert you to the drive needing to be reformatted. Please let me know if this drive meets these requirements. Thanks.
     
  3. denkbar

    denkbar Mentor

    39
    0
    Nov 10, 2005
    Thank you for the reply.

    "The drive must be 50 MB to 2 TB in size; must have its own power supply; must be single tiered, and can't be a flash drive"

    If by "single tiered", you mean the drive is all rotational and not "part solid state and part rotational", then yes, the drive meets all of these requirements.

    The "Level 1 tech" put me on hold while he talked to an advanced support rep, so I took him at his word about the drive having to be in an unformatted state. From your note, it seems that is not the case, though.

    I have since connected to my PC and it is still accessible from Windows Vista 64, and also from a Linux machine, so it looks like the drive is working.
     
  4. P Smith

    P Smith Mr. FixAnything

    21,338
    127
    Jul 25, 2002
    W.Mdtrn Sea
    You could clean MBR for start ... ie write all 00s to sector#0
     
  5. denkbar

    denkbar Mentor

    39
    0
    Nov 10, 2005
    The external drive is now working.

    After Ray C's reply indicating that an un-used drive is not required, I connected the drive to a 722K. It was recognized, gave me the "...format required" and "...are you sure" messages and then formatted the drive.

    Connected to the 622, and it was recognized. I could copy a recording to the drive.

    The only thing I can think of is there must have been "something" in the NTFS-formatted drive's handshaking that the 622's software did not recognize. (622 software Level L710).

    Paul, thank you for the MBR-to-0's suggestion. I have another old external drive that I'll try that on.

    Thank you both for your help, and please consider the problem resolved.
     

Share This Page