1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the new DBSTalk community platform. We have recently migrated to a community platform called Xenfono and hope you will find this change to your liking. There are some differences, but for the most part, if you just post and read, that will all be the same. If you have questions, please post them in the Forum Support area. Thanks!

GenieGo Out Of Home Access: cannot get it working with Comcast

Discussion in 'DIRECTV Connected Home' started by chris.dg, Dec 10, 2013.

  1. chris.dg

    chris.dg Cool Member

    35
    1
    Nov 25, 2006
    Hello - Well, I've exhausted all resources, so I'm coming to the gurus here for some much appreciated help... Here's the scenario:


    topology:
    Comcast Xfinity ISP > Arris modem > NetGear R4500 Router > 5-port switch > GenieGo (plus 2 HR34 devices also on this switch)

    - GenieGo device works perfectly within the house on my iPad, iPhone, and Windows PC, but the "Out of Home Access" feature doesn't work. When I'm outside of the house, the app stalls at the "searching for GenieGo" point, and when I'm in the house and run the "Test Out of Home Access" option within the app, it keeps telling me that "Out of Home Access is not setup" and wants me to go through the setup again.

    - I've setup the IP address reservation and Port Forwarding on router using both the automated method where my laptop is connected via wire directly to my NetGear N900 Series Router (model R4500) and the GenieGo software remotely configures the router, AND when that didn't work, manually per the DirecTV instructions here. I've reserved 192.168.1.23 for the GenieGo device, then setup TCP port forwarding for ports 8082 and 8083 for that internal IP address. I also tried different port combinations with no luck.

    - DirecTV's advanced tech support group told me to call my COMCAST ISP, and have them open those ports. So, I called Comcast, told them I needed ports 8082 and 8083 open for this streaming service... they charged me $79.95 for their "Signature Service" advanced tech support. That tech told me that Comcast does not block those ports. He says the only ports they block are those listed here. He logged into my PC via remote conferencing service, controlled my dekstop and confirmed I had the NetGear router configured correctly (after viewing the geniego requirements). NOTE: Sitting in front of my NetGear Router is the Comcast-supplied Arris cable/telephony modem which provides my internet, which he did not access in any way. I had thought that maybe this is where a change also needed to be made, but apparently not.

    - I called DirecTV back and after another hour on the phone with tech support, still no luck. They pointed the finger back at Comcast.

    - When I use a "port checking" online service such as CanYouSeeMe.org or yougetsignal.com to check to see which ports are open (per DirecTV's recommendation), those tools identify my IP address as 98.248.107.45, which is Comcast ISP, and the results say "Connection timed out" or"Port 8082 is closed on 98.248.107.45" respectively. In fact, no matter what port i put in there (whether it be 80 or 8083 or 100, or whatever), it says the port is closed (or times out)

    So, I'm at a loss.

    Does this give anyone enough information to go on? I'll send a 6-pack to your house if you can solve this. :grin:

    Thank you very much for your time.
    -Chris
     
  2. Scott Kocourek

    Scott Kocourek Well-Known Member

    9,491
    523
    Jun 13, 2009
    I recently had my cable modem replaced with an Arris Gateway and that is where I ran into the problem. My Linksys was set up as a router and the new Arris was also a router. I had to go to the Linksys and switch it over to bridge mode, and then restart everything in the house so it would get the internal IP from the Arris and not the Linksys - in yourcase the Netgear router. I did an internet search for the default address on the Arris so I could see everything connected to it and found that only the Linksys had an IP. After switching the Linksys to bridge mode Out of Home worked perfectly.

    Keep us posted.
     
  3. chris.dg

    chris.dg Cool Member

    35
    1
    Nov 25, 2006
    Thanks. Did you also try putting your Arris into bridge mode instead of the Linksys? It seems to me I'd want more of the intelligence happening in the device I can control (in my case, the NetGear Router + WAP).
     
  4. Scott Kocourek

    Scott Kocourek Well-Known Member

    9,491
    523
    Jun 13, 2009
    No, I let the Arris do the DHCP and UPnP. I was told that you can let the Netgear do the DHCP but the Arris has to do the UPnP. Just make sure you're plugged into one of it's LAN ports, not the WAN port. Also, make sure the NetGear is assigning DHCP addresses on the same LAN subnet as the Arris. Likely, 192.168.1.x

    I recently went through this and basically re-posted the instructions given to me, they worked perfectly.
     
  5. chris.dg

    chris.dg Cool Member

    35
    1
    Nov 25, 2006
    My cable modem is the "Arris TM722g Telephony Cable Modem Docsis 3.0", it does not have built-in router + wireless functionality like the Arris TG852G or TG862G. So, unfortunately, I don't think we're in the same situation Scott. When I go to my Arris directly via browser to http://192.168.100.1, I get a status page, an event log, and other static info, but no ability to "login" and configure anything related to routing.
     
  6. Scott Kocourek

    Scott Kocourek Well-Known Member

    9,491
    523
    Jun 13, 2009
    Well that's a bummer, I will look and see if there are any other solutions that I can come up with.
     
    1 person likes this.
  7. NR4P

    NR4P Dad

    6,270
    254
    Jan 15, 2007
    Sunny Florida
    Did some searching on the web.
    What I gathered is that if Comcast supplies the modem and leases it back to you, they won't let you into it.
    Seems to be a lot of those complaints.

    On the other hand, if you buy it and enroll it yourself (calling Comcast DIY department) you get full access.
    Might want to read this. User name and PW is available for the owned product.

    http://blog.trebacz.com/2012/01/comcast-xfinity-internet-and-arris.html


    Good Luck
     
    1 person likes this.
  8. chris.dg

    chris.dg Cool Member

    35
    1
    Nov 25, 2006
    Thank you very much for poking around! Actually, I just ordered a replacement Arris modem from eBay earlier today, in order to avoid the $8 per month rental fee I am currently paying (the same intent of the blogger above). But even if I do have access to the device, I'm not sure there is any configuration I could make within it to actually solve my port forwarding problem, since it's not a router, it's strictly a cable modem, not a combo device such as Scott has. Unless am I missing something.

    Cheers gentlemen.
     
  9. NR4P

    NR4P Dad

    6,270
    254
    Jan 15, 2007
    Sunny Florida
    I have a Netgear R6300 Router. Although a different version, maybe the port forwarding setup is like yours.
    Here's a screenshot of mine and how I separate the port settings which was required to make the forwarding work.

    The internal IP address is the reserved IP address which will be what you determine.
     

    Attached Files:

  10. chris.dg

    chris.dg Cool Member

    35
    1
    Nov 25, 2006
    Thanks. Yes, this is exactly what mine looks like...yet still no success.
     
  11. Jnelson

    Jnelson Cool Member

    27
    0
    Oct 14, 2010
    NR4P: I have the 6300 as well behind a Motorola Surfboard, but have been unable to get GenieGo OOH to work. My port forwarding set up is identical. any other ideas?
     
  12. dualsub2006

    dualsub2006 Icon

    883
    21
    Aug 28, 2007
    I couldn't get OOH to work with a Moto Surfboard and Airport Extreme on TWC.

    I changed the port numbers in the auto setup to 5001, 5002 and OOH works perfectly now. I use it all the time.
     
  13. Scott Kocourek

    Scott Kocourek Well-Known Member

    9,491
    523
    Jun 13, 2009
    Good to know. Thanks for the update.

    Sent from my SCH-R970 using Tapatalk
     
  14. NR4P

    NR4P Dad

    6,270
    254
    Jan 15, 2007
    Sunny Florida
    The R6300 modem was only part of my problem. Still had to wrestle with the Uverse modem.

    Once I set up the R6300 like the above, it still didn't work.
    Went into my Uverse modem and turned off all firewall protection. Opened it wide.
    OOH worked!
    So I knew the Netgear was correct and where the problem was.

    Went back to Uverse modem, put the firewall back as was, and had to port forward the GG ports to the EXTERNAL WAN IP address.

    In summary, the Netgear router is forwarded to the reserved internal IP address of the box (192.168.x.x) and Uverse modem is forwarded to the external IP address such as 99.x.x.x Tried port forwarding to the Netgear router and it didn't work.

    Hope the above steps with other modems help point them in the right direction.
     
  15. chadspeedy

    chadspeedy New Member

    1
    0
    Dec 27, 2013
    Grayslake, IL
    I know i am new here, but maybe i can shed some light for those of you that werent able to get it working, I dont have a Genie Go HOWEVER, it sounds like what is happening is the WAN Port which is where your Comcast internet connection comes into your Router in my case the Netgear WNDR 3700v3, isnt able to be pinged so you need to go over to the Advanced Tab on your router and then go to Setup on the Left Side of the Screen and then down to WAN Setup and check the box that says Respond to Ping on Internet Port, Now, if you use port forwarding to the respective IP address of the Genie Go, it should be able to find your Genie Go.

    Hope this helps some.
     
  16. chris.dg

    chris.dg Cool Member

    35
    1
    Nov 25, 2006
    This sounded promising, and thank you for the suggestion, but this change unfortunately did not resolve my issue. I activated "Respond to Ping on Internet Port", yet the identical error messages occur when attempting to activate "Out of Home Access"
     
  17. posty

    posty Mentor

    35
    0
    Sep 14, 2008
    If port forwarding is set up correctly on your NetGear router then your Arris modem is most likely the device that is blocking access to your GG. You'll need to figure out how to get into the advanced web interface of that device to see how it's configured. What do you see when you go to this URL:

    http://192.168.100.1/cgi-bin/tech_support_cgi

    There is some interesting info out here that may be helpful to you.
     
  18. xforms

    xforms New Member

    2
    0
    Feb 16, 2014
    Texas
    Good day to you all. I'm having some issues with a the GenieGo. I'm using an apple time machine and a Ubee ddw3611. In the GenieGo application, the Network assistant is passing all 6 test. However, the out of home access test returns out of home not set up. Should I tear everything down and simply start over? I didn't think it would be this complicated - so please forgive me
     
  19. xforms

    xforms New Member

    2
    0
    Feb 16, 2014
    Texas
    UPDATE - I'm using Apple Time Machine, which I configured to "Bridge Mode" behind the Ubee and a Netgear switch. I set the ports on the Ubee to 8082/8083. I setup Ubee's DHCP Static Lease for the GenieGo. I had to reboot the iMac - AFTER I saved the configuration in the Ubee modem, and BEFORE I restarted the Time Capsule. Hope this helps anyone in the Mac environment with the aforementioned setup. Good Day to you all.
     

Share This Page