1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

H20 and terk hdmi21 trbl

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by jlnigro, May 13, 2007.

Thread Status:
Not open for further replies.
  1. jlnigro

    jlnigro New Member

    1
    0
    May 13, 2007
    Just bought all new equipment. Olevia 342i, philips dvp-5960/37 and got the dtv h20. The Olevia 342i only has 1 hdmi input and the philips upconverts to 1080i thru hdmi. So I ordered a terk hdmi21 switcher.

    When the h20 is plugged into the Olevia directly thru hdmi it has worked fine for a week . I have it set for native on and picture is fine in both HD and SD. Sound is going thru pioneer a/v receiver using optical out on h20.

    Now I plugged the h20 into port 1 on the hdmi21 and the philips into port 2 and the output of hdmi21 to the olevia. the philips works fine. the h20 loses picture after 30 seconds. even if I unplug the philips it does the same. Then I plugged h20 into port 2 and same trbl.

    Since there are so many troubles listed for the h20 and I can't find a single one for the hdmi21 switch or any significant ones for the Olevia, I assume the h20 is at fault. Terk says the switch needs voltage from the components to power the switch and I thought maybe voltage from h20 hdmi port is not sufficient or to spec and that may be the trouble.

    Anyone else having trouble with a hdmi switch or thru a receiver that switches hdmi? also can I use the component outputs on the h20 and still get 1080 I on the Olevia tv?
     
Thread Status:
Not open for further replies.

Share This Page