1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the new DBSTalk community platform. We have recently migrated to a community platform called Xenfono and hope you will find this change to your liking. There are some differences, but for the most part, if you just post and read, that will all be the same. If you have questions, please post them in the Forum Support area. Thanks!

Has anyone ever had a dish DVR last more than a few years?

Discussion in 'ViP612/622/722/722K DVR Support Forum' started by steveT, Feb 27, 2012.

  1. BillJ

    BillJ Icon

    858
    6
    May 5, 2005
    One of my 622's was one of the first installed. Don't remember the year but I think it was late February or early March because I remember pushing for an earlier appointment so it would done before I left on a golf trip.

    My other 622 was installed a couple years later. Both still working fine.
     
  2. renpar61

    renpar61 Legend

    138
    0
    Aug 5, 2006
    I got my 622 since first installation in '05
     
  3. Mr.Gadget

    Mr.Gadget Mentor

    51
    0
    Mar 28, 2004
    I still have two 501's going strong (HD's replaced) - knock on wood.
     
  4. MrDave

    MrDave Cool Member

    12
    0
    Jun 26, 2010
    My original 622 turned 6 years old today. It was one of the first batch of 622's. My second 622 is a refurb unit that I've had for 2 years. Both units are located together in a single cabinet with a 24/7 external cooling fan and I've always treated their HDMI port like it's the most fragile thing in the world (because apparently it is). These 2 622s are the only HiDef DVRs I've had, both are heavily used, and I've been very lucky with both of them. I hope that bragging on them doesn't jinx me.

    Before that, I had a 721 which ran for several years trouble free before it was retired by Dish and replaced by a refurb 522. The 522 died after 18 months, but the harddrive that I salvaged from the retired 721 lives on today as a secondary disk in my desktop computer.
     
  5. Rduce

    Rduce Legend

    337
    9
    May 15, 2008
    My 722K has a set of cooling fans that keep the hard drive temps down to a 95 average with 107 being the highest, so the units own fan only runs hard when it does a reboot, which seems a lot lately with the OTA module issues…

    I also keep it dust free, but it has been tooling along since 09...
     
  6. jack51pine

    jack51pine New Member

    4
    0
    Mar 16, 2012
    We've had our 522 for eight years no problems.
     
  7. kregster

    kregster New Member

    7
    0
    Mar 16, 2012
    my 722s are still going strong after 2+ years with one in a cabinet
     
  8. P Smith

    P Smith Mr. FixAnything

    21,340
    127
    Jul 25, 2002
    W.Mdtrn Sea
    If you'll look at my posts related to overheating internal components include a drive inside 622/722 model (I would say 922 is in same boat), you'll find why.
    And I did propose (and fix my [own] 622 cooling headache) proper design for efficient cooling of 622's internal parts.
    My 622 is running from '07 without any HW problem (I don't want go into countless SW issues now ;) ).
    Recently, ["eSATA for 622"] I found other solution what is not required metal work at all - external box for the drive, see my other thread.
     
  9. shadough

    shadough Icon

    790
    6
    Dec 31, 2006
    I guess I've been fortunate. Havent really had any failures. My 1st dvr, the 721 (purchased Feb. 2003), still works, still use once in a while. 2nd dvr, 510 (purchased spring 2004), still works an still in use. Then I got a 522 as a 'replacement' for the 721, and allthough the 1st unit I got DID have hardrive issues after the 2nd day, once I got a proper replacement, no issues w/ it. It was hauled away for my HD upgrade back in august. Now have 722 an 922 working fine, course they are only a few months old.
     
  10. ryker

    ryker Cool Member

    21
    0
    Aug 22, 2002
    I've had my 501 since 2003 and it has been used constantly. Going to go HD soon.
     
  11. jcrobso

    jcrobso AllStar

    70
    0
    Mar 30, 2005
    My first 622 just died this last weekend, it was installed in 11/2006.
     

Share This Page