1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Have you had to return your HR20 for a replacement?

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by bto4wd, Jul 23, 2007.

Have you had to return your HR20 for a replacement?

  1. I have not had to return my HR20.

    0 vote(s)
    0.0%
  2. I have had to return my HR20 and received a replacement.

    100.0%
Thread Status:
Not open for further replies.
  1. Jul 23, 2007 #1 of 100
    bto4wd

    bto4wd Duplicate User (Account Closed)

    522
    0
    Apr 17, 2007
    I've only had mine for 4 weeks, but wondering how many have had to get replacement units?
     
  2. Jul 23, 2007 #2 of 100
    Michael D'Angelo

    Michael D'Angelo Lifetime Achiever

    10,839
    0
    Oct 20, 2006
    I have had two HR20's since September and added a 3rd in May. I have not had to replace any of them.
     
  3. Jul 23, 2007 #3 of 100
    houskamp

    houskamp Active Member

    8,636
    3
    Sep 14, 2006
    1 but that wasn't the boxes fault ;)
     
  4. Jul 23, 2007 #4 of 100
    Michael D'Angelo

    Michael D'Angelo Lifetime Achiever

    10,839
    0
    Oct 20, 2006
    Yea smoke. :lol:
     
  5. Jul 23, 2007 #5 of 100
    houskamp

    houskamp Active Member

    8,636
    3
    Sep 14, 2006
    Wondered how long that would take :rolleyes:
     
  6. Jul 23, 2007 #6 of 100
    bto4wd

    bto4wd Duplicate User (Account Closed)

    522
    0
    Apr 17, 2007
    So what happened? User Error? :lol:
     
  7. Jul 23, 2007 #7 of 100
    Earl Bonovich

    Earl Bonovich Lifetime Achiever

    30,092
    3
    Nov 15, 2005
    Actually... it was... he connected the power output of the SWM to the input of his HR20.
     
  8. Jul 23, 2007 #8 of 100
    RobertE

    RobertE New Member

    8,024
    0
    Jun 9, 2006
    All three here working just fine. One since Aug/Sep 06, the other two since March. No replacements needed.
     
  9. Jul 23, 2007 #9 of 100
    lwilli201

    lwilli201 Hall Of Fame

    3,189
    28
    Dec 22, 2006
    Missouri
    Have three, 2 from ebay and one from Costco. Have not returned any. I did have an H20 replaced. It was overheating.
     
  10. Jul 23, 2007 #10 of 100
    SoCool

    SoCool Godfather

    304
    0
    Feb 16, 2007
    South West...
    Both of mine good since i got'em
     
  11. Jul 23, 2007 #11 of 100
    me_ccie

    me_ccie New Member

    7
    0
    Apr 13, 2007
    Had to replace mine right after it was installed. It started with a flaky 2nd tuner. After troubleshooting with D* and the whole plug unplug deal the unit would no longer boot up.
     
  12. Jul 23, 2007 #12 of 100
    machavez00

    machavez00 Hall Of Fame

    3,738
    8
    Nov 2, 2006
    Phoenix,...
    I've had mine since Sept. '06
     
  13. Jul 23, 2007 #13 of 100
    houskamp

    houskamp Active Member

    8,636
    3
    Sep 14, 2006
    Your no fun.. was going to let them keep guessing :D
     
  14. Jul 23, 2007 #14 of 100
    Earl Bonovich

    Earl Bonovich Lifetime Achiever

    30,092
    3
    Nov 15, 2005
    The HR20-700 that was used for the review, is 1 year old next week..
    It is still up and running as the primary HR20.

    The HR20-700 that I got shortly after, was shutdown and replaced by the HR20-100...

    None of the three had been replaced
     
  15. Jul 23, 2007 #15 of 100
    chevroletman20042000

    chevroletman20042000 Legend

    105
    0
    May 19, 2007
    i had to return mine about a month after i got it cause tuner 2 was messing up and wasnt getting a signal on two of the sats.
     
  16. Jul 23, 2007 #16 of 100
    jbstix

    jbstix Godfather

    304
    0
    Dec 28, 2005
    I wish you had a few more choices in the poll, since I've had one box replaced twice...

    I had one HR20 replaced *2 times* after the original was stuck at Step 1 of 2....

    Was replaced with another unit, that only lasted about a week, then it crapped out, thus replaced 2 times.

    My other original unit - has been performing fine since day one. fingers crossed!
     
  17. Jul 23, 2007 #17 of 100
    davring

    davring Hall Of Fame

    6,417
    1
    Jan 13, 2007
    Since November and only one RBR, I think I caused it though.
     
  18. Jul 23, 2007 #18 of 100
    houskamp

    houskamp Active Member

    8,636
    3
    Sep 14, 2006
    Oh by the way I have 2 perfectly running units here for several months..
     
  19. Jul 23, 2007 #19 of 100
    Gary Toma

    Gary Toma UNIX DBSTalk Club

    2,306
    130
    Mar 22, 2006
    Back in September, 2006, I had two HR20's replaced. The first was great -- except HDMI didn't work, just got a scrambled screen. The second was great -- except the OTA capability wasn't there.

    Now the third HR20 -- has been with me for ten months now and has performed with very few problems.
     
  20. Jul 23, 2007 #20 of 100
    Doug Brott

    Doug Brott Lifetime Achiever DBSTalk Club

    28,939
    72
    Jul 12, 2006
    Los Angeles
    I wish there were more choices, too as I have two boxes since last September with no replacements.

    Perhaps the question could have been directed toward more recent times. We (milominderbinder2 and myself) developed a Site Survey early this year that identified a number of issues that were distinctly related to the software. CSRs where diligently replacing HR20s from October through January for issues that were unrelated to the actual HR20 hardware. Yes, they were problems, but swapping the hardware did nothing other than cost DIRECTV money - it didn't solve the customer's problem.

    I'm sure the return rate was high prior to this time period. Since the software works much better now, your poll should really be since April, or perhaps as early as March.
     
Thread Status:
Not open for further replies.

Share This Page