1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the new DBSTalk community platform. We have recently migrated to a community platform called Xenfono and hope you will find this change to your liking. There are some differences, but for the most part, if you just post and read, that will all be the same. If you have questions, please post them in the Forum Support area. Thanks!

HR20-700 Won't power up at all.

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by Scooter22, Jan 31, 2010.

  1. Scooter22

    Scooter22 Legend

    192
    0
    Jun 22, 2007
    Well, now that we have MRV and I don't need redundant DVRs, I decided to move one of the DVRs from our great room to a guest room. This unit has been off for months because my stereo receiver has been in the shop (I use it for HDMI switching and wasn't important for me to have that HR20 working).
    However, now it won't start up - at all. No lights, no sounds, nothing. I tried different outlets and power cords, btw.

    I think I may have seen this happen on my HR21 and there was a trick to convince the thing to power up.. Something like unplug the network cable and plug it back in when you boot it up <shrug>

    Do you have any ideas, gang?

    Luckily I have the warranty plan, but I thought I'd at least give it the good old college try first. :)
     
  2. hdtvfan0001

    hdtvfan0001 DIRECTV A-Team

    32,456
    258
    Jul 28, 2004
    Try unplugging the power from the unit, let it sit for 20 minutes, and then plug in the power again (and press the power on button thereafter).
     
  3. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    Can you hear the hard drive spinning up?
     
  4. Scooter22

    Scooter22 Legend

    192
    0
    Jun 22, 2007
    I'm trying that now, thanks. :)
     
  5. Scooter22

    Scooter22 Legend

    192
    0
    Jun 22, 2007
    Nope, it doesn't make any sounds.
     
  6. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    Almost sounds like the power supply is bricked, or the power cord isnt making contact with the units power jack pins. When its plugged in, do you see any LEDs inside lit up?
     
  7. Scooter22

    Scooter22 Legend

    192
    0
    Jun 22, 2007
    Nope, nothing. I tried a new cord and outlet. My guess is a dead power supply also.

    Thanks. :)
     
  8. Rabushka

    Rabushka Legend

    165
    0
    Dec 21, 2007
    Hit the red reset button and then the power button immediately. Wait 5 minutes and see if it doesn't power up. If no, press the power button and wait 3 minutes. If this fails, the unit is dead.
     
  9. Scooter22

    Scooter22 Legend

    192
    0
    Jun 22, 2007
    It's dead... DIRECTV is sending me a new one.

    Thanks for all of your help!! :)
     

Share This Page