1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HR20 Media Sharing How-to?

Discussion in 'DIRECTV Tips and Resources' started by XPLORx4, Jan 24, 2008.

Thread Status:
Not open for further replies.
  1. SledgeHammer

    SledgeHammer Icon

    1,788
    98
    Dec 28, 2007
    Ah, missed that part :)... So you are able to telnet to the HR20 on the Viiv port... hmm...

    Do you have any firewall/IDS/etc. software on your PC?
     
  2. mjbueche

    mjbueche Mentor

    46
    0
    Jan 14, 2008
    I have the standard Windows XP firewall and tried with off and on (expections when on) and it has not worked as of yet. I am able to run telnet to the HR20 and get back the error posted.
     
  3. JMII

    JMII Legend

    178
    1
    Jan 19, 2008
    South Florida
    Report back if you ever get Media Share working with this particular router, I gave up and returned mine thus I'm very curious to learn if it's hardware or software (configuration) problem in the end.
     
  4. mjbueche

    mjbueche Mentor

    46
    0
    Jan 14, 2008
    Did you get this working with a new router? If so what router did you buy?
     
  5. JMII

    JMII Legend

    178
    1
    Jan 19, 2008
    South Florida
    I ordered a NetGear router (forget which model #) but it hasn't arrived yet. Once it does I'll post the model # and results. Just keep in mine I've got a Mac so my firewall and applications are different so who knows what effect (if any) that has on the situation.

    Might try using static IP#s too, it shouldn't make a difference but we've found using static #s where I work makes trouble shooting alot easier.
     
  6. Spanky_Partain

    Spanky_Partain Active Member

    5,500
    0
    Dec 7, 2006
    There is some known working hardware routers listed in the thread in my signature for network help.

    You may have seen it or may not recall seeing it, look for the title "Hardware Wireless Routers for connection to your home network". As the title implies, they are ALL wireless routers, but you do not have to turn the wireless feature on.
     
  7. LarryS

    LarryS Legend

    134
    0
    Apr 22, 2002
    For several weeks now media share refused to show up on my HR20 after being there for several months. I tried all types of resets and firewall changes to no avail. I also tried using TVersity. Several days went by with no media share on the menu. Now all of a sudden its back with no change on my part other than my PC goes off each night while the HR20 stays on. Go figure. And it's the TVersity link that's working I see no sign of the WMP11 data although I have both active.

    Environment: Windows XP with WMP11, TVersity, MS LiveOneCare
    Netgear WGR614, Airlink WP431W access point, Wireless G with WPA security
    HR20-700 networked via static IP
     
  8. JMII

    JMII Legend

    178
    1
    Jan 19, 2008
    South Florida
    Are those listed confirmed to work with Media Share or just On Demand?

    For me On Demand worked fine but Media Share did not. My guess is that the way various routers handle UPnP activity might be very different and thus certain routers may not pass the requests properly. Just grasping at straws here :confused:
     
  9. Spanky_Partain

    Spanky_Partain Active Member

    5,500
    0
    Dec 7, 2006
    Those are verified to work on media share. VOD works if an internet connection is working and Directv has enabled your account for it.
     
  10. JMII

    JMII Legend

    178
    1
    Jan 19, 2008
    South Florida
    I just got a NetGear DG834GT and guess what... it doesn't work either. Guess I'll try a few more things on my computer then if all else fails I'll buy one of the routers in the list. This is getting rather silly :nono2:
     
  11. bradlej

    bradlej Cool Member

    16
    0
    Jan 27, 2008
    JMII - Not sure if this will help, but I did just get this running this morning with the following hardware configuration, which might give you some other hardware to look at.

    HR20-100 -> Linksys WRT54G with DD-WRT firmware client bridge -> Netgear WGR614v6 -> PC

    Now, I did have a few issues getting this to work although I did already have media share working with my PS3 so I knew my base setup was good.

    1) After getting the network connected on my HR20 last night DoD showed up this morning, but no media share
    2) I went into WMP11 and there was no unknown device besides my PS3
    3) In reading some posts I did not have any of the errors in the system log as indicated by other posts
    4) I did find the posts about unplugging the HR20 so I unplugged my HR20 for about 30 seconds and then plugged it back in, DoD came back up again, but still no media share. I then checked my WMP11 and after the reboot of the HR20 a new unknown device showed up in WMP11 with a yellow triangle with an exclamation point
    5) I still didn't have media share on HR20 and after some messing around, I realized I had to click on the unknown device in WMP11 and then click the "Allow" pushbutton
    6) After clicking allow and waiting about 5 minutes, the "Music, Photos & More" menu item appeared and is now working.

    Other thoughts, though if you've disabled the firewall this might not help. I use Zone Alarm on my WMP11 PC and I had to setup my DCHP pool and my static IPs (PS3 and HR20) as trusted systems or UPnP didn't work.
     
  12. JMII

    JMII Legend

    178
    1
    Jan 19, 2008
    South Florida
    Thanks for the info.
     
  13. tvl76

    tvl76 AllStar

    53
    0
    Dec 7, 2006
    Can the menu structure, shown on the Media Share screen on my TV, be customized ?
     
  14. Michael D'Angelo

    Michael D'Angelo Lifetime Achiever

    10,839
    0
    Oct 20, 2006
    no
     
  15. johnbrain

    johnbrain Cool Member

    15
    0
    Nov 3, 2007
    I finallygot WMP11 to connect with my HR20. I set up media sharing and folders to watch in WMP11. I run downstairs and am able to see the artists, songs etc but the system isn't actaully able to play them then tries to "grab" the content andfails.

    I am using Vista. Is there a sharing stepI am missing? Should I keep my content in the Public folder?

    help.

    There are so many threads I couldn't sift through them all.
     
  16. itzme

    itzme Hall Of Fame

    1,650
    21
    Jan 17, 2008
     
Thread Status:
Not open for further replies.

Share This Page