1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HR21 and gray screen

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by jhillestad, Aug 17, 2008.

  1. jhillestad

    jhillestad Godfather

    425
    0
    Jan 13, 2007
    I have a new HR21 that about once a week will just get a gray screen.

    For example:

    Everything will be normal... I'll change the channel and the screen turns gray the blue info screen comes up like normal but then it goes away and it stays gray. For fun I went into the menu screen and told it to do a sat signal check where it then proceeds to just sit at the menu screen like its brain dead. A reset of course cures the problem but this is annoying because it happens about once a week and recordings will either be gray or just not there at all.

    Should I try a reformat or just call support and off course they will tell me to reset it and it will work and they will tell me its fixed and the annoyance will continue...

    My other HR21 works great and I have a HR20 on the same sat dish so I know its not the sat.
     
  2. K4SMX

    K4SMX Hall Of Fame

    3,433
    0
    May 19, 2007
    More info please: external multi-switch, other HD receivers doing the same thing or not, dish type (AT-9 or Slimline), length of coax runs, signals strength levels on 99(c) and 103(c)?
     
  3. wideglide36

    wideglide36 Legend

    155
    1
    Jan 14, 2004
    Hey guys,

    I have the exact same problem as the OP.

    HR21-100
    Slimline dish
    Zinwell WB68 switch
    No other HD receivers
    coax runs no more than 50 feet
    Signal strength is in the high 80's to low 90's

    Just had this installed a few weeks ago and this problem happens exactly as the OP stated.

    Thanks
     
  4. kw2957

    kw2957 Godfather

    318
    0
    Apr 4, 2008
    I had the same problem when I originally upgraded back in the beginning of July, but it seemed to go away after downloading 0x255. Prior to that it was 0x235.

    Are you guys on the latest NR?
     
  5. wideglide36

    wideglide36 Legend

    155
    1
    Jan 14, 2004
    First off, my apologies for horning in on the OP's thread.

    As to your comment about the latest upgrade. I also have the 0x255 and it upgraded on 8-5. I have had these problems since after the upgrade.

    What is NR?

    I was checking some settings and saw that the internal temp was 113F.

    Is that normal or could that be part of the problem?

    Thanks
     
  6. The Merg

    The Merg 1*

    10,289
    35
    Jun 24, 2007
    Northern VA
    NR is referring to a National Release of the software as opposed to a CE Release (Cutting Edge or Beta Release).

    A temp of 113 degrees is probably about right.

    - Merg
     
  7. K4SMX

    K4SMX Hall Of Fame

    3,433
    0
    May 19, 2007
    When experiencing any reception problems not obviously related to signal strength, it's always a good first step to bypass any multi-switch with double-female "barrel" adapters, and temporarily connect your HR straight to any two of the dish lines. Also, a cold reboot with a receiver which has been unplugged all day or overnight sometimes clears out HR software errors which aren't cured by a standard menu-based Restart Recorder or an RBR. If neither of those suggestions identifies your problem, there's more things to check out.
     
  8. rudeney

    rudeney Hall Of Fame

    4,266
    1
    May 28, 2007
    I had almost the exact same thing happen yesterday. It was a bad connector at the multiswitch.
     
  9. jhillestad

    jhillestad Godfather

    425
    0
    Jan 13, 2007
    No multiswitch its hooked straight to the Slimline. The Hr10 that was hooked never had any of these problems.

    Its running version 255.

    The problem will only service when I change the channel.... it has never just turned gray while watching... its like it goes brain dead or times out and just shows the gray screen. Normally you only see the gray screen for a few seconds while changing channels so when this happens its like its waiting for something... but the sat signal is fine because the other receiver is fine.

    It takes a reset and all will be fine.

    How do I get beta firmware ? can I force a different version of software to test ?

    Otherwise I am just gonna press the red reset every day until I get frustrated enough to call DTV and get my unit replaced....
     
  10. K4SMX

    K4SMX Hall Of Fame

    3,433
    0
    May 19, 2007
    Instead of doing a RBR, try doing a satellite signal strength test while on a "gray screen."

    Menu button > Parental, Fav's & Setup > System Setup > Satellite > View Signal Strength

    Be sure to navigate over to the 103(c) satellite and check tuners 1 & 2. Then select "Done" and see if you still have a gray screen. Sometimes the receiver cycling through all the tp's on this menu page causes the missing channel to return. If this works for you, it's a lot faster than doing a RBR. It obviously doesn't prevent this problem from effecting pre-scheduled recordings, however.
     
  11. jhillestad

    jhillestad Godfather

    425
    0
    Jan 13, 2007
    I tried that - when I get to the test signal strength page it just sits there like its brain dead. It does not test or give info or even error messages.. it just sits there.

    Weird huh ?
     
  12. rudeney

    rudeney Hall Of Fame

    4,266
    1
    May 28, 2007
    That weird behavior is exactly what I got when tuner 1 was disconnected. I could get the guide, but when I went to Menu (to check signal strengths) it was ridiculously slow.
     
  13. gordon1fan

    gordon1fan AllStar

    90
    0
    Jun 27, 2007
    Talladega,...
    This same problem as happen to me two times within a week. I have the HR21-100 with the 255 updates. Come on DIRECTV, hire TiVo back because you don't seem to know what the hell you are doing! :(
     
  14. rudeney

    rudeney Hall Of Fame

    4,266
    1
    May 28, 2007
    I still don’t believe this problem is specifically caused by bugs in the HR2x’s software. I believe this is a signal problem. If you have no signal issues, you’d never see the gray screen, but a problem either with alignment, a multiswitch, LNB or cabling is preventing the tuner from locking onto the desired signal will cause it. When that happens, the HR2x is not handling it very gracefully. Instead of a user-friendly message saying “no signal on Tuner #x, satellite xxx”, the screen goes gray and the receiver “busies itself” with something that causes it to become very sluggish and almost non-responsive.

    The slimline has a built-in multiswitch in the LNB. You could still have a cabling/connection issue or even a bad LNB causing intermittent signal problems. As for the HR10 not having the problem, it may handle signaling issue much better. Maybe it’s something specific to the MPEG4 decoding algorithms that make the HR2x more sensitive to signal failures.
     
  15. repoman75

    repoman75 Legend

    118
    0
    Jan 27, 2008
    I get a grey screen on my recordings now and then... but the sound is there. Basically, if I wait for like 2 minutes and try again, the video comes on.
     
  16. vurbano

    vurbano Godfather

    295
    0
    May 15, 2004
    It happened to me once the other day too.
    HR21-100 with AM21
    slimeline dish
    Zinwell WB68
    Latest CE frimware

    also have an HR20-100 that I havent seen the problem on.
     
  17. richiephx

    richiephx Godfather

    335
    1
    Jan 18, 2006
    I have the same problem. My signal strength is very good. My gut reaction is, that it is a software issue. Seems too much of a coincidence that more and more people are having this problem. My experience with E* is that when they upgraded the software, a new problem popped up. I think this is the case with D* too. We'll see what happens with the next software upgrade.
     
  18. thestaton

    thestaton Legend

    233
    0
    Aug 14, 2008
    I'm having the same problem. New install today and I was just flipping channels when I got the grey screen. Signal strengths are great, no multi switch. When it happens the only remedy is to just reset it :(
     
  19. K4SMX

    K4SMX Hall Of Fame

    3,433
    0
    May 19, 2007
    See post #10 upthread. Is this also an HR21-100?
     
  20. thestaton

    thestaton Legend

    233
    0
    Aug 14, 2008
    Yes. HR21-100. I couldn't do a signal test when it locked it, it just sits there until you reset it.
     

Share This Page