1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is there an H25 Forum?

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by lipcrkr, Jan 13, 2013.

  1. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    ........or will this do? I have an H25 and everything was fine but i got a new A/V receiver and can't remember how it was hooked up. Now i can't get DirecTV because the Sat box won't come on. My Sat box is connected via HDMI to the HDMI on my TV? Or should it be from Sat box to the A/V receiver? I've tried everything but the DirecTV box doesn't come on. Any suggestions or can you guys point me in the right direction. Like i said, not matter what HDMI connection i'm using it still no power on the Sat box. Thanks.
     
  2. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    HDMI connection wont affect power to the sat box, unless you plugged the sat box power brick into the AMPs aux power plug. Plug the H25 power supply into a wall outlet, check the brick to make sure all connections are tight, and the H25 to make sure its plugged in good. Once its running, if you amp has HMDI input, run the H25 into the Amp that way, so you dont have to switch TV inputs every time you watch some other device.
     
  3. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    Thanks. Didn't work. The H25 still doesn't power on. The main plus is in the wall, my A/V receiver is plugged into the wall (like it says), and the brick is in the power pack. For some reason the H25 is not connecting.
     
  4. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    Is it not powering on at all, or is it coming on and you just arent getting video out? Light on the front not lighting up?
     
  5. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    No light. It's not even recognizing Directv, just my HDMI 1/DVI on my computer.
     
  6. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    If there is no light on the H25, take it into another room and plug it into another outlet and make sure the power supply isnt bad.
     
  7. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    I'll try, but it's not the power supply persay, because it was fine earlier today. But i'll try it.
     
  8. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    Ok. I cant think of any reason why a wall outlet would stop working though, unless somehow the breaker got tripped. If it works in another outlet, then we can figure out why it stopped working and go from there.
     
  9. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    Well, so much for that. I can't get the plug out from the back of the H25 box. If i call DirecTV will they come out soon, like a couple of days? Cause i can't watch my HDTV without the box.
     
  10. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    That I do not know. Is the plug melted? Cant take the H25 and power brick out without unplugging it from the H25?
     
  11. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    Yeah, i can do it. I just have to untangle all the wires, it may take awhile. I had a minor stroke last year so i'm not as mobile as i once was. Thank you. I'll post my results.
     
  12. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    Sorry to hear that. Awaiting your results. Hopefully we can get it working for you.
     
  13. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,679
    348
    Dec 9, 2006
    IIRC where the cord connects is a green LED to show the H25 is receiving power.
     
  14. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    I tried it again and nothing. Must be dead?
     
  15. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    No green LED or anything? Sounds like you need a service call. Hopefully they can get to you pretty quick. Dont know how long the service takes, think it probably depends on your location. Id give them a call. Cant fix it if we cant get it to power on.
     
  16. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    Nothing is showing in green or blue. Unless i missed something. The cords are all connected.
     
  17. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    Sounds like a bad power supply to me, but if you cant unplug it from the unit, I dont know of any option except having them swap the unit.
     
  18. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    The frustrating thing is apparently when i tried the A/V receiver earlier, it apparently did something when i tried to re-connect it. In other words.........it was my fault.....LOL. Thanks for hanging in there. I'll make an appointment.
     
  19. Davenlr

    Davenlr Geek til I die

    9,136
    27
    Sep 16, 2006
    Ok. Good luck. Hope you get a rapid repair.
     
  20. lipcrkr

    lipcrkr Legend

    331
    6
    Apr 27, 2012
    Thanks
     

Share This Page