1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Network - Yes, Internet - No (new twist)

Discussion in 'DIRECTV Tips and Resources' started by mrants, Sep 25, 2007.

Thread Status:
Not open for further replies.
  1. mrants

    mrants New Member

    4
    0
    Sep 24, 2007
    For the past couple of days I have been trolling the posts trying to see if anyone has had the same experience as I am having.

    Here is my story. Verified good cable connected directly to my 2Wire router provided by AT&T. Using DHCP on HR20 and I get the 169.x.x.x address with 255.255.0.0 subnet, no gateway no DNS (it even says Yes to the network at this point). Although if I look at the 2wire it has assigned an address to the HR20. So I force the static address on the HR20 and I get Yes to the Network but No to the Internet.

    I cannot telnet to the HR20, but the link lights are on. When I attempt to ping it (i know it won't respond) I see the link light flash for each ping. There is activity on both sides of the link but it never successfully connects on the HR20 side.

    I have tried two different networking setups on the 2Wire:
    network 192.168.1.x
    subnet 255.255.255.0
    DNS/Gateway 192.168.1.254

    and
    172.16.x.x
    255.255.0.0
    172.16.0.1

    When I changed the network setup the 2Wire handed out a new address to the HR20, but the HR20 never seems to accept it.

    Any ideas?

    Thanks for reading, even more thanks for an answer :)
     
  2. haggis444

    haggis444 Legend

    139
    0
    Jan 20, 2004
    More info might be helpful:

    1) How many other devices do you have on your network
    2) Assuming you have a Windows box, can you go to a command prompt and run the following:

    ipconfig /all

    and copy and paste the results into this thread

    3) Does the 2wire have a switch built in. If not what are you using as your switch.
    4) Can you default the 2wire and try again? After that please provide #2 above as well.
     
  3. mrants

    mrants New Member

    4
    0
    Sep 24, 2007
    I have my main home computer connected to the 2wire and I often have my work laptop connected to it as well as other computers every once and a while. It has a switch built into it. Off the top of my head an ipconfig /all will produce roughly the following:

    DHCP enabled yes
    IP 172.16.1.33
    Subnet Mask 255.255.0.0
    Default Gateway 172.16.0.1
    DNS Server 172.16.0.1

    I have rebooted everything multiple times. I have left everything unplugged multiple times for extend periods of time. I changed the addressing scheme on the router to force it to hand out new IP's. It attempted to hand out the IP to the HR20, but the HR20 never "took" it. The router shows the HR20 is a connected device, but obviously the HR20 doesn't see it that way.

    No other computer has ever had a problem getting an IP. I could reset the 2wire to the default setup, which is the 192.168.1.x scheme, but I am not at home right now, so that has to wait. If I were to do that the ipconfig \all would say:

    DHCP enabled yes
    IP 192.168.1.67
    Subnet Mask 255.255.255.0
    Default Gateway 192.168.1.254
    DNS Server 192.168.1.254

    My biggest concern is that the router is handing out the address so obviously it is making the request, the router is responding, but the HR20 is not accepting it.
     
  4. Spanky_Partain

    Spanky_Partain Active Member

    5,500
    0
    Dec 7, 2006
    Looks like your HR20 is not connected properly to the 2-Wire. Check/replace the CAT5e cable. If you are using the USB connection on the HR20 and the 2-wire, that will NOT work. You will need to get a switch, unplug the ethernet connection from the PC to the 2-Wire, plug a Cat5e cable from the switch into the 2-wire where you just removed the PC connection from, plug the PC into the switch, then run a Cat5e cable to the HR20.

    To set the HR20 to accept DHCP again after you have tried static, you must go into the advanced settings of the network and tell it to restore defaults. Then it will then be set to do DHCP again. If you cannot get it to work with DHCP ,then look at the range of the DHCP you have avaliable on the 2-Wire. You may have run out of DHCP addresses and need to bump it up. If that is not the case then look at the DHCP range, say the IP addresses start at 172.16.0.100 and you have 10 as a max address limit then that would include 172.16.0.100 - 172.16.0.109. You could then assign a static IP scheme to the HR20 using the following...

    IP Address 172.16.0.200
    Subnet Mask 255.255.255.0
    DNS 172.16.0.1
    Gateway 172.16.0.1

    Then everything should be fine.
     
  5. mrants

    mrants New Member

    4
    0
    Sep 24, 2007
    I am not using the USB port. I checked the cable against my laptop and it received an address. I tried to statically address it and it still wouldn't work. I am running out of ideas. :(
     
  6. jbarnes7952

    jbarnes7952 New Member

    1
    0
    Sep 26, 2007
    I'm guessing your DNS address is incorrect.
     
  7. Spanky_Partain

    Spanky_Partain Active Member

    5,500
    0
    Dec 7, 2006
    I am too!

    I am not very familiar with the 2-Wire product except that I have one in the shed from my mother-in-law. So I will assume you have a CAT5 network cable running from the HR20 to the 2-wire router and link lights are apparent on both ends. Assign an IP address to the HR20 as suggested earlier.

    Here is a check you can try.

    Open up Start => Run
    type in "command" and press return.

    This will open a command window.

    a.b.c.d = your HR20 IP address
    After the connection is made, the screen will appear unusable. You must wait for the telnet session to timeout and the result of the connection should be displayed as seen below.

    c:\telnet a.b.c.d 49152


    HTTP/1.1 400 Bad Request
    SERVER: Linux/2.4.29-uclibc-brcm, UPnP/1.0 JetHead SDK for UPnP devices /1.0 DLN
    ADOC/1.00 INTEL_NMPR/2.1
    CONNECTION: close
    CONTENT-LENGTH: 50
    CONTENT-TYPE: text/html

    <html><body><h1>400 Bad Request</h1></body></html>

    Connection to host lost.

    c:\> exit
     
  8. mrants

    mrants New Member

    4
    0
    Sep 24, 2007
    OK, it's a bad cable sort of. I tested the cable before hand and it worked on my laptop. I dragged my router to the family room hooked up a shorter cable to the HR20 and what do you know, I get fully connected. So I figure what's the deal. I hook up the original 75' cable to my laptop again. I am able to VPN to work and RDP my desktop at work with no problems.

    Apparently the NIC in the HR20 is a little more sensative. I have noticed the same thing with the Infrant ReadyNAS NV+. Cables that work otherwise do no work with it. We have about 120 of the Infrant units at work and 10% of them needed to have different cables. Those are Linux based, I am assuming the HR20s are as well? Maybe it is something with the Linux driver that isn't as forgiving? The cable has also been tested with a cable tester and it is fine from that aspect as well. I guess I have to buy or build a new cable. Anyone know where to get a good and cheap 75' cable? This time I will test it running it across the floor rather than fishing it into the basement, tacking it to the joists, and fishing it to the office. Just bugs me that it works fine with my laptop.
     
  9. S1nned

    S1nned AllStar

    58
    0
    Sep 7, 2007
  10. Spanky_Partain

    Spanky_Partain Active Member

    5,500
    0
    Dec 7, 2006
    Glad to hear it was the cable.
    http://monoprice.com/home/index.asp
     
  11. dardia

    dardia Cool Member

    14
    0
    Aug 19, 2006
    I have a similar problem, but it's not the cable. Here's my details.

    1) I live in a large condo building with its own LAN. It hands out IP addresses in the 192.168.1.x range. My router receives an address in 192.168.1.x range over the WAN port, and then hands out 192.168.147.x IP addresses to my:

    Computer = 192.168.147.2
    HR20 = 192.168.147.3

    2) Router has the wireless radio enabled. This is how the computer is getting its IP address. The wireless setting has WPA protection enabled. The computer is able to browse the internet just fine and has full network abilities.

    3) HR20 setup was done refresh via Restore Defaults. Automatically picks up the address given above and the proper subnet mask and default gateway. Internet connection comes back Unconnected though.

    4) Equipment details
    Netgear WGR614v5 (firmware version 1.09)
    HR20-700 (0x18a) w/ OTA antenna attached
    PC Running Windows XP w/ WMP11

    Any thoughts?
     
  12. Spanky_Partain

    Spanky_Partain Active Member

    5,500
    0
    Dec 7, 2006
    Is the HR20 using a wireless device to connect to the router or is it hard wired with a CAT5 cable?

    If wireless, check the settings ont the wireless portion of the router and make sure that nothing is blocking the connetcion. Mine has a setting to not allow wireless clients to the internet.
     
  13. dardia

    dardia Cool Member

    14
    0
    Aug 19, 2006
    Forgot that detail.

    The computer is connecting wirelessly, but the HR20 is connecting via a short ethernet cable.

    The router's admin page shows the HR20 in the connected devices list. I have no port forwarding/blocking enabled.
     
  14. Spanky_Partain

    Spanky_Partain Active Member

    5,500
    0
    Dec 7, 2006
    The only other thing I can suggest is what a couple of other people had to do to get their HR20 on the network was to plug the HR20(s) into a seperrate switch the uplink that switch to the router. In their scenario they also had a lot of stuff on the network, such as cameras, etc.

    I know it does not make much since to me either, but that is what they did to get the HR20 onto the internet.

    I would still try a cable swap, just in case. I have no other ideas, especially when it is a hardwire install.
     
  15. Stuart Sweet

    Stuart Sweet The Shadow Knows!

    37,060
    287
    Jun 18, 2006
    I certainly can't add anything more than Mark, I defer to his wisdom, but I will point out some advice I got a long time ago that has proven true, over and over:

    98% of the problem with everything is the cable.
     
Thread Status:
Not open for further replies.

Share This Page