1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with Sportster

Discussion in 'Sirius XM General Discussion' started by cyclone27, Apr 14, 2008.

  1. cyclone27

    cyclone27 AllStar

    71
    1
    Feb 1, 2006
    I have the first model of the Sportster in my car & I am wondering if it is time for a new radio.

    I have probably had it for about 3 years & had never had any reception problems. However, lately the radio works fine for about 5-10 minutes. Then the sounds just goes off. The usual 'Acquiring Signal' does not come up on the screen. The screen is still showing the song & there is just no sound.

    Then when I turn it off & then back on, it the says 'Acquiring Signal' & never does pick up a signal.

    The antenna does not appear to be damaged.

    Has anyone had this similar problem? Any suggestions or is it time for a new radio?

    Thanks.
     
  2. nhoJ

    nhoJ Mentor

    48
    0
    Jul 6, 2007
    Did the first Sportster have a docking station? If so, see if you can try a different dock. You could always try a different antenna also. Otherwise, you were just looking for an excuse to get a new Sportster 5 or a Starmate 4. Keep in mind the FM Mods on the newer models are not as strong as the old receivers, so you may need an FM adapter to hook up with your antenna.
     
  3. Behmer01655

    Behmer01655 New Member

    9
    0
    Jan 17, 2006
    I had the same problem over a year ago. I had to buy a new receiver. I got a Starmate 4 and I've never been happier.
     
  4. captcab_99

    captcab_99 Cool Member

    15
    0
    Feb 3, 2007
    Turns out the old Sportsters are prone to overheat and mine did exactly that. It started when I bought the boombox and the heat had a hard time escaping from the rear. Sirius sold me a new sportster replay for something like $40 and gave me 3-4 months free so it all worked out.
     

Share This Page