1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TIVO SW version 6.4

Discussion in 'DIRECTV DVR with TiVo Discussion' started by wahooq, May 2, 2012.

  1. litzdog911

    litzdog911 Well-Known Member

    12,204
    63
    Jun 23, 2004
    Mill Creek, WA
    Great to hear. Enjoy!
     
  2. ymaps007

    ymaps007 New Member

    1
    0
    Jun 30, 2012

    • Your Tivo model number DVR40?
    • What Tivo software version do you currently have? 6.3e-01-2-121
    • Your Tivo Service Number (TSN)? .... Should be in the system information display. 321-0001-302A-DF64
    • Does your Tivo have any "modifications" to its original software? No Mods, all stock
    • TV brand & model number? TCL 32" LCD
    • How is your Tivo connected to your TV RCA connections?
    • If you have an HR10-250 HD Tivo, what video output resolution(s) are you using? n/a
     
  3. Jul 5, 2012 #103 of 122
    stevecon

    stevecon AllStar

    85
    0
    Sep 5, 2006
    Boston
    I've just completed reading this thread with the hopes of learning why (and correcting) my 5 DirecTivos lost local stations. I ran a script of them *years* ago (I believe it was called "zipper") to enable MRV, etc.

    I have forced calls on several of them, on different phone lines, different dialer options, with different phone cords; but none ever complete. I get "failed negotiating", "line busy", etc. type messages when calling in. I get the same results with different dial in numbers - even when I choose the (800) number.

    I see that I need to toggle (or remove?) the "upgradesoftware=false" switch in order to trigger the upgrade when the call is made - but I fear that even with the setting changed - I will still not be able to complete the call; just as before. I'm not even really interested in hacking the Tivo any longer if version 6.4x is unable to deliver MRV or streaming from a PC for me.

    Any thoughts would be appreciated. Thanks!
     
  4. Jul 6, 2012 #104 of 122
    sbl

    sbl Icon DBSTalk Club

    897
    3
    Jul 21, 2007
    6.4 cannot do MRV, but it can do extraction and insertion and "MovieLoader" works. You may want to see if the 6.4 slices are in your box's MFS database. If so, you could manually do the upgrade or buy the "Slicer" program to do it.
     
  5. Jul 6, 2012 #105 of 122
    P Smith

    P Smith Mr. FixAnything

    21,608
    143
    Jul 25, 2002
    W.Mdtrn Sea
    Would you provide details how to ?
     
  6. Jul 6, 2012 #106 of 122
    sbl

    sbl Icon DBSTalk Club

    897
    3
    Jul 21, 2007
    As I no longer have an appropriate system active, I have to go from memory. This requires that you have previously "hacked" your box to provide Telnet access and have TiVoWebPlus installed. Open TiVoWebPlus and select the option that lets you look at the MFS database. Find the entry for SwSystem. You should see a bunch of entries there with TiVo version numbers and the three-digit TSN prefix for various boxes. Do you see a 6.4 entry there that matches your TSN prefix? If so, you have the slices.

    Then you would generally follow the instructions here , though you'd need to make changes for the different version. Elsewhere in that forum are instructions for patching the TiVo software to disable encryption, etc. I don't think the "add63" script mentioned in step 1 of that page will be helpful.

    If you run into trouble here, I can't help you. I can only tell you that I have successfully followed this process at least half a dozen times over the years.
     
  7. Jul 6, 2012 #107 of 122
    P Smith

    P Smith Mr. FixAnything

    21,608
    143
    Jul 25, 2002
    W.Mdtrn Sea
    I have regular box, no hacks on it ...
     
  8. Jul 6, 2012 #108 of 122
    Shades228

    Shades228 DaBears

    6,081
    45
    Mar 18, 2008
    Are you trying to get 6.4 active on your TiVo or are you just wanting to see if the slices are there?
     
  9. Jul 6, 2012 #109 of 122
    P Smith

    P Smith Mr. FixAnything

    21,608
    143
    Jul 25, 2002
    W.Mdtrn Sea
    Just to see if TiVo's drive has all the slices and its version, not what is running.
     
  10. Jul 6, 2012 #110 of 122
    Shades228

    Shades228 DaBears

    6,081
    45
    Mar 18, 2008
    My bet is that 6.4 slices are on all of the TiVo's by now but the ones not on it are due to something else. Without hacking it you may be able to pull the drive and then take a look on a linux box.
     
  11. Jul 7, 2012 #111 of 122
    P Smith

    P Smith Mr. FixAnything

    21,608
    143
    Jul 25, 2002
    W.Mdtrn Sea
    I did pull it, not sure if Linux/Ubuntu could mount the"MFS" type of partitions.
     
  12. cricketrulez

    cricketrulez New Member

    4
    0
    Jul 18, 2012
    Hi,

    I have a HDVR2 Zippered and networked on 6.2. I lost my locals and was told to upgrade to 6.4a.

    I got the slices from Lou (tivoupgrade on tivocimmunity)

    I bought the slicer from DVRupgrade.

    However when I try to install I get the following error message

    MJTIVO1-bash# ./slicer 6.4a-01-2-151
    Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!


    If you are able, could you please help me with this!

    thanks
     
  13. Diana C

    Diana C Hall Of Fame DBSTalk Club

    2,117
    293
    Mar 30, 2007
    New Jersey
    Did you check to see if the slices were downloaded? They come via satellite so I would be very surprised if they were not there already. I'm pretty sure the Slicer works from the TiVo database, so just copying the slices onto the drive may not work.
     
  14. Diana C

    Diana C Hall Of Fame DBSTalk Club

    2,117
    293
    Mar 30, 2007
    New Jersey
    The zipper did not disable dial in, but PTVNet did. I don't recall the exact mechanism they used, but the result was that the TiVo modem would connect, but fail during negotiation.

    It might be easier to just buy a 6.4 clean image from DVR Upgrade. It's $39.99 for a download.
     
  15. cricketrulez

    cricketrulez New Member

    4
    0
    Jul 18, 2012
    Yes, I got the slices from from "lou" at Tivo community forum. It was directly downloaded to my tivo via telnet.

    I forgot to mention that I unzipped the slicer on my ubuntu box and then uploaded it to my tivo. Could this the problem?

    Thanks for your help
     
  16. Diana C

    Diana C Hall Of Fame DBSTalk Club

    2,117
    293
    Mar 30, 2007
    New Jersey
    Could be...I don't know enough about the Slicer to be sure. I know DVRUpgrade (Lou Jacob) hasn't been supporting the software products for quite some time. The way the Slicer was meant to be used was to install software slices that had been downloaded to the Tivo normally but, for whatever reason, were not installed automatically (usually because the box was hacked and upgrades were disabled).
     
  17. volkl

    volkl Legend

    129
    1
    Jun 17, 2007
    The error message could be caused by a conflict in the two sets of slices existing on the drive. It would be best to have someone clean it up.

    I draw your attention to this thread --- www.dbstalk.com/showthread.php?t=143761&page=2

    Many people back in 2008 had all the slices, but the Tivo operated dialup servers were not working during the service call to detect the 6.4a slices and set then to install pending startup (set a flag). A user named boatlover posted that if one calls the Pittsburg Tivo server --- 1-412-471-1103, everything worked. It also worked for me, after trying for 2 frustrating months calling five different local tivo servers.

    It is possible that the Tivo servers still are not functioning correctly, and that could be the cause of your initial trouble; however, there may be more issues now.

    Maybe try calling the Pittsburg number.
     
  18. beanpoppa

    beanpoppa Cool Member

    13
    0
    Aug 22, 2008
    Does anyone know if the slices are still in the satellite stream? The drive went on the DTivo in my mother-in-law's room. She had been running a hacked 6.2a version that I built years ago (MRV, etc). Well, she no longer needs all the hacked features since it's the only Tivo left in the house. I restored an old 6.2 unhacked image to it, and got it set up. We have Vonage, so I'm unable to dial in to complete the initial activation call. I can bring it over to my parent's house and try dialing in from their landline, but I want to make sure that it can get the slices from the stream first. (and how long should I let it run to download the slices via satellite?)

    Thanks
     
  19. P Smith

    P Smith Mr. FixAnything

    21,608
    143
    Jul 25, 2002
    W.Mdtrn Sea
    I saw them in stream a few days ago - 101W tp27 PID 3f0 or 3f1
     
  20. cricketrulez

    cricketrulez New Member

    4
    0
    Jul 18, 2012
    Volkl,

    Are you referring to my error (posted below) message?

    thanks

    MJTIVO1-bash# ./slicer 6.4a-01-2-151
    Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!
     

Share This Page