1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vista & Media Sharing

Discussion in 'DIRECTV Tips and Resources' started by mdh333, May 5, 2008.

Thread Status:
Not open for further replies.
  1. May 5, 2008 #1 of 23
    mdh333

    mdh333 Mentor

    31
    0
    Mar 22, 2007
    OK...I'll apologize for starting another thread on this - but it's been very hard to find anything that has helped, with most threads being about XP.

    Anyway - running Vista Business version, WMP 11, connected to home network wirelessly through router provided by Verizon with FIOS install. HR20 is connected via ethernet.

    Issue - when going into media sharing, I don't see "Unknown Device", only "Other users of this PC"

    HR20 is connected OK. I can get to On Demand services, ping it from my PC, and see it in the router. I think that I can ping it from my PC means that nothing on the router is blocking this traffic. I've also temporarily tried turning off router firewall & Windows firewall. Both are currently on.

    IPSec Policy has been turned off. SSDP Discovery is on. Network settings show private network, allow media sharing. Media Player network service starts fine.

    I've rebooted my PC, and the HR20. I don't see any errors in Event Viewer, or on the router log.

    Ideas?
     
  2. May 5, 2008 #2 of 23
    MIAMI1683

    MIAMI1683 New Member

    2,570
    0
    Jul 11, 2007
    Ok so under Network do you see the Directv HR20?
     
  3. May 5, 2008 #3 of 23
    phat78boy

    phat78boy Hall Of Fame

    1,523
    1
    Sep 12, 2007
    Have you enabled media sharing thru WMP 11? Also, you can open it completely up by going into the settings for media sharing and selecting "allow new devices and computers automatically".
     
  4. May 5, 2008 #4 of 23
    Michael D'Angelo

    Michael D'Angelo Lifetime Achiever

    10,839
    0
    Oct 20, 2006
    What media player are you using?

    Did you check the "Share me media" box if you are using WMP11?

    Also make sure your HR20 is connected to the network too, not just the internet.
     
  5. May 5, 2008 #5 of 23
    mdh333

    mdh333 Mentor

    31
    0
    Mar 22, 2007
    No - when I just go into Network (neighborhood), I do not see the HR20. I see my computer now listed as a Media Device, my router, a net camera...but no HR20. I can still ping it though, and see it on the router - so I'm sure it's on the network.

    Using Windows Media Player, and sharing is enabled. I just don't see the HR20 (or unknown device) I have also turned on the "automatically allow new devices" but don't think that will really help for now.
     
  6. May 5, 2008 #6 of 23
    phat78boy

    phat78boy Hall Of Fame

    1,523
    1
    Sep 12, 2007
    Is the IP range on your HR20 the same as your computer? For example they should both be on 192.168.0.X.
     
  7. May 5, 2008 #7 of 23
    Michael D'Angelo

    Michael D'Angelo Lifetime Achiever

    10,839
    0
    Oct 20, 2006
    Do you see a new little icon down in the right corner of the PC screen? Every time I add a new unit to my network (HD DVR, PS3, etc.) I get a little pop up on all my Vista PC's and I just double click it and then click allow and it sets it up for "Media Sharing" for me.
     
  8. May 5, 2008 #8 of 23
    mdh333

    mdh333 Mentor

    31
    0
    Mar 22, 2007


    Yes, well, with a 1 in there (apparently it's a Verizon thing?)

    192.168.1.4 is the HR20
    .2 is my computer

    (incidentally, sometimes I am connected to work via VPN and things change a bit. I've disconnected on tries for this, but it shouldn't really matter. I still keep the local IP address as well, and can still see everything on the local network.
     
  9. May 5, 2008 #9 of 23
    phat78boy

    phat78boy Hall Of Fame

    1,523
    1
    Sep 12, 2007
    Actually, being connected to your VPN could make a difference. It depends on what your admin has allowed or disallowed with your VPN policies. I would get it working disconnected, then connect to see if it works.

    In the network and sharing center, are you setup for a public network or a private one?
     
  10. mdh333

    mdh333 Mentor

    31
    0
    Mar 22, 2007
    Yes - I'm definitely disconnecting from VPN when I try to get this to work.

    I do not have any icon for a new device.

    Network & Sharing shows me on a private network, with network discovery, file sharing, public folder sharing, and media sharing all turned on.
     
  11. mdh333

    mdh333 Mentor

    31
    0
    Mar 22, 2007
    Well - I made some progress...but still no luck.

    I did some router changes and specifically allowed the IP address for the HR20 to communicate. Now, in the media sharing I see DirecTV Plus HD DVR (not even "unknown device")

    I allow it to share on my PC.....but the HR20 doesn't do anything different. The "Music and Photos" option is just supposed to magically show up on the menu, right?

    Network tests pass, and I can download On Demand programming - thus it seems I'm on the network fine.

    Thoughts? I have rebooted both my PC and the HR20 a couple times.
     
  12. MIAMI1683

    MIAMI1683 New Member

    2,570
    0
    Jul 11, 2007
    It won't magically show up, but on my Vista as soon as it sees another device on my network I get a pop up. That says Windows has found a new device. Click here to allow media sharing. Have you seen that? If you go into wmp11 did you allow the reciever.
     
  13. phat78boy

    phat78boy Hall Of Fame

    1,523
    1
    Sep 12, 2007
    Sometimes you need to reboot your HR20 for the menu to show up.
     
  14. I. Liveclean

    I. Liveclean New Member

    4
    0
    Aug 15, 2007
    Phat is right. You should start from scratch and begin by shutting everything (including the DVR, computer and router) down. Reconnect the power to your router first and allow it to run through its cycle. Next power up your DVR and run through the reboot screens. Last, boot up your computer. I have found that Vista is often the culprit and seems to do better with connections when everything else has been issued an address by the router. This is often the case with an XBOX 360 as well.
     
  15. mdh333

    mdh333 Mentor

    31
    0
    Mar 22, 2007
    OK - I turned everything off over the weekend...and at some point, the option showed up on my DVR!!!!

    But.....

    I select it, then I see my computer name. I select it, and there's a message on the top of the screen asking me to select what type of media I'd like to see.

    But....there's no choices to select anything. What's missing? Do I have to use Windows sharing to share any folders, or something? I have added them into Media player.

    (incidentally, I've also installed TVersity...so I guess I'm not really sure which one the DVR is seeing. I did this awhile ago, and it didn't help things...but it's there)
     
  16. bhelton71

    bhelton71 Cutting Edge: ECHELON '09

    2,390
    0
    Mar 7, 2007

    If it is tversity you would see "[computername] : TVersity Media Server"
     
  17. mdh333

    mdh333 Mentor

    31
    0
    Mar 22, 2007
    Well - guess I still don't really know. My computer name is kinda long, so all I see are about the first 8-10 characters of the name. I can't tell if there's anything after it or not.
     
  18. aphoward

    aphoward Legend

    207
    0
    Sep 8, 2006
    You must have the items you want to share set that way on your PC. You need to a) make sure anything you want shared is part of your WMP library, and b) make sure you tell WMP what type of files IN THE LIBRARY to share (in the media sharing menu).

    Only media files that WMP has as part of it's lirbrary will be shared. Any other questions feel free to PM me, it took me forever to get media sharing setup, Windows + non-Windows devices is a bitch, but once it got going I can connect to both my HR20 and PS3 now.
     
  19. phat78boy

    phat78boy Hall Of Fame

    1,523
    1
    Sep 12, 2007
    As aphoward said, you need to have folders shared in WMP11 if that is what you are going to use.

    TVersity will add its name after your computer name if you are using that.
     
  20. wilbur_the_goose

    wilbur_the_goose Hall Of Fame

    4,492
    50
    Aug 16, 2006
    Make sure the Internet Connection Sharing service is turned off (set to manual). You do this thru services.msc
     
Thread Status:
Not open for further replies.

Share This Page