1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHDVR connection issues

Discussion in 'DIRECTV Connected Home' started by irish1811, Sep 16, 2012.

  1. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,683
    348
    Dec 9, 2006
    Reset the network defaults on this receiver then.

    If you're going to go with the WCCK, you'll need to log into your router and find the DHCP reserve IP range first.
     
  2. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    ok, found it?
     
  3. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,683
    348
    Dec 9, 2006
    So to set static IPs, find IP addresses outside the DHCP range and enter one in each receiver's advanced network setup.

    We'll wait on the WCCK at this point, to see if it is needed.
     
  4. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    isin't it needed to connect to the wireless network?
     
  5. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    I'm heading to bed, sorry. If you can post set by step instructions it would be appreciated, thanks!
     
  6. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,683
    348
    Dec 9, 2006
    It was after you do connect the WCCK, since that is how the router comes back into play.
    Connect it back up, then reset each receiver's network defaults, and use the "connect now" option.

    This will get you back to the beginning and then you go into the advanced network setup and change the last 3 digits of the IP address so it's outside of the DHCP range of your router.
     
  7. Laxguy

    Laxguy Honi Soit Qui Mal Y Pense.

    15,345
    578
    Dec 2, 2010
    Winters,...
    Might I suggest you don't tackle the last step right away if it's requiring you learning a bunch how to do that. VOS's steps short of setting a fixed IP should take you there, to a working MRV.
     
  8. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    Got it! Thanks VOS! I will give it a try tonight!
     
  9. The Merg

    The Merg 1*

    10,289
    35
    Jun 24, 2007
    Northern VA
    The OP's problem is that when he was using DHCP for MRV, one of the receivers routinely would drop off and reconnect. When the WCCK (and router) was removed from the equation and the OP used static IP addresses via APIPA, MRV worked fine. The next step is to reconnect the WCCK and use static IP addresses that are on his home network.

    - Merg
     
  10. litex2x

    litex2x Legend

    145
    1
    Sep 8, 2012
    Setting up static ip addresses differs from router to router so there's not really a universal step guide to doing it but the principles are the same. Are you completely sure you don't have the problem when the CCK-W is removed completely from your setup? You want to be completely sure before continuing any further.

    What I did for my setup was change the DHCP starting address in my router. I then connected my DirecTV setup to my home network normally using DHCP and then I went into advance network setup in each receiver and chose an address that comes before the DHCP starting address. I also assigned a static address to the CCK-W and you can do that through your browser. Each device should have its own unique address ie if your starting DHCP address is 192.168.1.100 your receivers can be 192.168.1.55, 192.168.1.56, 192.1681.57. Also you may have to restart all your current devices using the same router to release their current addresses so they can get new addresses.
     
  11. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,683
    348
    Dec 9, 2006
    My nature is to take steps for these changes, instead of a "shotgun" approach.
    It might be of some use to know if:

    1. static on just the receivers resolves this, or
    2. whether just static on the WCCK would, or
    3. if all need to be set to static.
     
  12. litex2x

    litex2x Legend

    145
    1
    Sep 8, 2012
    I can't say for sure. I gave everything a static ip address to rule everything out. He may want to start with assigning just the dvr with a static address and see what happens from there. If that doesn't work assign the WCCK an address and then everyone else if that fails.
     
  13. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,683
    348
    Dec 9, 2006
    Which is why doing things in steps helps. ;)
    For several years, some routers have needed to have the receivers use static.
    It would be something new if the WCCK needed static.
     
  14. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    Yes, I am 99% sure it only happend when the WCCK was connected. I have logged into my router controls and see where I can add a reserved IP, I will give it a try tonight when I get home.
     
  15. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,683
    348
    Dec 9, 2006
    This isn't what you want to do, as it's still under DHCP.

    You need to find the IP range for DHCP, and then select IP addresses outside of this range.
    For my router it's below .064

    1-ip.PNG
     
  16. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    My range is 192.168.0.1, but it looks like I can change it, I have 5 receivers, do I change all or just the DVR? And do I do the router thing first then connect the DVR or the other way around??????
     
  17. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    I tried to reserve an IP outside the range and I got an error message saying it needed to be in the range???????????
     
  18. litex2x

    litex2x Legend

    145
    1
    Sep 8, 2012
    That sounds like your gateway address. Go to your DHCP settings and see where the local address starts. It might be 192.168.0.2. Set it to 192.168.0.100 and then go to your hd dvr and go to the advance network setup and change that ip to 192.168.0.50. If there is a CPE setting in your DHCP configuration set it to the max allowed with the new range.
     
  19. irish1811

    irish1811 Mentor

    44
    0
    Sep 16, 2012
    This is the help fro my router, do i want the hard core IP address for my dvr and other receivers?

    "If you have your own DHCP server servicing the LAN side (or choose to "hardcode" all of your PC's IP addresses), you can disable the internal DHCP server by selecting the No radio button. If you do this, make sure the IP address assigned to the device is on the same subnet as the external DHCP server (the subnet mask is always 255.255.255.0), or you won't be able to access the device from the LAN. The IP address of the device can be set from the Basic Setup page.

    You can also set the starting IP address for IP leases available to the LAN, and change the number of PCs supported on the LAN. In the case above, addresses 192.168.0.2 through 192.168.0.9 can be used as hard-coded IP addresses with no fear of IP address conflict with the DHCP pool."
     
  20. litex2x

    litex2x Legend

    145
    1
    Sep 8, 2012
    Yea hardcoding is what you need. If it's already set 192.168.0.2-9 then try setting your hd dvr ip address to 192.168.0.2 or whatever the next available ip address is. Start with just the hd dvr for now. It may not be necessary to do everything.
     

Share This Page