Jump to content


Welcome to DBSTalk


Sign In 

Create Account
Welcome to DBSTalk, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of DBSTalk by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
 
Guest Message by DevFuse

Photo
- - - - -

722k: New kind of "Playback Ending Early" Bug?


  • Please log in to reply
No replies to this topic

#1 OFFLINE   sheltrk

sheltrk

    AllStar

  • Registered
  • 55 posts
Joined: Nov 01, 2007

Posted 14 February 2013 - 09:52 AM

This has happened two weeks in a row now. I've searched other "playback ended early" bug threads, but this seems different.

Setup: We have a 722k in the living room serving TV1 via HDMI to the living room tv. The TV2 output serves a tv in the back bedroom. Normally, our 722k stays in "Dual Mode".

Two weeks in a row now, I've been recording a college basketball game in prime time, and watching it either a bit behind live, or caught up to live. And I've been bitten by the same bug. Last night in particular, I was recording the game on ESPNU scheduled from 6:00 - 8:00 last night with the standard "sports padding" of 60 minutes, thus reserving the tuner until 9:00. I was watching the game on TV1, and the DVR was recording it on Tuner 2. I was watching it by hitting "play" on the recording, as opposed to watching "live TV". At 8:00, I was caught up to live. (In this case, the game had just ended--last week it hadn't...) The timer for Supernatural fired at 8:00 on Tuner 1. My playback of the game immediately ended, even though it was scheduled to record until 9:00.

Only, it didn't *really* stop recording. It looked like it did, but it was apparently still "stealthily" recording on ESPNU. The only way I could tell was if I pulled up the EPG and hit "Record" on the 8:00 program on ESPNU, I got an Error message: "Recording in Progress". Last night I didn't try to fix it, because my game had already ended.

But last week, when the same thing happened, my game was still going on. I couldn't just switch to "live TV" on Tuner 2, because I was watching on TV1 and the DVR was in "dual mode", and a timer on Tuner 1 had just fired. After a few moments of ranting under my breath, and getting the "Recording in Progress" message, I switched the 722k to "Single Mode". Then I selected the channel the game was on from the EPG, and then I was able to rewind to where I had left off watching the game. Which was still recording... Stealthily...

What I think is going on:
In "Dual Mode", the 722k doesn't fully recognize a program is padded if
1. It is recording on Tuner 2,
2. You are watching it on TV1 (while recording is in progress), and
3. Another timer fires on Tuner 1 when the program's scheduled end time is reached.

Work-around: Switch 722k to "Single Mode" when "end of playback" is reached. Re-Select channel from EPG in "Live TV". Rewind. Of course, if you are far enough behind live, this may not work...

...Ads Help To Support This SIte...



spam firewall