Jump to content


Welcome to DBSTalk


Sign In 

Create Account
Welcome to DBSTalk. Our community covers all aspects of video delivery solutions including: Direct Broadcast Satellite (DBS), Cable Television, and Internet Protocol Television (IPTV). We also have forums to discuss popular television programs, home theater equipment, and internet streaming service providers. Members of our community include experts who can help you solve technical problems, industry professionals, company representatives, and novices who are here to learn.

Like most online communities you must register to view or post in our community. Sign-up is a free and simple process that requires minimal information. Be a part of our community by signing in or creating an account. The Digital Bit Stream starts here!
  • Reply to existing topics or start a discussion of your own
  • Subscribe to topics and forums and get email updates
  • Send private personal messages (PM) to other forum members
  • Customize your profile page and make new friends
 
Guest Message by DevFuse

Photo
- - - - -

HR20 Quality


  • This topic is locked This topic is locked
13 replies to this topic

#1 OFFLINE   dburckh

dburckh

    New Member

  • Registered
  • 5 posts
Joined: Jul 05, 2007

Posted 05 July 2007 - 10:33 PM

When I got my DTV, I came with an H20 (not an HR20). I had OTA HD/analog cable before that. I noticed that the quality of the H20 was considerably lower than my previous setup. HD got blocky and hard too watch with any motion. SD looked like it was Lego-mation (I just made that up, but you get the idea). I assumed it was the DTV service. I almost canceled it.

Luckily I had purchased an HR10-250 on e-bay. It had a much better SD and HD picture via HDMI. I sent the H20 back and purchased another HR10.

Now that DTV is rolling out more AVC channels, I'm considering an HR20. I have a couple of friends with HR20-700(?) and they appear to have the same blockiness I noticed with my H20.

First, does anybody have an HR10 and HR20 and notice this? Nobody seems to mention it. Is it just me?

Second, is it just the HDMI connection? I've now seen several HR20's hooked up with HDMI and they all get really blocky with any quick motion. This is consistent with both the MPG2 and MPG4 channels, so I assume it's not the feed. Still/low motion video looks very good.

...Ads Help To Support This SIte...

#2 OFFLINE   litzdog911

litzdog911

    Hall Of Fame

  • DBSTalk Club
  • 11,498 posts
  • LocationMill Creek, WA
Joined: Jun 23, 2004

Posted 06 July 2007 - 02:10 AM

Welcome to DBSTalk!

I have both an HR10-250 and an HR20 connected to my Sony HDTV via HDMI. I see no difference between the two when comparing the exact same channels (OTA local HDTV channels, for example).
HD DVRs: HR34-700; HR24-500; (2) HR20-700 + WD eSATA 1TB drive/Antec MX1 case; HR21-700; HR21-200 w/AM21
Receivers: H25-500 HD Receiver; H21-100 HD Receiver
Mobile Devices: Nomad

Additional equipment configuration details

Sun & moon help site your satellite dish


#3 OFFLINE   AlbertZeroK

AlbertZeroK

    Icon

  • Registered
  • 914 posts
Joined: Jan 28, 2006

Posted 06 July 2007 - 05:10 AM

I would agree, picture quality from my old HR10-250 to my new HR20 is identical.

Blockyness is more likely a sign of bad signal quality than it is a bad HR20. Make sure the HR20 has some breathing room and the cables are attached and signal strength is good.
AT9 w/ Splitters & WB616 / SWM5
Living Room: HR21-700 / HR20-100 & 50" Hitachi 1080P Plasma w/ HD-A30 + Playstation 3 = Purple Nation!
Master Bedroom: HR20-700 & 42" Panasonic Plasma
Both Bedrooms: HR20-100 & 42" Panasonic Plasma.

#4 OFFLINE   dburckh

dburckh

    New Member

  • Topic Starter
  • Registered
  • 5 posts
Joined: Jul 05, 2007

Posted 06 July 2007 - 06:31 AM

Thanks guys, I must be crazy.

You may be right about the breathing room. I literally burnt myself on my H20. It runs much hotter than my HR10. Maybe it was just overheating.

I'm really liking the look of the HR20-100. Maybe I'll get one of those...

#5 OFFLINE   Fish Man

Fish Man

    Godfather

  • Registered
  • 439 posts
Joined: Apr 22, 2002

Posted 06 July 2007 - 07:51 AM

You probably had a defective H20.

There's absolutely no technical reason whatsoever that there should be any difference between the two, especially on the HDMI outputs.

HDMI is fully digital. It's ones and zeros. There can't be any difference unless something is wrong with the unit.

The decoding algorithm for MPEG2 (and MPEG4, for that matter) is 100% deterministic. You take the MPEG(2,4) bitstream and run it through the decoding algorithm and a digital result, ones and zeros, comes out. This result can't vary from one model to another.

Ones and zeros come out of the HDMI output of the box. If there's no defect, there can't be any difference.

There is one caveat: Subtleties in timing differences can cause compatibility issues with a very small number of TV's, that may not be the same from model to model of set top box. However, what you describe sounds like an outright defect.

#6 OFFLINE   69hokie

69hokie

    Icon

  • Registered
  • 716 posts
Joined: Sep 23, 2006

Posted 06 July 2007 - 10:09 AM

I have all three (H20,HR20, and HR10-250) presently in service and I have not noticed any differences in quality of picture, moving or still. They all seem to perform well for me.
Wayne
Go Virginia Tech....and "Hoo"ever is playing UVa!

My Setup

#7 ONLINE   veryoldschool

veryoldschool

    Lifetime Achiever

  • Moderators
  • 41,637 posts
Joined: Dec 09, 2006

Posted 06 July 2007 - 10:22 AM

Thanks guys, I must be crazy.

You may be right about the breathing room. I literally burnt myself on my H20. It runs much hotter than my HR10. Maybe it was just overheating.

I'm really liking the look of the HR20-100. Maybe I'll get one of those...

If you did, then you have/had the H20-600 which does run hot & needs all the air flow it can get. The "upside" to that unit is a very good OTA, that none of the other H series has.
All of the other H series runs cooler.
A.K.A VOS

#8 OFFLINE   dburckh

dburckh

    New Member

  • Topic Starter
  • Registered
  • 5 posts
Joined: Jul 05, 2007

Posted 06 July 2007 - 01:03 PM

You probably had a defective H20.

There's absolutely no technical reason whatsoever that there should be any difference between the two, especially on the HDMI outputs.

HDMI is fully digital. It's ones and zeros. There can't be any difference unless something is wrong with the unit.

The decoding algorithm for MPEG2 (and MPEG4, for that matter) is 100% deterministic. You take the MPEG(2,4) bitstream and run it through the decoding algorithm and a digital result, ones and zeros, comes out. This result can't vary from one model to another.

Ones and zeros come out of the HDMI output of the box. If there's no defect, there can't be any difference.

There is one caveat: Subtleties in timing differences can cause compatibility issues with a very small number of TV's, that may not be the same from model to model of set top box. However, what you describe sounds like an outright defect.


I have to beg to differ on your decoder comment. There is a huge difference in quality between decoders. Although the MPG2 algorithm is a standard, most decoders implement post processing filters to do things like blend in jagged edges and deinterlace. Even my TV has an MPG "noise" filter with 3 different settings.

As for the differences in units, I'll take everyone's word that they are the same.

#9 OFFLINE   dburckh

dburckh

    New Member

  • Topic Starter
  • Registered
  • 5 posts
Joined: Jul 05, 2007

Posted 06 July 2007 - 01:07 PM

If you did, then you have/had the H20-600 which does run hot & needs all the air flow it can get. The "upside" to that unit is a very good OTA, that none of the other H series has.
All of the other H series runs cooler.


This must have been what I had. The OTA was incredible, even better than my TV. My HR10-250 OTA sucks (my only complaint about the unit). I didn't realize there were so many Hx20-x models.

#10 OFFLINE   gio12

gio12

    Icon

  • Registered
  • 836 posts
Joined: Jul 31, 2006

Posted 06 July 2007 - 01:24 PM

If you did, then you have/had the H20-600 which does run hot & needs all the air flow it can get. The "upside" to that unit is a very good OTA, that none of the other H series has.
All of the other H series runs cooler.

HR20-600??? :confused:

I thought there was only the 700 and 100 series.

EDIT: Never mind!! I realized that its' a H series and not a DVR

#11 OFFLINE   AlbertZeroK

AlbertZeroK

    Icon

  • Registered
  • 914 posts
Joined: Jan 28, 2006

Posted 06 July 2007 - 01:27 PM

HR20-600??? :confused:

I thought there was only the 700 and 100 series.


Your thinking HR20, they are talking about the H20 (non-DVR HD Receiver)
AT9 w/ Splitters & WB616 / SWM5
Living Room: HR21-700 / HR20-100 & 50" Hitachi 1080P Plasma w/ HD-A30 + Playstation 3 = Purple Nation!
Master Bedroom: HR20-700 & 42" Panasonic Plasma
Both Bedrooms: HR20-100 & 42" Panasonic Plasma.

#12 OFFLINE   Fish Man

Fish Man

    Godfather

  • Registered
  • 439 posts
Joined: Apr 22, 2002

Posted 06 July 2007 - 01:53 PM

I have to beg to differ on your decoder comment. There is a huge difference in quality between decoders. Although the MPG2 algorithm is a standard, most decoders implement post processing filters to do things like blend in jagged edges and deinterlace. Even my TV has an MPG "noise" filter with 3 different settings.

As for the differences in units, I'll take everyone's word that they are the same.


The operative words in your description are "post processing".

"Post" what? Post decoding! :)

The 3 different filter settings on your TV have nothing whatsoever to do with the MPEG decoding which is deterministic. Those filters come after the decoding.

There is NO post processing (filtering) on the UDMI output. On the various analog outputs (Component, Svideo, composite), there very likely is. Low pass filtering, anyway.

#13 OFFLINE   dburckh

dburckh

    New Member

  • Topic Starter
  • Registered
  • 5 posts
Joined: Jul 05, 2007

Posted 06 July 2007 - 10:46 PM

The operative words in your description are "post processing".

"Post" what? Post decoding! :)

The 3 different filter settings on your TV have nothing whatsoever to do with the MPEG decoding which is deterministic. Those filters come after the decoding.

There is NO post processing (filtering) on the UDMI output. On the various analog outputs (Component, Svideo, composite), there very likely is. Low pass filtering, anyway.


I think in essence were are agreeing. I agree that the post processor mentioned only works on TS streams, not the HDMI input from my DVR. I am curious as to whether or not TV's are smart enough to telecide 1080i video down to the 1080p24fps it usually is (I'm taking this thread to Cuba).

I still stand fast on the notion the all decoders (I'm including post processors built into them) are not equal. For example, the Pure Video decoder (and it's post processor) on my PC is hands down better than the one in VLC.

#14 OFFLINE   Fish Man

Fish Man

    Godfather

  • Registered
  • 439 posts
Joined: Apr 22, 2002

Posted 07 July 2007 - 08:26 AM

I am curious as to whether or not TV's are smart enough to telecide 1080i video down to the 1080p24fps it usually is (I'm taking this thread to Cuba).


I'm currently actively shopping to upgrade my living room TV (the old one will go into the bedroom).

On the spec sheet of every HDTV I'm considering (I'm looking at LCD units, true 1080P in the 50" range) the spec: "Reverse 3:2 pulldown" appears.

Whether it's done in the analog or digital domain, undoing the pulldown consists of the re-timing of fields of video or of certain lines of pixels.

I'd be surprised if there were much variation from TV to TV as to the quality to which they did this.

I suppose they could vary in how precisely they align the fields. If they did, it might be visibly noticeable.




spam firewall