1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Any recent changes to rs232 receiver commands?

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by grover517, Sep 7, 2011.

  1. grover517

    grover517 AllStar

    171
    11
    Sep 29, 2007
    I have been using the Paterson Tech TV translators for years now with my ReplayTV's without any issues at all.

    However, a while back I started seeing channel change failures on 3 of my setups (1-H20 and 2-H21) which caused the wrong programs to be recorded. This was in the same time frame where a software update to the DTV receivers was pushed, and caused extremely slow receiver response times.

    After a week or two, the H21's started working again. This was about the same time as the software update to resolve the slow receiver issue was pushed.

    I cannot say for sure that the channel change failure issues appeared exactly with those software pushes, but I do remember that it was not a fun time in the house where out of 5 DVR's in the house, the 3 Replay's recorded the wrong thing, and the 2 DTV DVR's (HR21's) were slow as mollasses. :(

    But after all of that, the H20 never started to work right. Resetting or unplugging and plugging the H20 back in was the only way to get things working again, but after a day or so, the problem returned.

    So I had DTV swap out the H20, and they gave me an H24. Yippee, I thought. Surely, this new receiver will solve the problems since the H21's are working just fine. However, the H24 shows the exact same problem as the H20. I can reset the receiver and things work just fine, but after about a day, it's like the H24 just ignores the rs232 commands.

    I have already verified with Paterson, the setting needed to control the H24, but that still doesn't resolve the issue.

    I have moved the H24 to all 3 different setups in the house, and the problem follows the H24, so it is not the Replay's or the translators.

    Software versions on the receivers are:
    H21 - 0x44c4
    H24 - 0x4c4

    So, does anyone else seeing anything like this other than me? Am I going mad? :grin:

    TIA,

    J

    P.S. Please don't recommend that I upgrade to a DTV DVR. Already have 2 in the house. The Replay's are for the kids and they have massive amounts of archived recordings that would get lost if the Replay's are taken, so not an option. :grin:
     
  2. bobcamp1

    bobcamp1 Icon

    896
    1
    Nov 8, 2007
    I have seen that as well. I'm playing with the settings to see which ones work best. I think I bumped up the time it waits before it times out. In the H24, I also have set the banner to clear after 8 seconds.

    Have you downloaded the newest firmware for the cable? The new one reports the channel number back to the Tivo/ReplayTV device so at least it knows the channel didn't change.
     
  3. grover517

    grover517 AllStar

    171
    11
    Sep 29, 2007
    I reported the issue to Paterson Tech, and up till now they told me that I was the only one contacting them about an issue, and without any other complaints, they won't go to DTV to discuss at all.

    So maybe you need to contact them also to at least let them know that I am not the only one having the issue.

    I have played with settings for the past few weeks till I was blue in the face, and nothing I do seems to help resolve the issue, but it seems that some settings make it last a little longer before a reset is again needed.

    Paterson did tell me to make sure the receiver reset option is turned off on the H24, but for some reason, it seems to make the receiver last a little longer between resets when it is turned on.

    I have also made sure I had the latest firmware, as well as tried every iteration of the firmware that was available on the site. Earlier ones barely worked at all, where newer ones worked better, but still didn't resolve the issue.

    I have also seen issues mentioned in other posts elsewhere that mention the same H24 issues with other platforms, and their solution was to change connection cables. That isn't an option in this case unless Paterson recognizes a problem, and offers something different than what we have. Here is an example from the DTV forums (of all places) that shows we weren't the only ones seeing this on the H24's

    http://forums.directv.com/pe/action/forums/displaypost?postID=10790698

    When this issue first began, I mentioned to the other half that I was ready to pull out a christmas tree timer, plug the receiver into that, and set it to turn off the power and back on again every 24 hours and during a time when we don't record anything as a workaround.

    I originally mentioned that as a sarcastic joke, but now it is sounding more and more like the only solution I may end up with that actually works. :sure:
     
  4. bobcamp1

    bobcamp1 Icon

    896
    1
    Nov 8, 2007
    Maybe we have defective cables.

    My backup plan is to switch to the IR blasters on my Tivo. But it doesn't happen often enough for me to do that. It's just once or twice a month for me.
     
  5. grover517

    grover517 AllStar

    171
    11
    Sep 29, 2007
    Highly doubt it since I tried 3 different ones. A spare, and two from working setups with H21's.
     

Share This Page