1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apple TV Stopped Playing my Purchased Content Yesterday

Discussion in 'IPTV Hardware' started by islesfan, Oct 9, 2013.

  1. islesfan

    islesfan Hall Of Fame

    Oct 18, 2006
    I came home from work yesterday, and since my Genie "canceled" its recording of the Isles v. Coyotes for no given reason, I thought I'd spend the time watching the new episode of Sleepy Hollow on my Apple TV. I selected the show, pressed play, and a couple of seconds later, I was back to the same screen. After several tries with various content, I noticed that it was never going to the momentary "authorizing" screen. I then tried a reboot, still no luck. I tried a reset to factory settings, and I still cannot play my content. I logged in as my son, and bam, I can play his content just fine. It goes right to "authorizing" and then it plays. I sign back in as me, and it won't go to the "authorizing" screen anymore.

    Just to be sure there wasn't an account problem, I downloaded the same episode to my iPhone, iPad, and PC without any issues. Back to the Apple TV, and it won't authorize.

    What can I do next?
  2. Stewart Vernon

    Stewart Vernon Roving Reporter Staff Member Super Moderator DBSTalk Club

    Jan 7, 2005
    Kittrell, NC
    I wonder if this is related to other Apple authorization issues lately.

    Last week I was having issues on my iPhone and on my iMac as well. My iMac was particularly weird in that it sometimes would ask me to login, other times would just act like I hadn't selected anything at all. Even free content was inaccessible for at least half a day one day last week for me.

    When I poked around online to see... it seemed that some users were having more trouble than others... so some would be able to access, and others like me could not.

    You should keep trying periodically, especially later tonight or tomorrow and see if it is something that resolves itself.

Share This Page