1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Belkin Routers, TVApps and <301> Errors -- Oh My!

Discussion in 'DIRECTV Connected Home' started by jceman, Oct 24, 2010.

  1. jceman

    jceman Legend

    302
    7
    Aug 20, 2007
    North of...
    I have read all the threads that seem related to this set of entities while trying to restore the TV Apps functionality to my system after my old router died and getting a new Belkin, all to no avail. I did restarts, including the prescribed total cold boot, tried setting up Static IPs and port forwarding (even though the Belkin only lets you forward on one IP Address), no joy ever.

    The other night while (almost) mindlessly perusing the DirecTV Tech Forums, I came across this gem -- another user had noticed in his Belkin router's log that each attempt to bring up TV Apps resulted in a UDP query to Port 1701 which was, of course, being blocked.

    To cut to the chase, all I had to do was go into the router's setup page and forward Port 1701 for UDP on either my H24 or HR24, leave the Network Services selection on Automatic and voila! Network Services started and so did TV Apps. (I know there is no direct correlation between the two supposedly, but there you are.) It seems that the UDP port 1701 is universal for TV Apps so it matters not which STB's IP Address is placed in the forwarding setup.
     
  2. spikeit

    spikeit Cool Member

    19
    0
    Aug 13, 2007
    Thanks for the info, I tried your suggestion and now apps work fine.
    I've been trying to get this to work since the last couple updates.
    Thanks again...
     
  3. jamieh1

    jamieh1 Hall Of Fame

    1,442
    11
    May 1, 2003
    works thanks
     

Share This Page