1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D* failed to ship Return Kit for deactivated H20.

Discussion in 'DIRECTV Tips and Resources' started by sgibson, Aug 2, 2010.

  1. Aug 2, 2010 #1 of 12
    sgibson

    sgibson AllStar

    73
    0
    Jul 26, 2007
    7/16-Activated HR24 and made 2 attempts to return "deactivated" H20. Spoke to same rep twice.(First 7/23,then again on 7/30.)Still no Return kit after 18 days. After my 2nd try, Rep assured me Return Kit would be sent.
    I don't want to be billed later for not returning "leased" unit.

    Thanks for any advice,
    sgibson
     
  2. Aug 2, 2010 #2 of 12
    spartanstew

    spartanstew Dry as a bone

    12,566
    61
    Nov 16, 2005
    Wylie, Texas
    What did they say when you called on 7/30?
     
  3. Aug 2, 2010 #3 of 12
    sgibson

    sgibson AllStar

    73
    0
    Jul 26, 2007
    Rep made no excuse for not sending 1st time. After she promise again, I asked and got her Supv.s name. I told her I would prefer to not involve her Supv. She said she would issue another order for Return Kit. I'm still waiting.
     
  4. Aug 2, 2010 #4 of 12
    spartanstew

    spartanstew Dry as a bone

    12,566
    61
    Nov 16, 2005
    Wylie, Texas
    It's only been 3 days since that call. It can take up to 14 business days to receive it.

    If you haven't received it by August 20th, call again.
     
  5. Aug 2, 2010 #5 of 12
    LarryFlowers

    LarryFlowers New Member

    4,290
    1
    Sep 22, 2006
    Depending on which H20 it was, you may never see a return kit for it and the CSR will never be the wiser.

    Go to the DirecTV web site at http://support.directv.com/app/ask fill it out and send in an email about the issue and they will let you know if in fact you need a recovery kit.

    I recently deactivated 2 H20 receivers. I didn't get recovery kits. I emailed them and was notified in writing in an email that neither unit needed to be returned.

    THIS DOES NOT APPLY TO ALL H20's so you need to check.
     
  6. Aug 2, 2010 #6 of 12
    spartanstew

    spartanstew Dry as a bone

    12,566
    61
    Nov 16, 2005
    Wylie, Texas
    But I wouldn't worry about it until 8/20
     
  7. Aug 2, 2010 #7 of 12
    dpeters11

    dpeters11 Hall Of Fame

    16,345
    503
    May 30, 2007
    Cincinnati
    Which H20 is it? If it's a H20-600, that could be the reason you didn't get a box. They generally don't want those back. I'm actually surprised they want any H20 back, since there is no ethernet jack.
     
  8. Aug 2, 2010 #8 of 12
    bobnielsen

    bobnielsen Éminence grise

    8,473
    92
    Jun 29, 2006
    Bainbridge...
    They don't want a lot of the older models back. When I deactivated my HR20, the CSR checked and said it now showed up as an owned unit on my account and I didn't need to return it.
     
  9. Aug 2, 2010 #9 of 12
    sgibson

    sgibson AllStar

    73
    0
    Jul 26, 2007
    It's a H20-100-no Ethernet. If they don't want it back, D* should instruct their reps. I just don't want a "surprise" charge later, for not returning "leased" H20.
     
  10. sgibson

    sgibson AllStar

    73
    0
    Jul 26, 2007
    Rather than wait, think I'll take your advice and e-mail. Thanks for the link.
     
  11. j2fast

    j2fast Godfather

    395
    0
    Jul 15, 2007
    In the last month and a half I've deactivate two H20-600's and one HR20-700. Directv didn't want any of them back. On the H20's the rep tried to put in a return (or whatever they do) and he actually said, "it looks like they don't want the boxes." The HR was, "if you get a box send it back."

    I'm hanging onto them, a winter time science project might be to blend a couple of the boxes into a case for an HTPC. :D
     
  12. joshjr

    joshjr Hall Of Fame

    4,821
    86
    Aug 2, 2008
    NE Oklahoma
    I had the same thing happen for 2 D12's lol. Deactivated them and was told that they sent recovery kits. When they didnt arrive I asked for another one. They finally sent one and I mailed it back pretty fast. Then a week or 2 later I got an automated call asking if they had been shipped. I saved the tracking information on it though and have been able to verify that the receivers have been returned.
     

Share This Page