1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dish Anywhere and new router

Discussion in 'Hopper System Support Forum' started by KYGuy33, Aug 7, 2018.

  1. KYGuy33

    KYGuy33 New Member

    1
    0
    Aug 7, 2018
    I am sure this is a stupid question but perhaps someone that knows a bit more about networking and Dish than I do can help with my issue. Recently have switched devices in my home network and cannot connect with Dish Anywhere anywhere other than my home network, which obviously defeats the purpose.

    Former Setup:
    Spectrum Cable Internet -> Motorola - N300 Router/Modem
    Hopper 3 connecting wirelessly

    This worked fine, but the internet in the house was notoriously unreliable outside of the living room so dumped the combo unit and an IT friend told me what to buy.

    Since purchasing the new set up below he set the Linksys to receive the public IP. The Motorola was placed in passthrough mode.

    Current Setup:
    Spectrum Cable Internet -> Motorola - N300 Router/Modem -> Linksys 3200ACM
    Hopper 3 connecting wirelessly

    Now outside of our home network, there is no connectivity on the app/laptop. Says that it cannot connect to the receiver despite the fact that the DVR is showing green on the app and on the web. On the home network the shows load fine and play perfectly. We have tried several things like assigning a static IP on the wireless network to the Hopper and placing it in the DMZ. No effect.

    Any suggestions on how to get this working?
     
  2. TheGrove

    TheGrove AllStar

    201
    11
    Jan 9, 2007
    It sounds to me like either the Motorola or Linksys, probably the Linksys, has had it's firewall or port filtering turned on and it is stopping the signal. You will need to get into this configuration on the device and adjust it to allow the Dish traffic thru. Unfortunately I don't know what port Dish is trying to use to communicate or I would point you to that.
     
  3. scooper

    scooper Hall Of Fame

    6,556
    68
    Apr 22, 2002
    Youngsville NC
    Your "IT friend" screwed up and set you up as a dual NAT. At this point, you DON'T need the N300 router. Your internal network is probably not setup up correctly for everything to work correctly either.
     

Share This Page