DVR-942 seems to be dead

Discussion in 'Other HD Receiver Support Forum (811, 921, 942)' started by joaquinld, Apr 21, 2007.

  1. joaquinld

    joaquinld New Member

    7
    0
    Apr 21, 2007
    After a week on vacation we returned home on April 7 to find out there was no signal on both TVs connected to our 942 (TV1 displays a black screen while TV2 displays a blue screent).

    At first I though the problem was the satelite signal but the the signal on our son's room which is connected to a 311 is working fine. We went through every single possible troubleshooting tip on the users manual. I even connected the 942 to a different TV to see if my living room TV was the source of the problem and nothing. I've tried a hard reboot and nothing.

    Upon the hard reboot (unplugging for 15 seconds and then waiting an hour to turn it back on) only the TV1 green light in the front panel of the receiver is lit, along with the light below the two screen mode but I still can't get a signal on either of the two TVs. In addition, these lights only stay on for a few minutes and then go dark again. If I power off and then on the sequence is repeated and nothing happens.

    I've triple checked all the cables and even substituted them for new ones and still nothing. I've also tried the using the recover button on the remote and still nothing.

    Has anyone experienced something similar? Should I already be thinking about buying a new receiver as my 942 seems to be toast?

    Any help will be greatly appreciated.
     
  2. Jon Spackman

    Jon Spackman Icon

    650
    0
    Feb 7, 2005
    Try a reset by holding down the power button until it reboots. I had to do that a couple times in a row once to get my box back up. IF that doesnt work, you will need to call dish for a replacement unit.
     
  3. joaquinld

    joaquinld New Member

    7
    0
    Apr 21, 2007
    I've already tried that and at first I though the reboot was succesful but the 942 seems to go into sort of a loop in which the left green light under TV1 lights up and then off, then about 30 secs later the same happens again. I don't know if the 942 overheated in the rack where it's installed but at this point my hopes are pretty low and it looks like I'll have to replace the equipment...
     
  4. Mike D-CO5

    Mike D-CO5 Hall Of Fame

    3,099
    2
    Mar 11, 2003
    LOoks like it is time to add the dish home protection warrenty.
     

Share This Page

spam firewall