1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error 22 on Internet Connection with Directv HR20 HD DVR and Netgear WPN824

Discussion in 'DIRECTV Connected Home' started by YourDaddyNow, Mar 11, 2008.

  1. YourDaddyNow

    YourDaddyNow New Member

    1
    0
    Mar 11, 2008
    I have the HR20 HD DVR blue wired to my Netgear WPN824 router which also provides wireless access to 3 notebooks and wired access to my media server. The Netgear is hardwired to a Bellsouth (ATT) Westell Router hard wired to a 6Mb Bellsouth (ATT) broadband service. All the computers connect fine. I've even connected my kids PSPs with no issues. The Netgear is assigned a 192... address using a 4.2.2.2 DNS by the Westell, and is supplying DHCP IP addresses in the 10... range to my local workgroup.
    When I use the default settings in the DVR, I can see it in the list of Attached Devices as DIRECTV-HR20-F3 at a matching MAC.

    Connect Now shows OK for everything except Internet. The error message is 22.

    Most interesting is that when I originally set this up a week ago, it was working perfectly and did so for about 3 days. Then I happened to notice a message on the TV saying the Admin Account of the Media Server was logging out. I'm using Channel 6 and WEP 128bit security so no one is hacking in. I can account for all connections on the Netgear.

    Let me know if I need to supply more information. I have decent networking skills but can't figure this one out. Any help will be appreciated. Thanks in advance.
     
  2. Jun 1, 2008 #2 of 10
    Grofe

    Grofe New Member

    1
    0
    Jun 1, 2008

    I am having the exact same problem but I was never able to connect. After about 2 hours on the phone with Netgear and DirecTV I'm sure my IP address (etc.) is correct. Where able to resolve this issue? Thanks!
     
  3. dervari

    dervari Icon

    777
    0
    Dec 1, 2005
    WEP 128-bit security is about as safe as no security at all. I could get in within a few minutes, guaranteed.

    Anyway, I had this problem for a while and using a sniffer I found that if you get disconnected from the network, sometiems the HR20 will not automatically reconnect. Try rebooting the HR20 and as soon as it comes up, go into the network set up and tell it to connect to the internet.

    The HR20 actually tries to connect to a particular internet site when you do a connect to the internet and expects a certain response. It seems that sometimes it doesn't send that query at all, and then decides that your internet connection isn't working. If you reboot and immediately connect though, it seems to work most of the time.

    If you're curious about the internals of this, see http://www.dbstalk.com/showthread.php?t=107341
     
  4. curtmcgirt

    curtmcgirt New Member

    4
    0
    Jul 11, 2010
    still happening in 2010 with two hr20s. persists through receiver reboots. default config is through a belkin router but i have connected one receiver directly to my speedstream DSL modem. same behavior: everything connects except the internet, "error 22". the 3 laptops, 3 nintendo DSs, wii, xbox, playstation, and blackberry all connect to the internet just fine through the belkin router.
     
  5. BennyGregg

    BennyGregg Legend

    161
    0
    Jul 17, 2009
    I had this issue with an HR21-700; the fix was to set my router to use googles free dns servers at 8.8.8.8 and 8.8.4.4; my internet provider is AT&T DSL.
     
  6. jagrim

    jagrim Hall Of Fame

    1,910
    65
    Aug 25, 2006
    I'll bet that you have AT&T internet service. Try going into your router and changing the DNS to Google or OpenDNS (208.67.222.222 , 208.67.220.220)

    I had the same problem and that is what fixed it.

    Good Luck
     
  7. cawgijoe

    cawgijoe Legend

    192
    0
    Dec 22, 2005
    Just ran into this problem last night.

    I had to replace the FIOS Actiontec router with a new one that Verizon sent me because the old one died. I have a Cisco Linksys 5 port switchbox that I also had to replace with a new Cisco Linksys 8 port switchbox because I needed an additional port for my new TV. Long story short.....everything was working fine till I replaced the 5 port switch. Got the TV, PS3, Sony blu-ray player and Squeezebox Duet up and running.....then tried the HR20.....no luck. Everything appears to be fine, but no internet connection (#22).

    I gave up after several tries......however I will go ahead and re-boot the HR20 tonight and hopefully that will work.
     
  8. Chuck W

    Chuck W Icon

    853
    13
    Mar 26, 2002
    Connecticut
    My HR20's (100 and 700) have always been finicky if it happens to lose connection. Sometimes it would reconnect , other times it wouldn't. Rebooting has usually fixed the issue for me.
     
  9. wilbur_the_goose

    wilbur_the_goose Hall Of Fame

    4,625
    81
    Aug 16, 2006
    cawgijoe - I never could get the VZ FIOS Actiontec router to work. I ended up using my old, trusty VZ FIOS D-Link router.
     
  10. afrowiss

    afrowiss New Member

    1
    0
    Sep 17, 2010
    Error 22 No More ...


    Connecting DirectTV DVR to Internet


    After many hours of screwing around with with the Cisco/Linksys manual on how to pre configure a Dual Band N Wireless Bridge for Gaming/Video, finally got things working.


    QWEST Wireless router (ACTIONTEC) throughout house, but HD DVR to far for direct ethernet connectivity. Purchased Cisco device as shown on DirectTV web site and recommended by local PC shop. Followed Cisco instructions on how to setup up wireless bridge ... with no apparent issues. But could never establish connectivity through DVR. Kept getting Error 22. Tried several changes to IP Address, DNS, etc. No difference.


    Read all of the forums ... down the white rabbit hole, with lot of high tech recommendations. No success.


    Finally, reset defaults on DVR and on Wireless Bridge. Connected directly to DVR, and went through system setup on DVR/network setup. NOW, DVR recognizes wireless device ... and after a few minutes presents wireless networks present. I select mine, enter SSID, passphrase and bingo.


    Recommendation: Trash the manufacturer instructions, better suited for gaming devices, etc.. Go to DirectTV.com/connected site and follow directions on setting up WIRED/WIRELESS connections.
     

Share This Page