1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

H20 600 Locks Up

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by sdlehman, Aug 18, 2007.

Thread Status:
Not open for further replies.
  1. sdlehman

    sdlehman Cool Member

    11
    0
    Jan 1, 2006
    I have had an H20 600 that will periodically lock up. The screen goes black, the remote becomes unresponsive, and the on/off button on the unit won't work. I end up having to push the reset button which is very annoying durring a movie or a game. This unit runs very hot, whether it is on or off. Could it be just over heating?

    Stace
     
  2. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,684
    349
    Dec 9, 2006
    Yes it need a lot of air. Some use a small fan, others raise it up on some blocks to get more air underneath.
    What it the temp from the setup menu/ info screen?
     
  3. grandpaken

    grandpaken AllStar

    69
    0
    Feb 4, 2006

    Unless you have some sort of sentimental attachment to the receiver why not just call D* and request a new H20. They know there's a big heat problem with the -600 models and will replace it for free even if it's an owned unit out of warranty. Tell them it's so hot you're afraid it will catch on fire.
     
  4. eilloc

    eilloc Mentor

    51
    0
    May 17, 2007
    northern WI
    I have had the H20-600 for about 18 months, fortunately without any heating problems. Where is this temperature reading which sounds like a good idea??? Haven't found it in the setup menu/info screen??? Thanks!
     
  5. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    42,684
    349
    Dec 9, 2006
    If I still remember, it's in the info page after you've pressed select to refresh the screen [the one where there is then a tab for the system test].
     
  6. Michael D'Angelo

    Michael D'Angelo Lifetime Achiever

    10,839
    0
    Oct 20, 2006
    I was having some problems with my -600's locking up or resetting on their own. I have not had either problem after I got my first CE update for the -600's. So far with every CE update they have been fine. So you may want to take part in the next CE update whenever that is or hopefully the unit will get a national release update soon since the last couple of CE updates have went so well for the units.
     
Thread Status:
Not open for further replies.

Share This Page