HDMI sudden failure

Discussion in 'Other HD Receiver Support Forum (811, 921, 942)' started by zephyr, Sep 4, 2007.

  1. zephyr

    zephyr Legend

    183
    0
    Jun 25, 2005
    After a year and a half or so of no problem, HDMI (to DVI on Sony 34 in TV) failed suddenly. Saw a similar issue on 622 forum.
    Have been absent from this forum for nearly that long. Hope all are well. :hi:
    Any advice appreciated.
     
  2. stringray13

    stringray13 Cool Member

    22
    0
    Jul 12, 2007
    Are you referring to the port or the cable?
     
  3. Miner

    Miner Legend

    155
    0
    Oct 29, 2004
    Zephyr,

    The early model 622s were prone to failure due to a marginal attachment of the connector to the circuit board. Later 622s, and 942s use a more rugged connector. I've had my 622 connected to an Optoma RD-50 since Oct last year and last night it stopped working (was moving some furniture / cleaning up some wiring). After troubleshooting with a 942, a PC and 20" LCD panel, I believe the cause of the problem was the cable. I replaced the cable and all is well.

    You could also try resetting both the 942 and TV by unplugging both for 30 seconds or so.

    Mark
     
  4. Miner

    Miner Legend

    155
    0
    Oct 29, 2004
    Zephyr,

    After further review, it turns out my 622's HDMI output went sour. All was fine yesterday, but this morning it crapped out. A replacement 622 is on its way.

    I suggest full power resetting both the TV and 942 just for good measure.

    Mark
     
  5. Jon Spackman

    Jon Spackman Icon

    650
    0
    Feb 7, 2005
    Zep- contact dish have them replace your 942 with a 622 or 722. The 942 is not worth swapping. They are moving HD channels to mpeg-4 and will help you with a 622 or 722 swap out. :D
     

Share This Page

spam firewall