1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HDMI Switch,3 different devices, NO 720/1080

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by HDTVsportsfan, Feb 4, 2006.

Thread Status:
Not open for further replies.
  1. HDTVsportsfan

    HDTVsportsfan Active Member

    5,746
    0
    Nov 29, 2005
    Hello everyone,

    I just installed my new 4 port HDMI switch I purchsed from Monoprice and I'm a little bummed. I have three different sources and none of them will display any picture above 480P.

    Here's what a have.

    Panansonic TH-50PX50U
    HR10-250
    H20
    LG LDA-511

    I have three 3' HDMI (Monoprice) as the inputs and a Acoustical Research??? 6' cable feeding the plasma. Individually connected to the display without the switch all three work fine.

    Any thoughts would be appreciated. TIA.....
    (Posted in AVSforums well)
     
  2. JLucPicard

    JLucPicard Hall Of Fame

    3,985
    0
    Apr 27, 2004
    Do the specs of the switch indicate that it should pass the signals at the higher resolution, or is this a limitation of the switch itself?
     
  3. HDTVsportsfan

    HDTVsportsfan Active Member

    5,746
    0
    Nov 29, 2005
    The manual and web site says it supports 480i up to 1080p. Here's the link.
    http://www.monoprice.com/products/p...=10106&cs_id=1010602&p_id=2721&seq=1&format=2

    After a couple hours of plugging and unplugging and reconfiguring any and everything and every other combination I can think of, it still doesn't work.

    Either their is an incompatibility with the switch and TV that I cannot explain or the switch is bad. The closet I could get it to work was to power on TV first then the H20 second. A picture would appear for 1 or 2 seconds, flicker and then go black. No other wya to get a picture other than power off both TV and H20. This happens w/ the HR10-250 as well.

    Can anyone recommend another HDMI switch, also does anybody make one of these switches that allows you to connect the Optical Audio also?

    Thanks.
     
  4. leestoo

    leestoo AllStar

    94
    0
    Mar 23, 2002
    I have the same switcher as you and am not having the problem that you are having.

    I know that there have been some problems with the switcher. My problem is an audio sync issue.

    Monoprice is now selling a 5 port switcher that according to a review I read at AVS Forums seems to be better. And it is cheaper than the 4 port.
     
  5. HDTVsportsfan

    HDTVsportsfan Active Member

    5,746
    0
    Nov 29, 2005
    It just wasn't handshaking with the plasma at all. I'm returning the 4-port and have already pre-ordered the new 5 port that is supposed to be available the end of this month.
     
Thread Status:
Not open for further replies.

Share This Page