1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HR-20 Can't see TVersity no matter what I try

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by Special Ed, Feb 15, 2008.

Thread Status:
Not open for further replies.
  1. Special Ed

    Special Ed Legend

    Oct 26, 2007
    I have been posting about my TVersity issues in a very busy TVersity thread here but my questions keep getting buried and not answered. I decided to try a dedicated thread to help me and others that can’t even get their HR-20 to see TVersity. Maybe we can find a common set up issue that is causing the problem.

    Here is the back ground on my issue:

    • I have an HR-20 that cannot see that I have TVersity running on my computer.
    • The HR-20 has the latest national release from Jan 25 (0x1FE)
    • My computer with TVersity has a LinkSys WRT54GS v7 wireless router – I have since replaced the standard LinkSys Firmware with the high powered Open Source Firmware DD-WRT (I thought that might help me get TVersity working – it didn’t help)
    • At my media center I use a Buffalo AirStation turbo G wireless bridge.
    • Connected to this wireless bridge are: my Pioneer PRO-150FD Plazma, Pioneer VSX-94TXH Receiver, Xbox Elite 360, and the HR-20.
      All units are able to connect to my network and get internet feeds.
    • The Xbox works perfectly with TVersity.
    • The HR-20 is able to download VOD programs no problem.
    • The HR-20 Connect Test comes up completely successful.
    • All the correct ports are forwarded at the LinkSys. The port forwarding got the Xbox up and running but does not help the HR-20
    • On TVersity settings, I tried auto connect, HR20, HR20 wave, and HR20 MP3. None make a difference.
    • I tried a different default port for TVersity [30,000] – the new port works fine with Xbox but not the HR-20.
    • I turned of my computer’s software firewall and the router hardware firewall and the HR-20 still cannot see TVersity.
    I am at a loss as to what to try next. Someone mentioned in another forum that maybe the HR-20 can’t see the TVersity through a wireless bridge. My computer is too far away to do a direct Ethernet connect from my LinkSys router to my HR-20 so I can’t test this theory… Does anyone have TVersity working with an HR-20 using a wireless bridge? Especially a Buffalo Airstation.

    Does anyone have any ideas on what else I can try? I would love to use TVersity with the HR-20 rather than the noisy Xbox with a game controller.

    Maybe tell me step by step how you got TVersity to work on your HR20. I suspect for most it was like how I set it up to work with my Xbox - I turned on TVersity and forwarded the correct port for the Xbox and I was done.
  2. Lee L

    Lee L Hall Of Fame

    Aug 15, 2002
    I had to go in and disable the Wondows Firewall completely before I could get it to work. I had all the same things you do, working DOD, Xbox xould see TVersity, everything and sharing would not work, but when I disabled the Windows Firewall built into XP, it worked within minutes of a reboot.

    I see you say somethign about disabling a software firewall, but make sure hte Windows Firewall is totally disabled. (I think you have to go in there twice or confirm twice or something to tell it fully go away).

    The only difference I have from your situation is I used a wired connection.
  3. Special Ed

    Special Ed Legend

    Oct 26, 2007
    With my windows xp I don't use windows firewall, it is off. I use Zone Alarm and HR-20 can not see TVersity whether Zone Alarm firewall is on or off.

    Wired connection vs. wireless connection with wireless bridge is a much different setup.

    If anyone has TVersity working on a HR-20 with a wireless bridge connection please let me know.
  4. jahgreen

    jahgreen Godfather

    Dec 15, 2006
    My HR20-700 can see TVersity and Windows Media with the Linksys Game Adapter as a wireless bridge.

    I didn't do any port forwarding. I just selected folders to share and started the TVersity sharing service. I have had to "reboot" the bridge once to re-establish the connection, but other than that, I've done nothing special.
  5. Lee L

    Lee L Hall Of Fame

    Aug 15, 2002
    If you have not checked the windows Firewall settings, please do. Even if you have, if it was not recently, do it again.

    I was sure that Windows Firewall was not on because I had turned it off many moons ago. I even posted here about how it could not be the problem and I had the exact same issues you are having. However, when I actually checked it had turned itself on somewhow and I had to turn it off again, then it gave me the yellow exclamation point and I had to tell it to turn it off again.

    Now, if you have checekd it recently, maybe the wireless is your problem. (though that seems doubtful given that you have a connection and DoD is working)

    Could you temporarily run a long ethernet cable point to point to see if that fixes it?
  6. Supervolcano

    Supervolcano Hall Of Fame

    Jan 23, 2007
    I assume that is Model WLI-TX4-G54HP, correct?
    Bet it's using firmware v1.02 or maybe v2.50, correct?

    They actually call that product:
    Wireless-G MIMO Performance Ethernet Converter

    Here's the link to the v2.53 firmware update:

    According to many other posts in here, that should fix you right up, as the older firmware is what's causing your problem.

    Post results please.
  7. Special Ed

    Special Ed Legend

    Oct 26, 2007

    I took a while to get the thing flashed but the 2.53 firmware did it. Thanks!

    Finally someone with the answer.

  8. Canis Lupus

    Canis Lupus You make it, We break it

    Oct 16, 2006
    He may be the Ex-Chatroom Clown, but he certainly has answers. :p

Thread Status:
Not open for further replies.

Share This Page