HR20-700 Odd Intermittent Audio Issue

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by BillyBob_jcv, Jun 18, 2009.

  1. BillyBob_jcv

    BillyBob_jcv Legend

    175
    0
    Feb 11, 2006
    I have an HR20-700 that has started having a strange intermittent audio problem. Sometimes (not all the time) there is video, but no audio on BravoHD (Channel 273). This can occur on both recorded and live TV. Once it the sound drops, it doesn't come back - we have let it go for over an hour and the sound never comes back. Pausing then play doesn't fix it. Remote off doesn't fix it. However, if I change the channel, the sound comes back, and if I then go back to 273 the sound is now OK.

    I have not been able to figure out if it always occurs when recording and also watching live, or any other combinations. It is intermittent, but it does seem to happen at least once a day.

    This HR20 is connected via HDMI to the TV for video, but the audio is via optical to a Pioneer receiver. I have another HR20-700 in a different room that does NOT exhibit the same symptoms - and today I confirmed that when the audio dropped on the one unit, the other unit continued to have audio on the same channel with no issues.

    The "changing the channel fixes the problem" sounds familiar - I think I may have read about that somewhere. Changing the channel also dumps the buffer, and I suspect that's a clue - but I have no idea what it means.

    Any ideas?
     
  2. Rich

    Rich DBSTalk Club DBSTalk Club

    33,200
    1,270
    Feb 22, 2007
    Piscataway, NJ
    I do see that occasionally. And I've seen it for a long time. On all my HRs. I usually just hit the "skip back" button and the sound comes back. Really doesn't happen very often.

    Rich
     
  3. LI-SVT

    LI-SVT Icon

    668
    0
    May 18, 2006
    Try setting your audio output to downconvert to PCM. It sounds like the HR20 is having trouble with the HDMI handshake and selecting the correct audio format.
     
  4. BillyBob_jcv

    BillyBob_jcv Legend

    175
    0
    Feb 11, 2006
    Is that a setting on the HR20? If so, where? I can't seem to find it. FYI: I'm using the HR20 optical port for audio, not HDMI.
     
  5. litzdog911

    litzdog911 Well-Known Member

    12,392
    123
    Jun 23, 2004
    Mill Creek, WA
    It's in the "Audio Settings" menu. Turn off "Dolby Digital".
     
  6. BillyBob_jcv

    BillyBob_jcv Legend

    175
    0
    Feb 11, 2006
    So I lose DD5.1? That's OK for a test, but sucks as a long term solution! :(
     
  7. litzdog911

    litzdog911 Well-Known Member

    12,392
    123
    Jun 23, 2004
    Mill Creek, WA
    Just try it as a test.
     

Share This Page

spam firewall