HR21-700 internet not connected

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by 00derek, Mar 7, 2010.

  1. Mar 7, 2010 #1 of 29
    00derek

    00derek Cool Member

    25
    0
    Mar 16, 2008
    AZ
    HR21-700 DVR internet connection is hit and miss. Does anybody have a suggestion? What am I missing, or is something wrong with my DVR?

    My network:

    Cable internet from Cox, 10Mbps download speed.
    --> Modem; Scientific-Atlanta Webstar DPC2100
    --> Router; Belkin Wireless G F5D7230tt4 (DHCP ON) 100Mbps 802.11g
    --> Adapter Slinglink Turbo 1-port (wired)
    --> Adapter Slinglink Turbo 4-port (wired)
    --> Game console Playstation3 (wired)
    --> TV Streaming Slingbox Solo (wired)
    --> DVR Directv HR21-700 (wired)

    DHCP on the router is enabled. My IP address pool is 192.168.2.2~100. Lease time is forever. MAC address filtering is ON, and naturally I've checked, all clients on my network are listed in the router configuration by MAC address and nothing is blocked. No clients are in the "DMZ" meaning nothing is outside the router firewall.

    When I leave my DVR disconnected from the network, EVERYTHING WORKS FLAWLESSLY, I repeat FLAWLESSLY, using the universally understood protocols of TCP/IP etc. Let there be no doubt, there is nothing wrong with my network, except maybe some setting that ONLY the DVR needs.

    I have tried practically everything I have read here on this forum, and others, to get a reliable internet connection. Sometimes it works, sometimes it doesn't. Resetting everything to DEFAULT is not the silver bullet some people are saying. If you got your Directv DVR connected to the internet, congratulations, but you were lucky because the whole process is a lottery. Even when I have gotten it working, it doesn't last.

    Case in point, the DVR manual says use the top ethernet port, if you have more than one. In the DVR/System/Network/Advanced Setup I configured manual settings, and assigned the IP address given by DCHP from my router
    (192.168.2.5). DVR Network Services were on Automatic. After clicking "Connect Now" I got error 22. Ran the DVR system test, DVR said all my settings
    (IP address, subnet mask, DNS, gateway etc. all OK, Network OK, Internet not connected).

    Now the inexplicable part; I moved the ethernet cable on the DVR from the top to the bottom port, tried connect again and bingo, Internet got connected. That was Feb 28 2010.

    Today, March 7th, the ethernet cable is still in the top port, and without making any changes to my network settings the system test says "internet not connected". Even weirder, the Playstation can't get a connection to my network unless I disconnect the DVR ethernet cable. Again, I'm using DHCP but all the clients get the same IP they got the first time they were ever connected, so practically, IP addresses are "fixed".

    Moving the ethernet cable from the top to the bottom port on the DVR has also worked in the past on the advice from Directv phone support. I bet it would work right now, but why does the DVR not maintain it's connection, and why is it blocking the PS3?

    Anyway, I'm tired of messing with this. All my computers, the slingbox and the PS3 were set-up one time and have worked perfectly since then. I'm not a novice when it comes to home networking. Put the DVR on the network and it's a royal pain.

    If you want to stream music and video, try the PS3, it has NEVER had a problem, and the GUI is better than DTV anyway. If you want on demand programming, get Netflix and use their Instant Queue.

    Cheers.
     
  2. Mar 7, 2010 #2 of 29
    DogLover

    DogLover Hall Of Fame

    2,510
    0
    Mar 18, 2007
    Well, the first problem is that you should not be using Advanced setup and setting manual settings if you want to use DHCP. Advanced setup sets a static IP, which is mutually exclusive of using DHCP. If you use a static IP, it must be set outside of the range that you have reserved in your router for DHCP.

    You may have other problems, but that is the first one to fix, as it is a big one, and may be all of your problem.
     
  3. Mar 7, 2010 #3 of 29
    00derek

    00derek Cool Member

    25
    0
    Mar 16, 2008
    AZ
    OK Thanks. I assume I should fix it by doing "restore defaults" on the DVR?
     
  4. Mar 7, 2010 #4 of 29
    DogLover

    DogLover Hall Of Fame

    2,510
    0
    Mar 18, 2007
    That will take it back to DHCP, which I think is what you want for now. If that gives you problems, then you can go back to manual (static) addressing, but assign it an address out of the range of the DHCP addresses.
     
  5. Mar 7, 2010 #5 of 29
    dennisj00

    dennisj00 Hall Of Fame

    9,690
    196
    Sep 27, 2007
    Lake Norman, NC
    In the advanced setting of your dvr, set it to something like 192.168.2.110 (outside of the dhcp range), mask 255.255.255.0, gateway 192.168.2.1 / dns same.

    You might also check with your cable company to put their modem in bridge or transparent mode.

    Things should connect fine.
     
  6. Mar 8, 2010 #6 of 29
    00derek

    00derek Cool Member

    25
    0
    Mar 16, 2008
    AZ
    OK, I tried both ; I presumed I should leave the router in DHCP. If not, please clarify.

    1. After restore defaults, I rebooted my router, and the dvr. No connection to network or internet; when I look at the advanced setup the IP address is 169.254.7.72, subnet is 255.255.0.0, default gateway and dns are blank. I assume "restore defaults" on the dvr is equivalent to "obtain an IP address automatically" on a windows pc, so why are these fields blank? If that's not what "restore defaults" is doing, what does it do?

    2. Setting the IP address to 192.168.2.110 gets a connection to the network but not the internet.

    Do I need to configure my firewall to add ports for the DVR?

    What puzzles me is that I can get it to work well, for a while, by assigning a "static" IP, within the DHCP range e.g. 192.168.2.5. If that's a problem, why does it work at all?

    Thanks for the help so far.
     
  7. Mar 8, 2010 #7 of 29
    trekologer

    trekologer Legend

    127
    1
    Jun 30, 2007
    It doesn't make much sense to apply the MAC filtering rules to the wired connections but some consumer routers stupidly do so. Try turning that off.
     
  8. Mar 8, 2010 #8 of 29
    alnielsen

    alnielsen Godfather

    748
    24
    Dec 31, 2006
    ...- .....
    The DVR uses 2 port #'s (27177 & 12178) for it's internet connection. In your router, forward those ports to your DVR's IP address. Or, just set the DVR's IP in the routers DMZ.
     
  9. Mar 8, 2010 #9 of 29
    MizzouTiger

    MizzouTiger Icon

    645
    5
    Jan 9, 2007
    If you are going to manually assign the IP address to the HR20 through the advanced network settings of the receiver, then make sure you have "reserved" that IP address for the receiver on your router also. If you are assigning the IP address on the receiver itself, but not reserving it on the router, the router might be trying to assign a different IP address to the receiver.

    I think I have this right. I'm not as up on this stuff as others on this forum are, so please feel free to correct any mistakes I have made.
     
  10. DogLover

    DogLover Hall Of Fame

    2,510
    0
    Mar 18, 2007
    1. Since the DVR came up with a "169..." address, that means that it could not get an address from the DHCP server. (The DVRs will assign themselves unique addresses in this case. This allows them to be wired to each other without a router if MRV is only network function desired.)

    2. This makes sense given the above. When you set a static address, it can see the network, but still can't see the router, so it can't get to the internet.

    I would agree with the poster that indicated that MAC address filtering doesn't provide a benefit on your wired connection. If you can, you might try turning that off. (If you don't turn it off, you should triple check the MAC address. It's really easy to make a typo on those.)

    You should not need to forward any ports for the DVR to work correctly.
     
  11. TheChaos

    TheChaos Mentor

    36
    0
    Aug 16, 2006
    just go DHCP in general and do a static route on the device its self. as long as your static addresses are within that range you posted of 192.168.2.2-100 it will work fine.

    on my network its both static and dhcp addressing using the range of 192.168.10.100-110

    desktop:dhcp - 192.168.10.100
    wireless desktop:dhcp -192.168.10.101
    ipod touch:dhcp - 192.168.10.102
    192.168.10.103-108 dhcp addresses available for anything

    static routes - configured on the devices
    192.168.10.109 - wireless printer
    192.168.10.110 - HR21

    when you do the static route on the devices you obviously put the ip address you want within the range of 2-100 and its not being used by another device, make sure the subnet mask is all the same, and since you have a belkin router, the default gateway is 192.168.2.1 (or whatever you changed it to), and the DNS server as the default gateway address (it will use whatever DNS server is being used on your network which can be assumed it is your ISP's DNS server).
     
  12. DogLover

    DogLover Hall Of Fame

    2,510
    0
    Mar 18, 2007
    Actually, static addresses (set on the device) should always be outside of the range of DHCP. The DHCP server doesn't know about the static devices, and potentially could assign that address to another device. (You probably haven't had a problem, because most routers begin assigning DHCP addresses with the lowest number. But you have opened yourself up to the possibility that you would have 2 devices trying to use the same IP, which would usually cause both devices to not work.)
     
  13. 00derek

    00derek Cool Member

    25
    0
    Mar 16, 2008
    AZ
    Thanks.

    1. I understand. The DVR can't see anything and uses it's default network settings.

    2. I don't understand. If the network connection is OK, surely the DVR can see the router, since the router is the hub of the network? OTOH the router doesn't see the new IP address I assigned to the DVR manually; there's a client list in the router configuration that shows every IP address in use, the name of each device and it's MAC address. What bugs me about this router is that the IP address for the DVR never changes from the ***.2.5 it used before, even when the DVR is not connected to the network. If I assign a static IP at the DVR, how do I tell the router that this IP address is reserved? I know you probably aren't familiar with my specific router, but in general terms, is this a feature that most routers have?

    MAC filtering is not the problem. I know it's easy to make a typo, but the DVR did work for days when it was first connected, then it stopped. If there was a typo it would have never worked.

    So, going forward, I need to;

    1. assign a static IP and also reserve that IP on the router, outside the DHCP range, if I can figure out how.

    OR

    2. Reset my router to factory and go all static IP on all my network devices?

    OR

    3. Reset router to factory, use DHCP to issue brand new IPs to all devices?

    anything else I could try?
     
  14. Stuart Sweet

    Stuart Sweet The Shadow Knows!

    37,060
    288
    Jun 18, 2006
    I'm moving this to the HD DVR forum.
     
  15. Avder

    Avder Hall Of Fame

    1,395
    0
    Feb 6, 2010
    Okay, so using DHCP is hit or miss, and if you set up the box with a static IP it occasionally prevents the PS3 from working correctly.

    There are a couple of things you can do.

    You stated that you have the DHCP lease set to unlimited, correct? I suggest changing that. Give it a lease time of anywhere from an hour to 24 hours. I also suggest shrinking your DHCP pool from 98 possible addresses to something around 20. Start it at .20 and end it at .39 or so, that way .2 to .19 can be assigned manually, by you, for devices that need a static address.

    What devices need a static address? Any device that needs to have a port forwarded. I'm not sure if the HD DVR boxes *need* to have a port forwarded (mine works fine with a DHCP address and nothing forwarded to it), but if you want forwarding to work you must give the device a static address or else those forwarding rules you create will not work all the time.

    You also said that when you assign an address manually your PS3 does not work all the time. This is quite possibly because you are creating an address conflict by assigning a static address inside your DHCP pools address range. You give your DVR .3, but because your router things the .3 lease is available, it assigns it to whatever asks for it, likely your PS3. So now you have two devices on your LAN with the same address. Problems start showing up. As has been said before, give your static boxes addresses outside the DHCP pool range. That will fix this problem.

    Also, you say you have all of your devices mac addresses in the whitelist on your router? Does this whitelist apply to wired clients? In my experience, most consumer routers only have white and black listing for wireless clients. I do not know if that is the case with a Belkin as I have never worked with one of those, but it would be new to me if the whitelist applied to wired clients.

    Do you have any wireless devices in your home? Do you ever have guests over that use your wireless? If the answer is no you should disable your wireless completely as a security measure.

    Anyway, if you change your DHCP pool range and give the lease a proper time limit, it should help if you are still using DHCP to set up your box. If not, give it an address outside the pool range, make sure you set up the gateway and DNS servers properly, and that should work also.

    If you need any more help, feel free to send me a PM. I went to school for a few years for this stuff, so I know a bit about what I'm talking about :)
     
  16. DogLover

    DogLover Hall Of Fame

    2,510
    0
    Mar 18, 2007
    2. I think what happens is that the "switch" part of your router can send the DVR traffic around your internal network. However, the router part (that contains the DHCP assigner and the access out of the network to the cable modem) isn't recognizing the DVR.

    When you assign the address statically on the DVR, the DHCP part of the router doesn't need to know about the DVR. The modems I've had have no way to see any static addresses on the network. (That is one of the disadvantages of static addresses, the only way to see them is usually on the device itself.)

    So, your choices are correct, except that with #1, you don't have to do anything on the router. Of course, that's what you tried that isn't working. I would agree with you that if you haven't changed the MAC addresses and it used to work, it would seem that is not the problem. I can't imagine the MAC address on DVR changing, but if you can turn off the filtering for wired connections, it's worth a try.

    We are quickly getting to the end of my networking knowledge. If one of the above doesn't work, hopefully others will pipe in with more ideas.
     
  17. The Merg

    The Merg 1*

    10,289
    35
    Jun 24, 2007
    Northern VA
    Something else you can look at is using static DHCP addressing. This is exactly what it implies. You use DHCP on the router to assign an IP address. You pick one IP address in that range that will be the DVR and set up the DVR with that IP address. On the router, in the section for static DHCP addresses, you specify the MAC address of the DVR and the IP address it is supposed to have. The router will never assign that IP address except to the DVR then.

    I use that for my Wii, DVR, printer, and main laptop so I will always know what IP address they are and for port forwarding.

    - Merg
     
  18. DogLover

    DogLover Hall Of Fame

    2,510
    0
    Mar 18, 2007
    That is a good idea. Gives the benefit of using DHCP and seeing the addresses from the router, but also the addresses don't change. It may be called reservations, or something like that on your router.
     
  19. Avder

    Avder Hall Of Fame

    1,395
    0
    Feb 6, 2010
    If his router supports it, that would be great. A lot of consumer routers dont.
     
  20. The Merg

    The Merg 1*

    10,289
    35
    Jun 24, 2007
    Northern VA
    That's one of the main reasons I use it.

    True. I use Linksys routers, which don't have static DHCP capability with the stock firmware. I flash DD-WRT on it so that I have that ability. I did check and the Belkin Derek lists can be used with DD-WRT depending on what revision it is.

    - Merg
     

Share This Page

spam firewall

Advertisements