Internet And Server Connection Failed

Discussion in 'Hopper System Support Forum' started by Blowgun, Jun 19, 2015.

  1. Blowgun

    Blowgun DHMO User

    1,095
    43
    May 23, 2008
    Western Arc
    Due to the router log getting filled up with WLAN traffic from both Hoppers, I decided to ease the traffic by moving one of the Hoppers to a LAN port on the AP that is nearby. This nearby AP, which is fed from the primary router via Cat6 cable some distance away, is a secondary router that has been configured to work as an AP. This same AP currently and successfully supplies Internet access via LAN for the AVR and TV in the same area as the Hopper.

    The problem is, while the Hopper shows that it was assigned an IP, the Hopper does not see further down the chain to the router and ultimately to the Internet. While at the same time the router sees both the AP and the Hopper in the router's Attached Devices list. This results in the Hopper thinking it is not connected to the Internet and two red X's appear between the router and Internet icons in the Broadband settings. Because the Hopper can not see the router and the Internet, the Hopper then assigns a Google DNS on its own, but fails the Internet and Server Connection in the Network Details. The Network Connection says, "Internet Not Available". Which technically is not true since the router can see both the AP and the Hopper's IP addresses.

    I have rebooted the Hopper, I have pressed the "Reset Network" button in the Broadband settings and I have reset both the AP and the router all several times. Because the AVR and TV have no issues accessing the Internet, I believe the AP and the router are configured properly. This is further confirmed by successfully pinging the Hopper's IP address from the computer and at the same time watching the RX/TX packet count on the Hopper accelerate during the ping. In addition, I believe if the Hopper had a real Broadband configuration this would not be an issue.

    Has anyone successfully used an AP to connect their Hopper to the Internet?
     
  2. Stewart Vernon

    Stewart Vernon Roving Reporter Staff Member Super Moderator DBSTalk Club

    21,627
    396
    Jan 7, 2005
    Kittrell, NC
    Since you have two Hoppers... Do you have bridging enabled? IF you have both Hoppers directly connected to the Internet, then Hopper's bridging features might cause problems. Also, if you only connect one Hopper to Internet but enable bridging on both Hoppers you can again have problems.

    My suggestions to try...

    IF each Hopper is directly connected to Internet, check both Hoppers (Menu -> Settings -> Network Setup -> Broadband, then click Network Details and click Bridging after that) and make sure Bridging is disabled for both of them.

    Alternate suggestion... Pick a Hopper, either Hopper, connect that to the Internet... on THAT same Hopper do the above but enable Bridging... and make sure Bridging is disabled on the other Hopper.

    See if either of those helps you out.
     
  3. Blowgun

    Blowgun DHMO User

    1,095
    43
    May 23, 2008
    Western Arc
    It is my understanding that Bridging is only necessary when you use MOCA. Each hopper is directly connected to the Dual-Node and no MOCA or Joey's for that matter, are involved. I checked the Hopper nears to me at the moment and Bridging is disabled. Without verifying, I am almost willing to bet that the other Hopper has Bridging enabled. I'm going to fiddle with this again later tonight and see if I can get it going.

    Thank you for your suggestions.
     
  4. Stewart Vernon

    Stewart Vernon Roving Reporter Staff Member Super Moderator DBSTalk Club

    21,627
    396
    Jan 7, 2005
    Kittrell, NC
    MoCA is always there... even if you have no Joeys. MoCA is also how the Hoppers communicate with each other... and if bridging is enabled on either, or both, it will also try and get IP addresses even if you already have them from direct connections of each Hopper. It isn't quite smart enough to see that it is already connected, and basically tries to connect (apparently) every way that it can!

    So... yeah, if you don't have Joeys and both Hoppers are already directly connected to Internet, check that other Hopper and make sure bridging is disabled on it as well as the one you already verified.
     
  5. FarmerBob

    FarmerBob Godfather

    690
    13
    Nov 27, 2002
    I had the same problem in the beginning and was talking to my rep at DISH and they had no clue. Hoppers are very needy and network hungry. My network went to a crawl with all the constant, even when they were off, network requests and address hopping. After quite a bit of watching what was going on and monitoring the router, the way I fixed it was as Stewart suggests, is turn on Bridging so that all the peripherals share resources from one source. My main HwS is hard wired, even though the other two devices are feet away from the router, with bridging turned on and our second HwS and Joey all get it from the one source. Although all three devices get allocated individual IPAs, part of the "needy" part and are always jamming up the network, so I gave them each an IPA Reservation based on their MAC addresses so they would not be address hopping and the traffic load decreased dynamically. Oh and no QoS turned on. It only causes more problems.

    One day I was playing and changed the second HwS to a WiFi direct connection and all went to pot. Even though it had a reserved IPA. Switched it back to grab through the system source and everything calmed back down. I'm thoroughly amazed that with this supposed level of "hardware sophistication" that this type of thing was not either foreseen or discovered through R&D and dealt with. One communication with DISH I asked that this be officially submitted as a bug. I don't think it was. I have never seen a device(s) that play so poorly on a network compared to the millions of other devices in the world. Once again DISH is doing their own thing and ignoring the status quo.

    The best thing is to isolate and restrict them as much as you can. Until DISH addresses this . . .
     
  6. Blowgun

    Blowgun DHMO User

    1,095
    43
    May 23, 2008
    Western Arc
    I guess the issue started when the Hopper would not let go of the previous 192.168.1.111 wireless configuration. Despite connecting a cable to the Ethernet port and resetting the Hopper's network settings a bunch of times, the Hopper seemed to insist on connecting through wireless. To prevent that I changed the SSID to a made up one and later restricted the Hopper on the router. Yet the Hopper kept thinking it was connected wirelessly. Well, at least half of it did, the details told of a different story and certainly the router was showing the Hopper as blocked. Only by narrowing the DHCP pool, basically starving the Hopper of the IP address it loved and held so dearly, did the Hopper finally throw it's electronic hands in the air and a assign a 169.x.x.x address -- which typically happens to avoid conflicts when a private address can not be obtained by a device.

    Later after fiddling with it more, the Hopper reported it had a 192.168.1.120 IP address. That IP address did not come from the router. Looking back on it now, it was probably something the Hopper came up with, likely the same way the Hopper decided on it's own to use Google DNS. I did not know that at the time, but when I saw the Hopper with that IP address I figured that the Hopper switched to a static mode -- even if it was guesswork on the Hopper's part -- it was still a vacant and valid static IP address. So I figured we were making progress. We had LAN access, but no WAN access across the same multiple hops. No place to add any other information.

    Anyway, because static was going nowhere, I decided to go back to DHCP. Because I had to narrow the DHCP pool earlier to stop wireless access, I had to widen the DHCP pool for the Ethernet port. The Hopper then changed it's IP address to 192.168.1.113 and once again the Hopper had conductivity.

    My entire network is static, which includes a combination of old and new AVRs, laptops, desktop computers, routers, servers, HDTVs, basically everything else but the Hoppers. I'm not suggesting DISH should do away with DHCP. No, far too many people need dynamic. Instead, DISH should allow for both dynamic and static configurations. This would never have been an issue if I was allowed to configure the Hopper's network settings myself. And, on the outside chance, if this was the Hopper's ability to automatically switch from dynamic to static, if that was the case, then there is something seriously broken.
     
  7. Blowgun

    Blowgun DHMO User

    1,095
    43
    May 23, 2008
    Western Arc
    Except in my case, one Hopper is intentionally isolated and so the MOCA signal bar shows zero.

    I checked the other Hopper and Bridging was enabled. I disabled it, so now both Hoppers have bridging disabled.

    Thanks again.
     
  8. Blowgun

    Blowgun DHMO User

    1,095
    43
    May 23, 2008
    Western Arc
    No question that DISH needs a better logging system for bug reports. Going the CSR route is hopeless. Since August of last year I reported three different times that the CW Network was showing the Univision logo and vice versa in the EPG. Maybe CW is not in HD in someway because of that, who knows, anyway, it is still that way. I tried to explain to two different CSRs that there was a issue with the no authorization and On Demand, got nowhere. All five said they would submit a bug report. So it really doesn't surprise me that others who report bugs are not taken seriously. I remember the old days when you could speak with an engineer.

    Yep, just like not including an option for a static network. I swear this is true, when I first set up the wireless connection and saw that it didn't have a static option, I really thought halfway through entering the wireless WPA2 passkey that the Hopper was going to stop accepting input. I figured that DISH probably thought why include space for all 64 hexadecimal characters, who uses that.

    I have bridging disabled on both and one Hopper is isolated. Network traffic has reduced. Instead of receiving a router log once a week, maybe I'll get one every two weeks. I can almost live with that. ATM my old IP wasn't renewed and I'm getting the prior owner's DoS garbage. Probably have to do a IP change. Perhaps then I'll get two and a half weeks after that. :)
     
  9. FarmerBob

    FarmerBob Godfather

    690
    13
    Nov 27, 2002
    And I even told a "Installation Instructor", the guy that did my HwS install, that with my help and reevaluation of the job took his, as he told me, 9 hour installation plan down to 3.5. And most of that was because he wouldn't get on my roof where the dish was waist height and came up the 30 foot brick face of the chimney to drill the 6 anchor holes for the new dish that he said wouldn't hold, that now he has had a taste of 55 year old concrete which I told him it would be a bear, said worked so well that the antenna itself is legally an anchor point for roof access. So he knew what I was talk about. Also I'm on the list for "credible sources". If one exists. I'm still complaining about Tribune and their erroneous info that they use for the guide. Have been for years. That one I know they are just plain lazy.

    Since day one every time I set up a network I always give the important and troublesome devices address reservations via their MAC addresses. That way they get locked into a sudo static IP state at the router and it doesn't matter what the box can or can't do. That really stopped the IPA hopping.


    I think if you do as I spoke of above with address reservations, that I consider part of the isolation process, it just might smooth things out. You need to take back the control that the HwS take. Set your main HwS to Bridge and leave the other alone. And see what happens. Let us know if this works for you. When I did it all the lights on the hubs and whatnot all stop the constant flashing from HwS activity. I hope this helps, if not solves the problem. Good Luck...

    . . . fb
     
  10. SJ HART

    SJ HART Legend

    145
    0
    Feb 11, 2003
    I have a two hopper setup with no Joeys. I often have to reset the network to get things connected back to the Internet. Is there any reason to have bridging on? I have both directly wired to my network. I'll turn bridging off on both units and see if that helps. Thanks. SJ
     
  11. FarmerBob

    FarmerBob Godfather

    690
    13
    Nov 27, 2002
    As I have described above, the best thing is to connect one HwS to your network and turn on Bridging on that unit and leave it turned off on the other unit and disconnect it from the network. And if possible give both units IPA Reservations to keep them from network hopping. So far mine has cruised along nicely with only MoCA dropping every so often. But it reconnects quickly. I have also noticed the other units accessing Internet related features much quicker now.
     
  12. SJ HART

    SJ HART Legend

    145
    0
    Feb 11, 2003
    After turning off bridging on both units (which are both hard wired to my network), have not had a single issue. Thanks. SJ
     

Share This Page

spam firewall