1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Manually configuring a router for DIRECTV’s TVApps.

Discussion in 'DIRECTV Connected Home' started by Draconis, Jun 30, 2009.

  1. Draconis

    Draconis New Member

    Mar 16, 2007
    Las Vegas, NV
    The DIRECTV HD-DVR normally uses Universal Plug and Play (UPnP) to automatically assign the ports needed for TVApps to function.

    However, some of the older routers do not support UPnP. If you are having problems getting TVApps to work you may have to configure these ports manually.

    A good introductory article for setting up the ports on your router can be found here:

    Introduction to Port Forwarding

    A note for the security-minded folks. Yes we are opening a hole in your routers defenses, however, it is for only 2 ports that are also assigned to 1 specific IP address so this cannot be used to infect your computer.

    Setting up the router:

    The first step in manually configuring your router is to determine the “Default Gateway” you computer is using.

    On a Windows-based PC you would click on “Start” then “Run”. Type in “CMD” and then click on “Ok”.


    This will open a command prompt. In the command prompt type in “IPCONFIG/ALL”, the computers TCP/IP settings will be displayed. Find the Default Gateway and write it's address down.



    Once the Default Gateway is known, open your web browser and enter that number into the address line. Your router will prompt you for the password to access it. If you do not know your routers password please consult with the routers manual. If you do not have the manual you can usually look up the manual online.

    If your router is not accepting the default password someone may have changed it. Find the person who setup your router for further assistance.

    Only in extreme cases would you press the reset switch on your router, this will change the routers password back to the default password, but it will also clear any Point-to-Point Protocol over Ethernet (PPPoE) settings DSL users would be using and it would also clear any wireless security settings.

    Should a DSL users PPPoE settings get cleared they would have to contact their ISP for the correct settings to reconfigure the router to work with DSL.

    Also, it is NEVER recommended to use a un-secured wireless router. If you have a wireless router and use the reset switch please make sure you re-enable the security settings.

    Once you have access to the router you need to decide what IP address you want your DIRECTV HDDVR to have and what ports you want it to use. The IP address does need to be manually set and care needs to be taken to make sure the number does not conflict with any other device on the network. I chose a higher number and configured my units to and above.

    Remember: Check the IP range your router supports before setting the IP addresses.

    The DIRECTV receiver can use ports from 27161 to 27192.

    Do NOT set the port forwarding to the entire 27161 to 27192 range, choose 2 sequential numbers for each IRD.

    The screens for opening the ports will be different for every router. I have found that SlingMedia has a very good site for walking you through this. (You just substitute your IP address and port information instead of using the info for the SlingBox while going through the walkthrough).

    Slingbox Network Setup Assistant

    This screen is from my router and illustrates how the system should look once the ports have been configured.


    Setting up the HDDVR:

    Once the ports have been opened on the router you will need to change the network settings on the HDDVR.

    On the remote press Menu then select Parental Faves & Setup > System Setup > Network > Advanced Setup.

    If you have already setup your network the only thing you need to change is the IP address to match what you put into the router earlier.


    (If you are setting up the network from scratch you can find the rest of the information by running IPCONFIG/ALL as illustrated earlier.)

    If you get an error after clicking on “Connect Now” you will need to re-check your router settings.

    Once the IP address has been manually assigned you will need to assign the ports for the Network Services. This is also on the Network screen but you would select “Network Services” instead of “Advanced Setup”.


    Change the Configuration Type from “Automatic” to “Manual” then change the STB Services Port and Audio Services Port to the numbers you assigned earlier when setting up the router.

    Finally, click on “Connect Now” or “Test Connection”, if everything is configured correctly you should be up and running. If not, recheck the settings on both the IRD and router.

    Thanks to smiddy for proof-reading this for me and thanks to bobnielsen for the Mac info.

    If other members had to manually configure their router and have a different brand than mine I encourage you to post a screen shot of your configuration so other members can see the setup on a different model router than mine.

    If all else fails, remember to read your routers manual.

    Attached Files:

  2. Jul 1, 2009 #2 of 17

    bobnielsen Éminence grise

    Jun 29, 2006
    On a Mac, click on System Preferences and select Network, then Built-in Ethernet. There will be a screen like the attachment, which will show the router IP address (i.e., the gateway), along with other information.

    This information can be found on the DVR's System Information display and on the system setup network menu under advanced setup (even if you have let it be configured automatically via DHCP).

    Attached Files:

  3. Jul 1, 2009 #3 of 17

    JoeTheDragon Hall Of Fame

    Jul 21, 2008
    I Forwarded the ports and I still get the 301 error but all other network stuff works.
  4. Jul 1, 2009 #4 of 17

    Athlon646464 Gold Members DBSTalk Gold Club

    Feb 23, 2007
    Uxbridge, MA
    Drac - great job, and thanks. This should be a sticky, or at least linked to from the various help guides here.....

  5. Jul 1, 2009 #5 of 17

    fineware AllStar

    Jun 12, 2007
  6. Jul 1, 2009 #6 of 17

    DJPellegrino Godfather

    Nov 17, 2005
    At times, you need to wait a bit for everything to sync up before it is recognized.
  7. Jul 1, 2009 #7 of 17

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    Dec 9, 2006
    I've found sometimes a reset or trying to manually start the network services will get this to work [with the 301 error]. 602 error seems to be a bit harder to clear. Lately I found going into advanced networking and forcing "connect" would clear the 602, but still needed to manually start N/S for the "5000" to show under the system info. 5000, 5001, etc. seems to reflect a working status for TVApps [here].
  8. Jul 2, 2009 #8 of 17

    mickcris Legend

    Mar 16, 2008
    Just a warning that this may not work for everyone. I had tried to do this on my Linksys BEFSR81 a while ago and it did not work. The router is an older version (probably about 6 - 7 years old) which may be one of the reasons. I finally gave up and decided to pick up a cheap replacement.
    I ended up purchasing a refurbed netgear WNDR3300 for about $30 from newegg and flashed it DD-WRT. TVApps now work without having to change any settings in the router.
  9. Jul 2, 2009 #9 of 17

    luth316 Cool Member

    Jul 30, 2004
    Have waited 2 days and still the "301" error. Tried several reboots of the receiver to no avail-soft and hard. Any other suggestions?

    *Like a lot of other people, the DOD and Media Share both work fine as well
    as Directv2PC.
  10. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    Dec 9, 2006
    Have you tried manually starting network services?
  11. JoeTheDragon

    JoeTheDragon Hall Of Fame

    Jul 21, 2008
    where is that at?
  12. veryoldschool

    veryoldschool Lifetime Achiever Staff Member Super Moderator DBSTalk Club

    Dec 9, 2006
    Setup menu/network/network service/start .....
  13. Draconis

    Draconis New Member

    Mar 16, 2007
    Las Vegas, NV
    Article updated with the Mac info posted by bobnielsen, thanks.

    mickcris, one thing that threw me off when I first configured my Linksys BEFSR81 was that little checkbox to the right where it says "Enabled". You can have all the correct IP information there but it will not work unless that box is checked.
  14. mickcris

    mickcris Legend

    Mar 16, 2008
    You have a newer version of the router than me. I have a ver. 2 and has really old firmware (Ver.2.45.10 released in 2004) that I cannot update. It is probably the firware that it is the reason that it will not work. When I tried port forwarding, i did have the checkbox enabled. I messed with it for hours trying different settings and nothing worked. I am not worried about it anymore as I disconnected it.
  15. woj027

    woj027 Icon

    Sep 3, 2007
    Portland, OR
    Hey all, I don't want to sidetrack this thread, but any recommendations on a good/better/best wireless router? Do I have to get 2.4/5 GHz? And G/N? I have looked online and the most recent review of anything is from november of last year.
  16. mfeinstein

    mfeinstein Godfather

    Sep 1, 2007
    I was also able to get TVApps to work without having Network Services working. However, this procedure did get Network Services to work with my Linksys router. It used to work with uPnP, but for some reason that stopped working. The manual configuration does work, but, as I said, TVApps was working before Network Services was.
  17. thekochs

    thekochs DirecTV 10yr+ Customer

    Oct 7, 2006
    I recently upgraded a H20-600 to HR23-700. I also have a HR20-700. I went into these and tried the MRV Beta and works....after setting static IP addresses, etc. Funny I tried to re-enable STB Services Manually with 27161-27162 & 27163-27164 and came back setup but connection failed....what got it to work was going back and using the Auto command on Starting Services. The ports show as greyed out since Auto but in the Info page show above listings.

    Anyway, me question is....saw an old post about going to SEARCH function and typing in WIDGETOFF. This was some old trick to get Services to work ?...or TVApps...honestly I forget. What does it actually do ?....assume default is some "widget " on...which is ? Thx.

Share This Page