1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Multi-Room Viewing and Static IP Addresses - Discussion

Discussion in 'DIRECTV Connected Home' started by The Merg, Oct 23, 2010.

  1. mrdobolina

    mrdobolina AllStar

    396
    15
    Aug 28, 2006
    A Mile High
    DHCP Reservations - I've heard about this, but for some reason I've never really understood it. I start to read up on it and am immediately confused.

    RR - I'm pretty green in the area of routing/networking, too. Only really recently "dug in" to it when I started getting my receivers all networked. Static IPs are assigned at the DEVICE level, not at the router level. For instance, you set the static IP for a sat receiver via the receiver's menu on the Advanced Networking menu page.

    I'm still not sure I want to even attempt to get into the WCCK's setup page. I'm kinda thinking I'll just leave well enough alone! :grin: It might be fun to try as a weekend project, though.

    *just saw your reply. Sounds like you don't have any green on you!
     
  2. Richierich

    Richierich Hall Of Fame

    8,489
    7
    Jan 10, 2008
    The reason I don't have a problem when I leave home is that I have "Reserved" IP Addresses that I refer to as "Quasi" Static IP Addresses that are Assigned by my Router and Not at the Device Level. They are "Static" in that their IP Address is Never Changed but just Reassigned to the same IP Address.
     
  3. dennisj00

    dennisj00 Hall Of Fame

    9,689
    195
    Sep 27, 2007
    Lake Norman, NC
    Which really means you're using DHCP and all the discussion about STATIC addresses for your laptop is moot!
     
  4. Richierich

    Richierich Hall Of Fame

    8,489
    7
    Jan 10, 2008
    No, it is not Moot as not everyone knows the difference between the two. :)
     
  5. Bluegrassman

    Bluegrassman AllStar

    62
    0
    Feb 18, 2009
    I'd like to thank you guys for the excellent info and the write up in the FAQ regarding multiroom viewing and static ip
    It took only a few days before I began having issues with my DVRs dropping out. Assigning a static ip outside of the DHCP range to each DVR completely solved the problem. And that is such an unbelievably easy fix!! Thanks again, you guys rock! :icon_bb:
     
  6. Oct 7, 2013 #366 of 393
    chicho.misho

    chicho.misho New Member

    1
    0
    Oct 6, 2013
    Greetings,

    New member here, registered specifically to share my experience troubleshooting whole-home/MRV. I believe it may help others and add more detail on how MRV works to the knowledge base of this forum.

    As a beta tester of whole-home I was allowed to keep using it with my initial (current) setup - wired ethernet, no DECA (and no support).

    My equipment:
    • 2 x HR22-100 DVRs
    • 1 x H23-600 receiver
    • 1 x HR10-250 DVR (Tivo) - doesn't play with other equipment in MRV
    • Buffalo WZR-HP-G300NH router running Buffalo firmware (not DD-WRT)
    Everything has been working fine for over 2 years (when I got the router) until mid August this year. Then the two HR22's started losing connection to each other (occasionally at first), as well as the H23 could not see the DVRs. First I thought it might be related to the software update my DVRs received on 8/14, as I haven't done any changes to my network. Other functionality like DIRECTV2PC and VOD was not affected, so the network was fine - all DirecTV equipment was using DHCP at the time. Then at some point MRV went completely down (DTV2PC and VOD still working), but I didn't have much time to troubleshoot...

    This weekend I finally decided it was time to get it fixed as the NHL season began and I really use MRV during the season. First thing was to set up the DVRs with static IPs - didn't help. Rebooting everything, including the router worked for few minutes, then connectivity between DVRs went down again. I tried many other things like changing the gateway on the DVRs so they don't have Internet access, or subnet mask (to change their broadcast) - nothing worked. Only when the router was powered off, the DVRs could see each others recordings - they are connected to an internal gigabit switch, not directly to the router, so LAN is still up when the router is off.

    I was about to get started with installing DD-WRT firmware on the router, but I noticed that every time I made changes to the network settings on the DVRs, Windows Media Player (Library View) was showing the DVRs for a few seconds, then they would disappear for a few (not at the same time), and so on for about 2 hours. After that they would stabilize and stay in WMP - confirmed it on multiple PCs. That got me thinking in a different direction (after replacing several LAN cables) and I ran "arp -a" on the PC and saw a bunch of 169.254.x.x entries, all with the MAC address of my router. I did a traceroute on few of them, and they were all going out outside my LAN to my ISP (TWC).

    Some of you probably know about "Link-Local" address space - 169.254.0.0/16. More info here http://www.ietf.org/rfc/rfc3927.txt

    You can also see Link-Local as the last line in Advanced Network settings on your DVR. If it is empty, MRV will not work!

    It turned out that one (or more) of my ISP routers advertise routes to 169.254.x.x, so these routes were picked up by my Buffalo router and all packets in the 169.254.x.x address space were forwarded there. That explains the 2-hour "hesitation" shown in WMP - the DVRs were changing their Link-Local addresses in an effort to establish connectivity, but everything was being forwarded outside my LAN.

    Once I figured it out, the fix was easy - added a static route on my Buffalo - 169.24.x.x is sent back to one of the DVRs 192.168.x.x address. MRV came back right away and is rock-solid.

    Not sure who's to blame here - my router, or my ISP - but I'm leaning towards the ISP, as 169.254/16 is not supposed to be routed, see the link above. A cheap home router is excused from not adhering to the RFC standards, but an ISP is not.

    Be aware that while the DVRs are using the assigned IP for VOD and DIRECTV2PC, they use Link-Local 169.254.x.x to communicate between them.

    Hope this helps.
     
  7. Oct 9, 2013 #367 of 393
    lflorack

    lflorack Godfather

    473
    0
    Dec 16, 2006
    I've had two HR20's for several years connected via hardwire and running in LAN/unsupported Whole Home mode - using DHCP addresses and never had any issue with DVRs disconnecting until about 10 days ago. Rebooting one or both of the DVR's would fix thie issue for a while. A few days after that started, I upgraded one of the HR20's to a Genie (HR44-700) and for the first day or so, the issue continued with the remaining HR20. Then it settled down, To avoid future issues, I decided to set up the DVRs with fixed IP addresses (NOT DHCP Reserved addresses) as is being discussed in this thread. So, I set up the HR20 with a fixed IP address that was outside of the DHCP pool and it worked fine. The DVRs talked to each other well and the recorded lists were shared, recordings were shareable, etc.

    Here's my potential issue and question (sorry if it's a stupid question). I use the iPad/iPhone-based Roomie Remote to control my two A/V systems. Roomie uses IP addresses to control IP capable devices (including the DVRs). Devices that are only IR capable are controlled via an IP to IR converter. Anyway, Roomie can't see the DVR with the fixed address. (BTW, I will also pursue this issue with Roomie.) The question for the experts here: Does the use of the DECA/Coax network for the DVRs or the use of fixed IP addresses somehow hide the DVR(s) from my home network? Roomie can't seem to find the DVRs with the fixed address and I don't see the hardwired/fixed IP DVRs on the Router either.

    Thanks in advance.
     
  8. Oct 9, 2013 #368 of 393
    peds48

    peds48 Genius.

    20,082
    1,068
    Jan 10, 2008
    NY
    I've had two HR20's for several years connected via hardwire and running in LAN/unsupported Whole Home mode - using DHCP addresses and never had any issue with DVRs disconnecting until about 10 days ago. Rebooting one or both of the DVR's would fix thie issue for a while. A few days after that started, I upgraded one of the HR20's to a Genie (HR44-700) and for the first day or so, the issue continued with the remaining HR20. Then it settled down, To avoid future issues, I decided to set up the DVRs with fixed IP addresses (NOT DHCP Reserved addresses) as is being discussed in this thread. So, I set up the HR20 with a fixed IP address that was outside of the DHCP pool and it worked fine. The DVRs talked to each other well and the recorded lists were shared, recordings were shareable, etc.

    Here's my potential issue and question (sorry if it's a stupid question). I use the iPad/iPhone-based Roomie Remote to control my two A/V systems. Roomie uses IP addresses to control IP capable devices (including the DVRs). Devices that are only IR capable are controlled via an IP to IR converter. Anyway, Roomie can't see the DVR with the fixed address. (BTW, I will also pursue this issue with Roomie.) The question for the experts here: Does the use of the DECA/Coax network for the DVRs or the use of fixed IP addresses somehow hide the DVR(s) from my home network? Roomie can't seem to find the DVRs with the fixed address and I don't see the hardwired/fixed IP DVRs on the Router either.

    Thanks in advance.
    not sure what your issue is, but I can tell you that for your network it does not matter if you are using static over coax or static over UTP. these are only transport method and the delivery is the same. even using DHCP over either transport method would be the same


    Sent from my iPad using DBSTalk
     
  9. Oct 9, 2013 #369 of 393
    dennisj00

    dennisj00 Hall Of Fame

    9,689
    195
    Sep 27, 2007
    Lake Norman, NC
    Did you reboot your router after assigning the fixed IP - or more specifically after not using the assigned DHCP addresses? They will eventually expire and fall out of the table, but this could be confusing your RR. (reboot it too)
     
  10. Oct 9, 2013 #370 of 393
    dennisj00

    dennisj00 Hall Of Fame

    9,689
    195
    Sep 27, 2007
    Lake Norman, NC
    The router shouldn't be forwarding the 169 packets. Check with Buffalo for a firmware update or better yet, install dd-wrt.
     
  11. Oct 9, 2013 #371 of 393
    lflorack

    lflorack Godfather

    473
    0
    Dec 16, 2006
    Thank you.
     
  12. Oct 9, 2013 #372 of 393
    lflorack

    lflorack Godfather

    473
    0
    Dec 16, 2006
    I did not reboot either the router or the iPad (w/Roomie). I will retry this all tonight. Thank you. I'll let you know.
     
  13. Oct 9, 2013 #373 of 393
    peds48

    peds48 Genius.

    20,082
    1,068
    Jan 10, 2008
    NY
    Correct me if I am wrong. but aren't this IP to IR "dongles" supposed to get their own IP addresses and as such the Roomie app is supposed to "see" the "dongles" and not the DVR. I would assume that you would assign DVR commands to the "dongles" no?
     
  14. Oct 9, 2013 #374 of 393
    lflorack

    lflorack Godfather

    473
    0
    Dec 16, 2006
    Correct me if I am wrong. but aren't this IP to IR "dongles" supposed to get their own IP addresses and as such the Roomie app is supposed to "see" the "dongles" and not the DVR. I would assume that you would assign DVR commands to the "dongles" no?


    You are correct but the DirecTV DVRs are IP controlled and don't need to use the IP to IR converter. Sorry I made my original post confusing by putting in information about my setup that wasn't actually part of the issue.


    Sent from my iPad using DBSTalk
     
  15. Oct 9, 2013 #375 of 393
    lflorack

    lflorack Godfather

    473
    0
    Dec 16, 2006
    Tonight when I got home, i noticed that both DVRs had been updated last night and were rebooted. Perhaps as a result, the HR44 couldn't see the HR20. I then proceeded to change both to static IP addresses and reboot them both. They both came back up with their new addresses and able to see the other. In addition, Roomie Remote can see and control them both too. We'll see if this solves the original 'dropping off the net' issue over the long term, but for right now all is well.

    Thanks to all for your help.


    Sent from my iPad using DBSTalk
     
  16. lflorack

    lflorack Godfather

    473
    0
    Dec 16, 2006
    Unfortunately, even with the newly added static IP addresses, the HR20 seems to stop seeing the HR44 or visa versa every few days. This started a few days prior to my upgrade to the HR44 so I'm pretty sure it's not that. I even replaced one of my two HR20's with the new Genie. I guess I chose the wrong one? Rebooting always beings them back. Is their an easier way?

    Also, any other troubleshooting ideas other than just replacing the HR20?


    Sent from my iPad using DBSTalk
     
  17. lflorack

    lflorack Godfather

    473
    0
    Dec 16, 2006
    I'm staring to see a pattern with this loss of DVR connectivity (it happened again yesterday). I'm not positive yet but it appears that the HR44 and HR20 lose connectivity with each other whenever either receive a software update or are rebooted for any other reason. It seems that one or the other of my DVRs have been receiving numerous updates over the past few weeks and each time, I then need to reboot both of them so they can see each other again. Both of them are on UPS/conditioner units so I'll have to keep an eye on this to confirm its due to software updates/reboots.


    Sent from my iPad using DBSTalk
     
  18. mrdobolina

    mrdobolina AllStar

    396
    15
    Aug 28, 2006
    A Mile High
    Question: I am moving from Static IPs to DHCP Reservations. A couple of questions:

    Will I be ok if I don't "delete" the static IP from my D* receivers but still reserve the IP address in my router's DHCP reservations page? Also, I have opened up my DHCP range to include the IP addresses that are currently assigned staticly on the receivers. Should I expect those to show up on my router's routing table? Finally, if I wanted to "delete" the static IPs from my D* receivers, how would I go about doing that?

    Thanks!
     
  19. peds48

    peds48 Genius.

    20,082
    1,068
    Jan 10, 2008
    NY
     
  20. mrdobolina

    mrdobolina AllStar

    396
    15
    Aug 28, 2006
    A Mile High
    Thanks, Peds! I've started migrating all of my static IPs to DHCP reservations.
     

Share This Page