1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Music & Photos Missing From Extras

Discussion in 'DIRECTV General Discussion' started by HarleyD, Apr 5, 2013.

  1. Apr 5, 2013 #1 of 12
    HarleyD

    HarleyD Hall Of Fame

    1,357
    62
    Aug 31, 2006
    This has been an issue (albeit a small one) for a while now.

    Music & Photos is missing from many...perhaps all...of my extras menus.

    For a while it would come and go. Sometimes not showing up and then appearing later but now it has been gone for weeks.

    Now the only places I have actually looked for it are the Living Room (R22-100), Family Room (HR20-700), Kitchen (HR21-100) and Bedroom (HR21-200).

    I believe this started to be an issue when I converted my system to SWM. I installed a SWM16 with a Wireless CCK for the Internet bridge. Previously I had used power line adapaters and Music & Photos was a reliable option for years. Then it became sketchy and now non-existent.

    Now it isn't a huge problem. I can actually accomplish the same thing using my blu-ray players but it used to work and now it doesn't. It piques my curiosity and irritates me a little only because I know it is supposed to work and used to work.

    I am at work right now and don't know what release I am using for certain but at least two of them are on the latest NR.

    Anyone else seen this and more importantly, anyone else solved this?
     
  2. Apr 5, 2013 #2 of 12
    RunnerFL

    RunnerFL Well-Known Member

    17,054
    312
    Jan 4, 2006
    The "Music & Photos" selection only shows up if the unit detects a server in your network that is serving up music and/or photos. Have you tried restarting your multimedia server?
     
  3. Apr 5, 2013 #3 of 12
    HarleyD

    HarleyD Hall Of Fame

    1,357
    62
    Aug 31, 2006
    I don't use a multimedia server. Once upon a time I had gone into each individual computer on my network and enabled media sharing.

    Granted, this was done a long time ago but it worked and worked for several years.

    I can tell you that those computers have been restarted many times over the weeks that this has been an issue.
     
  4. Apr 5, 2013 #4 of 12
    peds48

    peds48 Genius.

    20,082
    1,069
    Jan 10, 2008
    NY
    I would skew sure that your pc firewall is not blocking access
     
  5. Apr 5, 2013 #5 of 12
    HarleyD

    HarleyD Hall Of Fame

    1,357
    62
    Aug 31, 2006
    All of them? I have four networked computers, all of which used to show up.

    It's something to look at though.
     
  6. Apr 5, 2013 #6 of 12
    Volatility

    Volatility Legend

    436
    10
    May 22, 2010
    I thought they removed this feature. I am pretty savy with networking (atleast id like to believe so lol) and that media feature no longer appears for me on any hd dvrs and sharing is enabled on my pc. I gotten it to work like years ago though.
     
  7. Apr 5, 2013 #7 of 12
    jceman

    jceman Legend

    302
    7
    Aug 20, 2007
    North of...
    Sharing by itself is not enough - you need a server running on the PC(s), such as Windows Media Player (with option on) or PlayOn, for example.

    I have the free version of PlayOn running on my PC and all my IRDs have "Music and Photos" in my Extras menu.
     
  8. Apr 5, 2013 #8 of 12
    Volatility

    Volatility Legend

    436
    10
    May 22, 2010
    oh duh. thanks.
     
  9. Apr 5, 2013 #9 of 12
    goinsleeper

    goinsleeper Godfather

    673
    17
    May 22, 2012
    I use Serviio and it runs everything just about flawlessly.
     
  10. Volatility

    Volatility Legend

    436
    10
    May 22, 2010
    cool. these forums need a like button lol i cant believe i forgot that you have to have a program like that to make it work- i was using tversity
     
  11. acostapimps

    acostapimps Hall Of Famer

    1,866
    50
    Nov 5, 2011
    Illinois
    Like others said you need a media server software (i.e. serviio,playon,tversity) installed on your computer with media sharing enabled, once is installed you need to add media files(music,video,pictures etc) to your server software from your computer to appear on the DVR, and have your server running and recognize your device (It would show Directv DVR in the list of devices) In my case I'm using Serviio because it plays any format.
     
  12. HarleyD

    HarleyD Hall Of Fame

    1,357
    62
    Aug 31, 2006
    It's just too weird but it appears to be related to my router.

    I noticed that on a computer with a wired connection to the router I could not see any of the DirecTV Media devices in Windows explorer, which are all connected by a wireless CCK on the SWM network. I could ping them all, but they didn't show up in explorer. All the wired devices were listed

    On a laptop with a wireless connection I could see all of the wireless DirecTV devices and not the wired units.

    When I would log into the router I could see everything.

    Everything is all on the same subnet. The IP addresses are randomly distributed.

    When I log into the router and click on "reset to defaults" after the router reboots everything in the entire network shows up in explorer on both wired and wireless units. Mediashare shows up on the HRs and I am able to start streaming music and continue for as long as I like as long as I don't stop. Once I stop, Mediashare disappears from the Extras menu shortly afterward and the network devices shown in Windows explorer become wonky and segregated by connection type again.

    This is just too dang weird.
     

Share This Page