1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PlayOn: Watch Hulu, YouTube, CBS, CNN, ESPN, and Netflix on your TV using your HR20?

Discussion in 'DIRECTV Tips and Resources' started by cnmsales, Nov 23, 2008.

  1. bonscott87

    bonscott87 Cutting Edge: ECHELON '07

    9,809
    2
    Jan 21, 2003
    I had trouble with PlayOn and found out that for some reason my anti-virus (AVG Free) was blocking it. Put the media server on the exception list and it started working fine again.

    FYI, reboot your computer or close and restart PlayOn for it to autopatch itself with the patch that fixes the Hulu problem for most people (it did for me).
     
  2. bsboggs

    bsboggs Legend

    210
    0
    Oct 18, 2007
    Thanks for your suggestion. I tried it and still no updates. Must be something else. I'll keep looking...
     
  3. bobukcat

    bobukcat Hall Of Fame

    1,967
    2
    Dec 20, 2005
    That quit working for me and the hotfix didn't resolve anything either but I saw a post on another forum that if you have a Hulu account (it's free) you can add items to your queue and then they'll play. I tried it and it works fine for me, even with video quality set to Max.
     
  4. bonscott87

    bonscott87 Cutting Edge: ECHELON '07

    9,809
    2
    Jan 21, 2003
    The update just happens in the background, you won't be prompted for it. I had no idea I even got it until I checked the version number.
     
  5. jrr4

    jrr4 AllStar

    83
    0
    Sep 29, 2006
    I've been running PlayOn for quite a while, and it works great on my Xbox 360 and my Dlink media server. I have NEVER seen PlayOn in my list of available options on my HR20. It seems odd that Tversity and Windows Media sharing always show up (Twonky used to until they went to the newest release, and I uninstalled it). With PlayOn working on my other devices, I wouldn't think it's a firewall issue on my server (I have confirmed that it is in my Windows Firewall exceptions)

    Anyone have any thoughts?
     
  6. bonscott87

    bonscott87 Cutting Edge: ECHELON '07

    9,809
    2
    Jan 21, 2003
    I just choose "Photo's, music and more" or whatever that media share option is in the menu. Choose my computer and then the playon menu options show up. There isn't a specific option to actually choose Playon. Maybe if you have those other media servers running at the same time perhaps they conflict or the HR20 gets confused?
     
  7. psweig

    psweig Hall Of Fame

    1,070
    0
    Feb 4, 2006
    When I select Music, Photos, Etc.... I get My Computers, -> three media servers. the one at the top which is labeled with the name of my Dell, is the Playon one, but it doesn't say "Playon". Click on that and I get a list with Netflix, HULU, CBS, and so on. Nowhere on my HR does it say "Playon" but it runs fine. :D
     
  8. alnames

    alnames Cool Member

    21
    0
    Sep 23, 2007
    Anyone else have an issue with the DirecTV HR20-100 using Playon having audio issues only?

    My problem is that while I can usually play videos without too much issue, the audio is higher pitched than normal (like chipmunks) and the audio also stutters (vibrates) at the same time.

    Local media play fine through WMP to the HR20-100.

    Playon works fine streaming to other computers on the network running XMBC.

    I've sent in logs to themediamall to no avail. Any ideas?
     
  9. bsboggs

    bsboggs Legend

    210
    0
    Oct 18, 2007
    What kind of machine (PC) are you using? If it's a few years old the cpu could be maxed out. Could be a transcoding issue. Do you have background processes running that might take cpu cycles away from the mediaserver? Just a thought .... :)
     
  10. alnames

    alnames Cool Member

    21
    0
    Sep 23, 2007
    I have a fairly new computer. I think it has an AMD 3Ghz dual core processor and 2Gig's of Memory. Even when processing video, the CPU never goes beyond 50%.
     
  11. Struff

    Struff AllStar

    62
    1
    Dec 23, 2008
    How do I access it on my R22-100? installed the program on my computer and in the PlayOn settings it says that it is running. DirecTV2PC works perfectly for me so I know that the R22 and my computer 'talk' to each other.

    Thanks.
     
  12. dave29

    dave29 New Member

    5,945
    40
    Feb 18, 2007
    Menu> Music Photos and More> Computers
     
  13. Struff

    Struff AllStar

    62
    1
    Dec 23, 2008
    I never had Music & Photos as an option until I installed TVersity last night. Now sometimes Music & Photos is there but most of the time it's not. And when I do have it, I only have TVersity as an option.

    Is there anything else I need to do to PlayOn? Does it not like TVersity?
     
  14. Mrmiami

    Mrmiami Legend

    201
    0
    Oct 3, 2006

    Try doing a red button reset on your DTV receiver but also within the same timeframe - on your computer, stop the playon service and restart it. It "Should" now show up in your receivers Music.Photos and more list but for how long it remains in the menu is anyones guess. For some strange reason it keeps disappearing from D* Menu. I just wish the 2 parties could come together for a solution because I love all those old shows on HULA.
     
  15. bonscott87

    bonscott87 Cutting Edge: ECHELON '07

    9,809
    2
    Jan 21, 2003
    I've never had it disappear from my receiver. It's always there so long as PlayOn server is actually running. Then again I have a very stable network connection for my receivers, all hard wired and no flaky WiFi.
     
  16. jrr4

    jrr4 AllStar

    83
    0
    Sep 29, 2006
    Yeah, I'm an idiot. Thought that the computer shown was Windows Media Sharing, but lo and behold, there was PlayOn. Thanks for the wisdom guys!
     
  17. lwilli201

    lwilli201 Hall Of Fame

    3,189
    28
    Dec 22, 2006
    Missouri
    I have an HR21-700 that locks up on Netflix when I start a selected show for the queue. Usually works OK after a reboot. This happens almost every time I go to Netflix.
     
  18. Struff

    Struff AllStar

    62
    1
    Dec 23, 2008
    I finally see it. I am getting lots of errors when I play videos - they either won't start or they'll stop after a few seconds or they stutter or it tells me that my selected videos are not available, just as I do with TVersity (pics and audio work ok on TVeristy).

    I've had my R22 since the first week of January and I never knew any of this was possible - I never saw that Music & More menu choice before and I figured that Media Share was something that I needed to download and install on my computer.

    But that's off-topic. Back on-topic, I thought my video playing errors were because my router was getting old and tired so I bought I new router and I'm still getting errors playing videos. Does anyone have any ideas how I can improve performance?

    Thanks.
     
  19. MountainMan10

    MountainMan10 Icon

    607
    0
    Jan 30, 2008
    Mine often does the same thing. Seems some combinations of software versions, both on the HR21 and Playon work, others don't. I am about ready to give up on it and get the Roku box.
     
  20. bonscott87

    bonscott87 Cutting Edge: ECHELON '07

    9,809
    2
    Jan 21, 2003
    All I can say is to make sure that the Media Mall server and the Playon executable is on the exception list on both your firewall and your antivirus. And I really hope you don't have Norton. Ugggggg. Also if you have a bunch of junk eating up resources on your computer that's going to effect it as well.

    Also, do you have a steady/fast broadband connection? They recommend bare minimum of 1.5 mb solid but you really need a solid 2.5-3 mb. So do some tests on your ISP like at Broadband Reports. Also, stream the Hulu and/or Netflix on your computer and see if it's choppy there. That will help you determine if your internet connection is ok or not.
     

Share This Page