1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Replacement HR21 - Network connection issue

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by miketorse, Dec 20, 2012.

  1. miketorse

    miketorse Icon

    Jul 29, 2008
    Hi All...
    I received a replacement HR21 today for an older HR21 that the hard drive died on. I have Whole Home Service via my home network, not SWIM.

    I'm having trouble connecting to the internet and home network to see the other DVR in the house. The light on the Ethernet connection is solid green, and the other light is blinking orange once every five seconds (Which I assume means no data).

    I'm going through the connection and getting the Internet Not Connected (22) Error, result code 86-837.

    I tried using default information that came with the DVR, and then tried with the following settings:

    IP Address:

    Subnet Mask:

    Def Gate:


    network says "connected", but it won't see the other DVR, and internet fails. So I'm assuming that "Connect" under Network isn't really connected.

    I actual cable that is in the back of the DVR can connect to the internet via the ROKU that is sitting next to it (for testing purposes, I wanted to eliminate the cable or switch or router).

    I reset the DVR once already....

    Any help would be appreciated!
  2. r028806

    r028806 Mentor

    Mar 12, 2010
    Check the lites on your DECA, all should be green with middle one flickering. Make sure green and amber lites on Ethernet 1 are lite where your blue ethernet cable is connected to the HR21. Go to Network in the menu select, reset network defaults then select connect now should fix if for you.
  3. miketorse

    miketorse Icon

    Jul 29, 2008
    No DECA. This is hard wired only.
  4. Rent_Share

    Rent_Share AllStar

    Aug 31, 2011
    Have you recycled the router it's plugged into ?
  5. dielray

    dielray Legend

    Aug 5, 2009
    Have you tried plugging the cable in the other jack?

    When you're in the advance network setup does it show a valid MAC address?

Share This Page