Samsung JS8500 and an AVR That Works Correctly?

Discussion in 'Home Theater Audio' started by Rich, Aug 19, 2016.

  1. Rich

    Rich DBSTalk Club DBSTalk Club

    33,368
    1,324
    Feb 22, 2007
    Piscataway, NJ
    Does anyone with a Samsung JS8500 (or a similar Samsung 4K TV) have an AVR that works correctly when connected to the Samsung TV? I've tried 3 Sony AVRs and 1 Denon and had similar problems with all of them. I can't get a Sony AVR to work correctly unless I set the HDMI control to "Off". The ages of 2 of my Sony AVRs don't seem to be the problem, a brand new 1070 had the same issue.

    So, that's two 4K AVRs that haven't worked correctly and 2 older Sony AVRs that all seem to have the same problems. I'm hoping to get some help, I'm not gonna buy another AVR until I know what's going on.

    The reason I think the Samsung TV is at fault is the fact that my two older AVRs work correctly with my Panasonic plasma TVs. I never had to shut off the HDMI control until I got the Samsung TV. Never had a problem, didn't expect this to happen.

    Any help or guidance would be most appreciated.

    Rich
     
  2. Rich

    Rich DBSTalk Club DBSTalk Club

    33,368
    1,324
    Feb 22, 2007
    Piscataway, NJ
    Well, this is interesting. Somehow I got two iterations of this thread. I can't seem to delete one, could someone please delete the other thread?

    Rich
     
  3. Jbdaws

    Jbdaws New Member

    53
    0
    Aug 4, 2016
    I own a Samsung not 4K but I highly recommend a Yamaha AVR. They are extremely reliable, pack all the punch, and if you do research are generally one of the top brands highly recommended. My rxv781 works flawlessly with my Samsung D6000.
     
  4. Rich

    Rich DBSTalk Club DBSTalk Club

    33,368
    1,324
    Feb 22, 2007
    Piscataway, NJ
    Thanx, other folks have also recommended the Yamahas. Only problem with them is the lack of choices on Amazon. I do want to buy one from Amazon.

    So, your AVR never just switches to "TV"? All the 4K AVRs I've tried kept trying to use the "TV" source. I had to turn off the HDMI control on the Sonys to get it to stay on the selected input. See anything like this? I know it doesn't have to be a 4K AVR for this to happen.

    Rich
     
  5. jimmie57

    jimmie57 Hall Of Fame

    9,636
    746
    Jun 26, 2010
    Texas City, TX
    Rich, have you installed the latest Firmware for your TV?
    Link to it: http://www.samsung.com/us/support/owners/product/UN55JS8500FXZA
     
  6. Rich

    Rich DBSTalk Club DBSTalk Club

    33,368
    1,324
    Feb 22, 2007
    Piscataway, NJ
  7. Jbdaws

    Jbdaws New Member

    53
    0
    Aug 4, 2016
    I haven't seen anything like that. I have everything hooked up over hdmi to my AVR. PS4 goes into hdmi 1, Directv in hdmi 2. I don't know if this is what you're talking about but the AVR will start up on the last input used it will never change inputs by itself...even if i powered on my cable box/tv. I have a Harmony remote that does all the work for me.

    The newer models are the rxv581 681 781 there might be some higher end models as well would have to look on Yamahas website.
     
  8. Rich

    Rich DBSTalk Club DBSTalk Club

    33,368
    1,324
    Feb 22, 2007
    Piscataway, NJ
    My old Sony AVR (1010) is now switching when I change from one device to another without the HDMI control set to "On". This is what it should be doing. It no longer randomly switches back to the "TV" input. I'm pretty sure there's nothing wrong with the Sony AVR, I really think the JS8500 is doing something, I just have no idea what. I've had Sony AVRs for years and I've never had a problem with them until I hooked one (ultimately 3) up to the 4K set.

    I am tempted to buy the 681, I just have to wonder if Amazon is gonna go berserk if I buy it and return it. This would be the third returned AVR in less than a year.

    Rich
     

Share This Page

spam firewall