Still no luck with TV Apps

Discussion in 'DIRECTV HD DVR/Receiver Discussion' started by EricBergan, Aug 25, 2010.

  1. EricBergan

    EricBergan Mentor

    50
    0
    Apr 26, 2007
    I'm still unable to get TV Apps to display (HR20). When I click the right arrow, it briefly displays "TV Apps are loading", which then disappears. There are no error codes.



    I've manually configured the ports, and opened the ports on my router. I can see traffic in and out from my router logs. (I'm running a linksys running dd-wrt, which many others have reported success with.) Receiver tests all indicate everything is up, and net services start without a problem. I can download on demand content from the receiver, and via the website. I've done lots of RBRs.



    Now, one thing that is strange is that I can't change my apps information on tvapps.directv.com. It shows 5 apps, and I can set preferences, move them to inactive, delete them, etc. But when I call back up "my apps" they are still the way they were. The receiver name agrees with the name for on demand.



    My receiver just got the 40C update, still the same problem.



    Anything else to check? Any way to "reset" my apps account on the web site? I'm suspecting the problem is on the server end...



    eric
     
  2. coolyman

    coolyman Legend

    102
    0
    Oct 4, 2007
    I got the 0x040c update at 0326 today. Around 0700, the apps didn't work but now (2000) they are for me.
     
  3. Hutchinshouse

    Hutchinshouse Hall Of Fame

    4,632
    0
    Sep 27, 2006
    Same for me on my HR24-500. Apps are not working for some of us. DIRECTV is aware of the issue. Hopefully it will be fixed shortly.
     
  4. EricBergan

    EricBergan Mentor

    50
    0
    Apr 26, 2007
    Do you also have problems getting changes on tvapps.directv.com to stick?

    eric
     
  5. Hutchinshouse

    Hutchinshouse Hall Of Fame

    4,632
    0
    Sep 27, 2006
    BINGO! Sure do.
     
  6. armchair

    armchair Hall Of Fame

    1,295
    12
    Jul 27, 2009
    It's only a guess on my part but maybe the APPS aren't updating because the server fails to update the receiver?

    Conversely, another guess would be that the TV APPS are dormant for some receivers. If dormant, is there a way to wake them up or to activate them on the server?

    For those adventurous to open ports of your router, I'd suggest setting up a port forwarding trigger. Use outgoing UDP/TCP (both) port 443 to trigger the receiver's manually assigned STB port (use TCP) to the static IP of the Receiver. This should start network services and may result in a successful connection test; however, I do not know if that will help if either applies.
     
  7. EricBergan

    EricBergan Mentor

    50
    0
    Apr 26, 2007
    I've manually configured the ports, opened them on my router, and am getting successful connection tests. I can even see (sporadic) in/out traffic in my router logs. The problem seems to be at a higher protocol layer, either on the server or the receiver.

    eric
     
  8. Hutchinshouse

    Hutchinshouse Hall Of Fame

    4,632
    0
    Sep 27, 2006
    All of my HR units are on the same network, sharing the same router.

    All hardwired on the same switch. All have fixed IP address.

    Port forwarding setup for all units. All HR units pass network services every time. (I've been told network services is irrelevant)

    Apps work great on two of my three units.

    The issue unit is my HR24-500. DOD and MRV work great, just not apps.

    I’ve tried a zillion ways to jumpstart the apps. No dice.

    Your server guess is a good one. :up:

    There’s a big dog at DIRECTV looking for a fix. It’s only a matter of time before we’ll all be rocking and rolling.
     
  9. codespy

    codespy Go Pack Go!!!! DBSTalk Club

    2,274
    491
    Mar 29, 2006
    Seasonal
    My Apps have not worked on ANY of my HR2x's for the entire month of August.....no matter what I configure.

    VOD works fine and have downloaded many movies.

    All system tests are positive....still no Apps. Very frustrating.

    And yes, I have rebooted, unplugged, reset, revamped, you name it!
     
  10. armchair

    armchair Hall Of Fame

    1,295
    12
    Jul 27, 2009

    Thanks Hutchinshouse,

    That answers my question: the congrats! Network connection test successfully passed, does not jump-start TV APPS. Just the other day when some one was asking about the 301 TV APPS are initializing error, I had it too for a couple minutes. I pushed the network services connection test in auto mode and got the 202 error which allowed me to get APPS back again. I wasn't using the manually assigned STB/audio ports but remembered my first HR24-500 seemed to maintain good network services connection once configured. So I configured the advanced network setup complete with static IPs, manually assigned STB ports and forwarded them again to see if that would be more reliable for TV APPS. Point is, works either way here.

    I just wonder what the process is? Is there someone standing at the door with a bar code scanner as they go out the door to activate them into Server database? If he takes a break... what happens if your receiver goes out the door and doesn't get scanned?

    Hopefully, Earl and company will get these resolved soon.
     
  11. HarleyD

    HarleyD Hall Of Fame

    1,359
    63
    Aug 31, 2006
    OK, my TV Apps worked until I had to have my HR20-700 replaced. It will not work on the replacement HR20.

    On top of that I cannot even log into the App Store. I use the same password and email that I use for directv.com and I get an error that my login attempt was unsuccessful

    I've spoken to the Networked Media Tech Support, and they in turn escalated it to the engineers and I didn't hear another word about it.

    So I emailed DirecTV, they confirmed my problem and were able to reproduce my login issue by changing the password on my account and trying themselves. They confirm there is indeed a problem.

    So they escalated the problem and I have not heard another word about it.

    I can get DoD programming no problem. My Internet connection checks out and TV Apps actually do work on my R22 but I am getting nowhere on this replacement HR20.
     

Share This Page

spam firewall

Advertisements