1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VIP 722 - Sling Adapter not powering on

Discussion in 'ViP612/622/722/722K DVR Support Forum' started by amgoodrich, Oct 23, 2013.

  1. amgoodrich

    amgoodrich New Member

    Oct 23, 2013
    Gaylord, MI
    My Sling adapter will not power on any longer, for some reason. Is there any way to troubleshoot what the problem might be?


  2. Jim5506

    Jim5506 Hall Of Fame

    Jun 7, 2004
    "She's dead, Jim!"
  3. Grandude

    Grandude RichardParker II

    Oct 21, 2004
    You could try dropping it on the floor to see if that would wake it up. If not, get it replaced. It's not unusual for those adapters to die.
    1 person likes this.
  4. 3HaloODST

    3HaloODST Godfather

    Aug 9, 2010
    Don't do that. Just skip the dropping part and contact Dish to have it replaced.
    1 person likes this.
  5. Mike.H_DISHNetwork

    Mike.H_DISHNetwork DISH Representative DISH Representative

    Feb 1, 2011
    [SIZE=12pt]I can help you with the Sling Adapter not powering on, have you tried the front USB port of the HD dual DVR? Please PM me with the phone number on the account.[/SIZE]
    1 person likes this.
  6. mweathers

    mweathers AllStar

    Sep 4, 2007
    I have a Hopper and mine stopped working at around the same time. No red light. I know USB ports work. How can I resolve this issue. Strange that this has happened to a few owners at the same time.....

    Thanks for any help!
  7. Mike.H_DISHNetwork

    Mike.H_DISHNetwork DISH Representative DISH Representative

    Feb 1, 2011
    [SIZE=medium]I am more than happy to help you with your Sling Adapter questions. Would you PM me with the phone number on the account?[/SIZE]
  8. wmidgett

    wmidgett New Member

    Nov 23, 2013
    Having the same Sling adapter problem everyone else is having... Is there a workaround for it yet?
  9. GarajMahalic

    GarajMahalic New Member

    Nov 30, 2014
    i am in the same boat as amgoodrich, although mine hasn't worked for around a year. no red light, no matter which usb input i used. i called in once to dish but they wanted me to unplug my dvr and i was recording something at the time.

    so today i was dusting and moved the sling adapter so i could dust underneath it. when i looked up at the tv there was a message saying that the sling adapter was detected and that i should look for the red light. i looked back down at the adapter and the red light was actually on! so i grabbed my ipad and started up the dish anywhere app but every time i tried to watch something on the ipad it would say that i needed a sling adapter to do it and give me the option to go to dish.com. i tried using my iphone and got the same result. the red light is still on on the sling adapter but it's a no go in regards to actually streaming anything.

    i, too, read that there have been a lot of problems with the sling adapter. my brother has one and his hasn't worked in a year either. when it did work it came in quite handy at times. it would be nice to be able to watch football while i'm cooking breakfast. would dish replace mine for free as well?

Share This Page