DBSTalk Forum banner

722K broadband connect problem - arp issue

2417 Views 4 Replies 2 Participants Last post by  bnborg
My 622 recently died and was replaced with a 722k (about which I am not happy). I just noticed the 722 isn't getting a broadband connection now, never had a problem with the 622. The 722 gets the proper DHCP config set, but fails the broadband connect test. So, after much messing around (different routers, etc), I put a packet-sniffer on the network to see what was going on. The 722 sends a broadcast arp request to find my gateway, and never gets a response. Normally, I'd say this was a problem with the gateway, but no other device on my network has a problem, and neither did my 622. I'm out of ideas. Below is a packet trace. You can see that xx.12 does a broadcast and gets a response. xx.16 (the 722) does a broadcast and gets nothing. BOTH of these are on the same router (and I've tried 3 different routers, btw). 12 always works, 16 never works. I've included the expanded packet for 16's request, looks fine. Anyone have any ideas? (and no, I don't use ATT, and yes, I've put it behind other routers)

Time Source Destination Protocol Length Info
2 0.039335000 Azurewav_02:dd:88 Broadcast ARP 42 Who has Tell
3 0.041220000 Netgear_46:5c:25 Azurewav_02:dd:88 ARP 60 is at 00:24:b2:46:5c:25
6 3.610808000 Echostar_ce:2b:32 Broadcast ARP 60 Who has Tell

Frame 6: 60 bytes on wire (480 bits), 60 bytes captured (480 bits)
Ethernet II, Src: Echostar_ce:2b:32 (00:08:89:ce:2b:32), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Address Resolution Protocol (request)
Hardware type: Ethernet (1)
Protocol type: IP (0x0800)
Hardware size: 6
Protocol size: 4
Opcode: request (1)
[Is gratuitous: False]
Sender MAC address: Echostar_ce:2b:32 (00:08:89:ce:2b:32)
Sender IP address: (
Target MAC address: Broadcast (ff:ff:ff:ff:ff:ff)
Target IP address: (
See less See more
1 - 2 of 5 Posts
wje said:
Amazing how seeing something in a different format suddenly shows something you haven't noticed - note the request packet size. The one that works is 42 bytes, the 722 sends a 60 byte packet. Looking at arp requests on my network for a while, every other device sends a 42 byte packet, and they all work. Looks like the 722 sticks a trailer on the packet, and no one will answer it. OTOH, from what I can find out about arp packet sizes, 60 is a possible size. So, I'm still not any closer to a solution.
My conclusion - for whatever reason, arp is broken on the 722, which, combined with all its other problems, makes it a candidate for the 'most useless dvr' award. I want my 622 back.
Very interesting. The problem has been discussed before, in threads such as 722k always appears offline? and Sling box drops connection but this is the first real insight as to a cause. I am going to look at the advanced settings on my router and see if there is any way to enable trailers or somthing related.
I have configured my router's dhcp server with an assigned ip of for my ViP722k.

The arp request I am seeing is "ARP:Request," asks for, but it is being broadcast to everyone, TargetMacAddress: FF-FF-FF-FF-FF-FF. Is this maybe looking for a subnet? If so, I don't know why. The DVR has a normal subnet mask,, as does the router. There is no device on my network with a matching IP (*.*.*.127, no subnet).

With that request it's not going to get an answer. Maybe if I assign to the router something?
1 - 2 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.