DBSTalk Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

· Thanks Earl! Go Bears!
Joined
·
65 Posts
Discussion Starter · #1 ·
Hello all. I was the owner of a H20-600 receiver until today. The constant rebooting while watching any HDTV programming really got to me... So Sunday Dec 17, 2006, I called D* and spoke with a representative about my problems. They agreed to send me a new reciever at no cost whatsoever. Today, I received a brand new H20-100 receiver... Manufactured on 11-23-06, south of the border. I like that the unit does not run hot.

Other than that, this new H20-100 has been nothing but trouble already. I have had to reset the unit 4 times in the last four hours... While watching "Mind of Mencia" just a short while ago, the screen dropped out 6 times and froze twice. Sometimes a white screen would come up, then go black, then come back within about 6-10 seconds. It has nothing to do with closed captioning, I've checked that already. So my question is: Has anyone else experienced any of these problems (or other problems) with their H20-100's? I have the latest software, the 100C version, it downloaded about 10 minutes after I initially set the box up. Any insight would be GREATLY appreciated. Thank you.
 

· AllStar
Joined
·
51 Posts
I had to switch from the 600 to the 100 due to it crapping out and
outside of a weird transponder issue that was solved by unplugging
the unit for awhile nothing has happened.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top