DBSTalk Forum banner
1 - 10 of 10 Posts

· New Member
Joined
·
3 Posts
Discussion Starter · #1 ·
Is anyone having issues logging into the MyDish account on a PC? This just started a couple of weeks ago.

I can log in and connect... then my account will flash up for a second...then it will go back to the logon screen.

This happens on all browsers and all PCs. The MyDish app on iOS works fine.

Thanks for any response. I appreciate it!
 

· Premium Member
Joined
·
1,118 Posts
Is anyone having issues logging into the MyDish account on a PC? This just started a couple of weeks ago.

I can log in and connect... then my account will flash up for a second...then it will go back to the logon screen.

This happens on all browsers and all PCs. The MyDish app on iOS works fine.

Thanks for any response. I appreciate it!
I haven't had occasion to access my MyDISH account lately, but I just gave it a try with Chrome on my Linux laptop with no problems. I even clicked around on a few menu items to make sure. Have you tried clearing your cache? DISH has been making some updates to the website.
 

· Registered
Joined
·
330 Posts
Here is what I get in Chrome after clearing my cache:
Gadget Font Material property Electronic device Screenshot

This is the exact same thing I see in other browsers and on other PC's, every time I try to log into my mydish account, whether I clear the cache or not. This also started for me a couple of weeks ago.

I recently added the Dish Anywhere app to a new Android streaming device. When I went to the dishanywhere.com/activate page the app said to go to, my login did not work there, either. I had to go to the main dishanywhere.com page to log in there. That login worked properly. After that, I could successfully go the activate page to finish setting up the Dish Anywhere app on my new Android device.
 

· New Member
Joined
·
3 Posts
Discussion Starter · #7 ·
Thanks for the replies. I am still having the same issues. Have cleared the cache, and am using the MyDISH login. I can login and for a second see the next page…then it bounces back to login page. Sounds like issues are with the Dish site. Haven’t had time to wait on support yet to talk to them. I’m sure they will straighten it out soon. Thanks again to everyone!
 

· Beware the Attack Basset
Joined
·
26,463 Posts
I visited without issue a couple of times over the weekend and again just now. I agree with psanrules that the issue is likely with your account.
 

· New Member
Joined
·
3 Posts
Discussion Starter · #9 ·
Just wanted to update. I called Dish today and they couldnt find anything wrong with my account access. I played around a bit and found the problem. I use T-Mobile 5G Home Internet as my home internet. When I turned off the Wi-Fi on my iPhone and connected using the Verizon Wireless network to Dish everything worked fine. I was able to connect sporadically to the Dish account using T-Mobile but it was very erratic. Works fine every time on the Verizon network, so it appears to be the T-Mobile network. Every thing else connects fine…just the Dish account. I also changed the DNS server on my connections but that didn’t help. At least I know what to do to get to my account. Thanks for all the responses and help!
 

· Registered
Joined
·
330 Posts
Here is what I get in Chrome after clearing my cache:
Gadget Font Material property Electronic device Screenshot

This is the exact same thing I see in other browsers and on other PC's, every time I try to log into my mydish account, whether I clear the cache or not. This also started for me a couple of weeks ago.
It's been awhile since I've tried to log into my mydish account, so I'm not sure exactly when this got fixed. I just thought I'd update everyone here that my log in is working properly again, at least as of tonight when I just checked it.
 
1 - 10 of 10 Posts
Top