DBSTalk Forum banner

Had my HR20 two days now...

915 Views 6 Replies 5 Participants Last post by  spolaski
I've spent just a few days with my new HR20, but I thought I'd give my thoughts. Basically, I like the box. It has a few issues, but I like it.

I can't test locals as the box doesn't yet have OTA (obviously) and my area doesn't have spot-beam HD locals. Other HD channels look fine.

First, the problems:

* Closed Captioning problems (garbling, cutting off, timing issues) that occur on both HD and SD channels. THIS MUST BE FIXED.

* Replay glitch where hitting 30-sec slip locks the reply and you have to scan forward to recover. Minor problem but annoying.

* One show recorded as first run though it was a repeat. Minor annoyance.

Not so much problems but annoyances:

* The 30 second slip needs to be a bit faster.

* I really want Closed Captioning to work on 1X. I scan through a lot of BS at 1X and skim the text.

* As others have, I've seen and dislike the problems with channels I don't subscribe to showing up in searches, the inability of the search utility to ignore the "The" in a show's title so that I can search for "Amazing Race" and not "The Amazing Race," and things like that.

* Caller ID still isn't working right, as many have described. (Minor to me.)

I am using componant to a 17 inch HISENSE HDTV monitor in my home office, so can't test HDMI or anything other than RCA cable sound.

The things I like:

* Showing available space

* Ease of recording a show and setting up a season pass (or whatever they call it)

* Ease of getting to the My VoD menu and the shortcut (color) buttons to useful lists

* The quick guide and relatively fast guide options.

* Overall speed and ease of use. Where some people find that it's too different than the Tivo, I think it's fine. I've used the D10 and the H20 so I was somewhat used to the menu setup. I don't find it a hassle at all and the UI isn't a reason to avoid this box.

Bottom Line:

Once OTA is activated, Closed Captioning is totally fixed (and implimented with 1X FF), and dual buffers are given to this box, I would have no problem replacing my 2 SD-Tivos and my HR10 with this unit. I'd really want the 30 second slip to be faster as well. It's far too slow to be useful, and I'll probably just create a macro that runs 3x for a certain length of time if they don't fix that.
See less See more
Status
Not open for further replies.
1 - 7 of 7 Posts
Good overview and I agree with what you have said.

I will have had mine for a week tomorrow. I have noticed a freeze up on starting to play back a recorded show twice. Other then that no issues.

I would also like to see OTA soon since my A9 dish isn't going to be installed until 10/27.
Phil T said:
Good overview and I agree with what you have said.

I will have had mine for a week tomorrow. I have noticed a freeze up on starting to play back a recorded show twice. Other then that no issues.

I would also like to see OTA soon since my A9 dish isn't going to be installed until 10/27.
The good news is that there have been weekly updates that have seemed to help lots of the original stability problems that everyone had at one time or the other. There are still outstanding issues that need to be addressed; but I'm fully confident that they are being worked on; as we speak.
I'm pretty confident as well, Vinny. I forgot to mention that I like the font choices for CC, which never seemed to work right on my H20.

Earl, if you read this and have any info on CC updates, I'd always be interested.
Capmeister said:
I'm pretty confident as well, Vinny. I forgot to mention that I like the font choices for CC, which never seemed to work right on my H20.

Earl, if you read this and have any info on CC updates, I'd always be interested.
I have no updates on the CC.
I know they where paying extra attention to my two threads asking for input on Showtime preview weekend.
Thanks, Earl. I figured they might be, which is why I posted the pic of the letter cut off. :)

I hope they also listen about CC on 1x. :)
Capmeister said:
the inability of the search utility to ignore the "The" in a show's title so that I can search for "Amazing Race" and not "The Amazing Race," and things like that.
I can't believe the "The" issue wasn't done correctly right off the bat. It seems like the sort of thing that someone would notice in alpha testing. I'm sure it's an easy fix, hopefully they'll code it into an update soon.
1 - 7 of 7 Posts
Status
Not open for further replies.
Top