DBSTalk Forum banner
1 - 6 of 6 Posts

·
Legend
Joined
·
184 Posts
Discussion Starter · #1 ·
So today my 2 1/2 yr old 50" Hitachi Plasma went black. It was on earlier and just went out, when it is turned on it shows a flash of a picture very briefly then goes black with the blue power light flashing three times repeatedly. Tried unplugging power for a few hours as well as unplugging the inputs. Cannot find any codes on the internet so far. Hoping someone has a magic solution otherwise I am guessing I am in the market for a new one :(
 

·
Geek til I die
Joined
·
9,821 Posts
While I have no idea, it sounds like it might be the power supply power capacitors. If so, it should not be an expensive fix, if you can find a service center that still does board level repairs (vs just replacing the whole power supply). Just a guess tho.
 

·
Legend
Joined
·
184 Posts
Discussion Starter · #4 ·
Finally got it to the shop today, we'll see what they come up with, I set the limit around $300. TV stand sure looks strange empty :(
 

·
Legend
Joined
·
184 Posts
Discussion Starter · #5 ·
Nearly a month now and still not fixed dang it! They haven't even told me if it's fixable! I want my HD TV!
 

·
Godfather
Joined
·
722 Posts
That just sucks. Unless they guy is having trouble locating the parts, it should have been fixed ages ago. Even then you should have been kept up to date. If it is just a couple of caps or even the whole board, it takes longer to take the back off the set than it does to make the repair.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top