DBSTalk Forum banner
1 - 5 of 5 Posts

· New Member
Joined
·
5 Posts
Discussion Starter · #1 ·
OK - I am near my wits end! I have an HR20-100 that has performed flawlessly for ove one year. I went on vacation beginning June 5. When I returned on June 19th, my HR20-100 was experiencing latency/non-responsiveness with the standard DireTV universal remote. I tried several RBRs and hard Receiver resets, and these did nothing, save for some brief improvements, to the issue. I also have a Logitech Harmony universal remote set up to control the HR20-100, and it displays the same latency issues when trying to control the HR20 receiver.

I called D* the second time this evening and spoke with a customer service rep. After walking me throught everything that I had already tried omn my own, she suggested that we schedule a service call priced at $19.95 with an agreement that I buy the "protectition plan" for $5.99/month!!!! I was flabbergasted! THe other "option" that I was offered was to forego the monthly protection plan and pay $79.95 for a one-time D* service call. This seems insane to me. I pay this company almost $120/mo for service, have been a loyal customer for over 10 years, and they want me to ante up for a service call for what I believe is either defective equippment or a defective FW upgrade that has disabled my receiver? ANyone have a suggestion for hopw I should proceed?

Thanks in advance.
 

· Superfly
Joined
·
4,572 Posts
I'll let others respond to your specific complaint about speed issues. Instead, I'd recommend that today, tomorrow or next Wednesday, you get over your outrage at having to spend money for a service call. You may not need one this time but sometime you will. And, unless you have the protection plan in effect for at least the previous 30 days, you will have to pay for that service call. Them the rules, period. Sorry. You may not feel it's right or equitable, but it's the agreement you have signed up for. You're going to have to get over it sometime. It might as well be now.

I do have one question on your speed issue. Did you get the new software upgrade that began last night? I wonder if that will make any difference in your latency.
 

· Freethinker
Joined
·
3,179 Posts
Hopefully the new update will take care of the issue.

I've had very few issues with my HR20 until the last week. Tonight I had my 5th lock up in a week. Very frustrating.
 

· Legend
Joined
·
268 Posts
The last 2 AM's when I've gone to turn on the HR20-100 I have in my kitchen it's been "dead"...no responsive to the remote. When I flip the switch on the remote to TV, it operates the TV fine.

I did a RBR yesterday and the unit then responded to the remote commands when it finished rebooting......but this AM again it was dead.....so I decided to see if it responded to any button pushes on the front panel---and it didn't. So, again, I did a RBR...and it came back to life after that.

So, it doesn't *seem* to be the remote (i.e. bad remote, dead batteries, bad IR sensor) I'm having an issues with but moreso the unit itself. I'll have to see how it responds tomorrow AM and go from there....
 

· Freethinker
Joined
·
3,179 Posts
My issue is not the remote. The issue is that my HR20-100 has recently become a peice of sh!t that locks up every f**king day. As I stated before, I hope the new update fixes things. Maybe I'll get it before the weekend.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top