DBSTalk Forum banner
21 - 27 of 27 Posts

·
Go Pack Go!!!!
Joined
·
2,435 Posts
Discussion Starter · #22 ·

·
Registered
Joined
·
43 Posts
Yep, capacitors - not resistors! Must have been distracted by the kids cheering that their Spongebob videos were restored. ;) Corrected my response.
I realized this is old, but I'm dealing with a similar power LED on, no display and no resolution setting looks dead. I only found this thread after making a new post and then googling "hr20 power supply pin out" hoping someone published power supply outputs. Somehow I didn't find this thread when I searched here before starting a new thread.

BlueBird999, your results give me some confidence that replacing the 4 bulging caps won't be for not. For me it's 4 caps CP 201,202, 205,206. I thought the voltages looked good except I can't figure out if 4.2V on the first two pins of BP201 (closest to front on main board). The voltages from front to back were (relative to HD ground) 4.2, 4.2, 0, 13.2, 0, 0, 5.5, 5.5, 5.5. I'm pretty sure the 5.5 and 12Vs are good.
I've attached a picture in case any of the non-EE folks are interested. 😁
Light Circuit component Font Electronic engineering Electrical wiring
 

·
Registered
Joined
·
43 Posts
@jeff d, keeping it in one thread would be a kosher behavior :)
Agreed, and found this thread only after starting my thread. But because capacitors were mentioned here as a cause I wanted to include my findings to support the capacitors replacement can restore video output/front panel LED light up on power on.

Full analysis and results of my repair can be found in this thread
 
21 - 27 of 27 Posts
Top