DBSTalk Forum banner

HR20 swapped up to HR21

673 Views 2 Replies 2 Participants Last post by  z28lt1
I've posted a few times on here about the various problems I've had with my HR20, and finally couldn't take it anymore, so I called for the swap.

As a quick recap:
One of my two HR20-700s would very regularly (average of 2-3 times a day) drop a tuner and need a reboot to get it back. This happened on most of the software releases (including the most recent NR) , but there was a few NR's that it seemed to work fine with - including the originally installed 0x15. Recently, I moved, so new dish, new wiring, new everything except the receiver. Same problem.

As one last ditch effort, since I'm about to add a 5th DVR to the setup and outgrow my multiswitch, I purchased a SWM, figuring that would help since it was only one wire and no BBC's. That made it much worse actually, as often just changing the channel would cause it to lose a tuner.

I finally called DirecTV. The CSR really wanted to roll a truck and since I'm not on the protection plan and knew obviously it had to be the receiver, I asked him to just swap out the thing. He agreed, but noted my account that his recommendation was to swap it out. Received a refurb HR21 and so far it is only been one day, but appears so far so good.

Moral of the story, for those of you having a ton of 771 issues that others aren't, go ahead and swap as it probably will help.

As a side note, the T+C's in the e-mail they sent for my swap of leased receiver stated a new 2 year commitment that I wasn't happy about, but it is my own fault for not have the protection plan (first time I would have needed it in 10 years, so I'm still ahead of the game).
1 - 3 of 3 Posts
I'm glad it finally worked out for you!
Well, it lasted a day. The dropping tuner probelm is gone, yay!. But the refurbished HR21 no longer thinks it has a network card in it. It worked for a few hours, and (without moving the unit, so it shouldn't have gotten unseated) The network card doesn't work. No lights on the back of the unit with a cable plugged in, the MAC address from the advanced setup menu is blank...so this one needs to go back too.

As a side note, the thing seemed to hiccup on acquiring all the guide data. 20 some hours in, it still had very little data. A complete reset fixed that problem, but not the network problem.
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.