DBSTalk Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
New Member
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,

I'm a long time reader of these posts, which eventually pushed me to go ahead and order the HR20.

I purchased an entirly new HDTV entertainment system (new TV, reciever, DVD, and HR20). The HR20 was the last piece to arrive, it came yesterday after I ordered it on 9/11/06. The installer came and got the reciever to work, see the satellite, and checked to see I was getting all my channels. 10 minutes after he left, I was familiarizing myself with the new controller and I pressed pause. The screen whet grey, the 1080i led on the front of the box went out (all 4 LEd's are out) and the blue led on the power button, which was bright, went dim. Now the thing won't work at all!

I've pulled the power cord, pressed the red reset buton, all to no success. I called the installer and they are trying to get someone out Sunday, but they said they aren't sure they will even have a replacement HR20!

Any suggestions to what else I can do?:mad:
 

·
New Member
Joined
·
2 Posts
Discussion Starter · #3 ·
tstarn said:
Watch DVDs? Just kidding. I feel your pain. Try and at least get an H20 until your HR20 is replaced, at least you can watch HD programming. No older DVR? Directivo?
Yeah, the guy took one of my older recievers, but I still have my two other std def tivo boxes. I was hoping someone could give me some button press/ while plugging the box in reset which might fix my problem...

Guess I'll just have to get by...
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top