DBSTalk Forum banner

HR21 won't use eSATA (SIL5744, RAID1)

2727 Views 6 Replies 4 Participants Last post by  Riot Nrrrd™
I'm trying to put together an eSATA RAID1 disk system for my new HR21. I've used an AMS DS-312 enclosure, 2 * Seagate DB35.3 750GB SATA 3Gb/s disks, and a 2m SIIG eSATA cable (though I've also tried the cable that came with the enclosure). The DS-312 uses a SIL 5744 chip, which is the same chip that is in the DS3RPRO that some folks have working. (So I thought this solution would have a good chance of working also.) I don't use any jumpers on the disks, so they are in 3Gb/s mode. The DS-312 also runs 3Gb/s on the eSATA port.

So, I restart the HR21, and disconnect power when the lights go out. I connect the eSATA and power up the DS-312. A short delay after the drive lights indicate they are up to speed, I reconnect power to the HR21. Then the "Almost there...a few seconds more" (yeah, right) screen comes up. During this screen, the DS-312's drive-activity LEDs light up 4 times, like this:

...about 5 seconds go by...
both drive activity LED's flash once (about .5 seconds long)
(a second later, I can hear the internal drive start up)
...another 5ish seconds go by...
both drive activity LED's flicker for about 1 second
...another 5ish seconds go by...
both drive activity LED's flash once (about .5 seconds long)
...another 5ish seconds go by...
both drive activity LED's flash once (about .5 seconds long)
(the internal drive starts making lots of seek noise)
(after a short delay, the screen switches to the "step one of two" screen)

I've tried a 2m SIIG cable and the 1m cable that came with the enclosure. Both seem to fit perfectly in the HR21 and DS-312, and both behave as described above. I've also tried reversing both cables, though both ends are identical.

I have connected the enclosure to my PC, though I can only do so with USB. :-( So, I cannot verify the eSATA is working this way. Ignoring that, the rest of the functionality works perfectly. The PC shows a 698GB RAID1 disk. I can partition it, format it, and check for errors (finding none). The PC likes it via USB.

(EDIT: bogus stuff about firmware deleted. The box already has the latest firmware for the DS-312.)

Does anyone have any idea what could be wrong? At this point, I'm thinking about moving to a DS3RPRO since someone has that one working, and it is almost the same feature-wise. It seems like the eSATA connection is working, due to the LED flashes, but there's no way to be sure. I wish the HR21 gave some feedback on what was going on...

See less See more
1 - 3 of 7 Posts
I've never heard of the DS-312 and can't even find any Web pages on it in Google. References?

I agree with you about the lack of feedback. To me, the fact that after 2 years there is no way to migrate your recordings/settings from the internal drive to a newly-attached eSATA drive is beyond retarded. I was even going to start a separate thread about this very issue this weekend. That the HR21 can't even put up a dialog box - "New external eSATA drive detected", "Initializing..." - and an error message in your case, given your results - is ridiculous. C'mon DirecTV! You put in the port, now fully support it!
hasan said:
Consider priorities. How long have we been fighting (with D*'s active and considerably efforts) to get Media Share to function? It is still limping along. The fact that eSATA is attainable, with stability in the face of it being low priority says a lot about the efforts others have gone through to make it so, and those truly in need have a solution at hand.
I'm sorry, but I don't agree with this.

Putting a port on a consumer device and maintaining after 2 years that it's "just there" and not fully supported is ludicrous. Support the hardware you ship, or pull the port off of successive generations of the hardware if you aren't going to support it.

The only way I've seen to migrate the internal drive's recordings to the external eSATA is to have a desktop PC with room for 2 internal SATA disks with SATA data cable & power cable available to the HR's internal drive (either by stretching to reach the HR or taking out the drive entirely from the HR, which voids the warranty and is not advisable).

Well, that doesn't work too well for those of us with a Mac laptop, now does it?

I am sorry to thread hijack but my main issue isn't the original poster's - gregries is a far more basic "Gee I plugged this in and it doesn't work" dilemma - it's the fact that as of now, the eSATA port is nothing more than a giant toggle switch. I know enough about Linux (I am a Systems Programmer and admin over 100 Linux boxes daily) to know that combining the internal with the eSATA into one mondo volume isn't really feasible, but the fact that there are no migration tools at all is absurd. :nono2:

You plug in a new, fresh eSATA drive. What should happen then? What happened to gregries? No on-screen feedback at all?

Why not

"New external drive detected. Initialize? [Yes] [No] [Ignore]"
"Initialization complete. Migrate recordings to external drive? [Yes] [No]"
"Migrating recordings. Please wait..."
"Migration complete. Restarting..." (and it either resets or gets to the "Step one of two" screen and continues)

We all know that the internal drive is formatted into 3 partitions, and the 3rd one contains the "raw" recordings.

How hard would it be for D* to initialize the external eSATA as a single partition (XFS volume) and move all the recordings over to it, and use it as the partition instead of the 3rd internal one from that point onwards?
See less See more
gregries said:
Yeah, the DS-312 is hard to find even on AMS's own site. They also call it the "VENUS eS2". You can find info on it with a search on DS-312SUES.
How bizarre. It just looks like the DS3RPRO in a different form factor.

No idea why it won't work for you. But I have a 2x1TB DS3RPRO (with 2 WD "Green" drives inside) sitting here raring to go, so I hope the same fate doesn't befall me! :eek2:
1 - 3 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.