DBSTalk Forum banner
1 - 19 of 19 Posts

· New Member
Joined
·
6 Posts
Discussion Starter · #1 ·
I have Verizon DSL and an SMC2804WBRP-G router with 2 PCs wired to it and a laptop connected wirelessly. No other current home network problems. Anyway, I'm trying to set up my new 722 to my Home Network, but I get no IP address when connecting to a router port. When I connect the 722 directly to the DSL modem, bypassing the router, I get an IP address and connection. I have my router's firewall disabled and have no MAC filtering. Dish support suggested I contact the router's support folks, but I thought I'd try here to see if anyone's experienced this.

Thanks
 

· Beware the Attack Basset
Joined
·
26,488 Posts
I agree that the problem is likely that your router isn't doing what is expected/required.

Are you certain you have your router set up to serve up DHCP?

How many DHCP clients is it set up to serve?

Have you tried resetting the router to factory defaults?
 

· Cool Member
Joined
·
27 Posts
I would go through your router's settings (log into it at 192.168.1.1) and make sure you don't have any configurations limiting the number of MAC or IP addresses using the router at once. Based upon your initial post, there's no question that your issue is router-related, but it's probably as simple as changing one setting in your router setup.
 

· Hall Of Fame
Joined
·
15,556 Posts
PFDG3 said:
The router's DHCP server is enabled, with an IP address range of 192.168.2.100- 192.268.2.199.
My two boxes are
192.168.1.100
192.168.1.104

You may have to have IP address available with 192.168.1.10X?
 

· Beware the Attack Basset
Joined
·
26,488 Posts
PFDG3 said:
The router's DHCP server is enabled, with an IP address range of 192.168.2.100- 192.268.2.199.
I'm going to assume that the 268 is a typo.

Is this how the number of clients is limited, or is there a separate setting?
 

· New Member
Joined
·
6 Posts
Discussion Starter · #9 ·
The 268 was indeed a typo. I don't see any other setting that would limit the number of clients.

I changed the default gateway, and the range in the router to 192.168.1.100 - 192.168.1.199, but still no luck.
 

· Godfather
Joined
·
316 Posts
I also have Verizon DSL. This is how I got my little network configured. I have an old wired Linksys router. My 2 PC's are configured with static IP's and static DNS's I enabled DHCP on my Linksys. I just connected my VIP622 and it automatically found an IP.The DNS servers showed up in the 622 network configuration. All my router settings are pretty much default except for my Verizon login and setting it up for PPPOE and DHCP and of course the DNS servers. I don't have any other DSL software running on any of my PC's. Hope this helps in some way. Good Luck.
 

· New Member
Joined
·
6 Posts
Discussion Starter · #11 ·
EXTACAMO said:
I also have Verizon DSL. This is how I got my little network configured. I have an old wired Linksys router. My 2 PC's are configured with static IP's and static DNS's I enabled DHCP on my Linksys. I just connected my VIP622 and it automatically found an IP.The DNS servers showed up in the 622 network configuration. All my router settings are pretty much default except for my Verizon login and setting it up for PPPOE and DHCP and of course the DNS servers. I don't have any other DSL software running on any of my PC's. Hope this helps in some way. Good Luck.
Well, all I know about static IPs is that they're normally for businesses and they usually aren't free. Before I explore that path, does anyone know if/why static IPs and static DNSs would make a difference for what I'm trying to do?
 

· Beware the Attack Basset
Joined
·
26,488 Posts
PFDG3 said:
Well, all I know about static IPs is that they're normally for businesses and they usually aren't free.
Static IP addresses within your own LAN are always free. With most routers, you should block off those addresses from the DHCP pool.
 

· Premium Member
Joined
·
21,658 Posts
Configuration varies from router to router... but some folks have had MAC filtering enabled on theirs that prevented the Dish receivers from connecting. You might have to disable MAC filtering so your receiver can get an IP then you can add the Dish receiver's MAC address to the "allowed" section and turn back on MAC filtering if that turns out to be the problem.
 

· New Member
Joined
·
6 Posts
Discussion Starter · #15 ·
harsh said:
Static IP addresses within your own LAN are always free. With most routers, you should block off those addresses from the DHCP pool.
I guess my lack of knowledge about static internet IPs is eclipsed by my greater lack of knowledge of local static IPs.

So let me see if I've got this. If I set up each of my current computers with static IP addresses, my router may have a better chance of being assigned a dynamic one by the router's DHCP server?
 

· Beware the Attack Basset
Joined
·
26,488 Posts
PFDG3 said:
If I set up each of my current computers with static IP addresses, my router may have a better chance of being assigned a dynamic one by the router's DHCP server?
Static IP addresses on LANs are really only useful if you're trying to get to a machine that isn't showing up on the LAN or you want to open up a hole to the device from the Internet proper (very dangerous). This kind of activity shouldn't have any effect on the DHCP situation.
 

· Icon
Joined
·
695 Posts
I am assuming you have a multi port router. You have a wire going from the 722 to the router. Less than 100 meters long.

Pull the power cord for the 722 from the wall. Restart it with the ethernet port connected to the router. Run the ip address setup again on the 722.

Sometimes it gets upset and won't get a DHCP address once it has one from somewhere else. Dish's interface for controlling the IP address sucks. They really need some troubleshooting tools added.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top