DBSTalk Forum banner

In Win 7 can't install printer driver

2313 Views 6 Replies 5 Participants Last post by  dmspen
I have a Win 7 Home desktop. Have had it for a couple of years. I have an all-in-one HP C6380 printer/fax/scanner.
It always has seemed to lose itself, i.e. become disconnected. Now I get error messages that say the driver is not installed. Device manager says it's not installed.

I ran the HP Printer Wizard and it said the drivers were disabled. It tries to enable and then restarts the wizard without the driver getting enabled.

I've downloaded the full driver and software suite several times and tried to install. If I try the 'connect with USB' it hangs after usb is connected as if it can't find the printer. When I try to use the wireless, it can't find the printer on the network. I can connect the printer to the network from the printer control screen easily. I get a message on the PC that TDP ports and a UDP port need to be unblocked. I opened those ports and only one was recognized as open by the printer install software.

I've tried the generic 'add a printer' but the printer doesn't show up in the Windows driver list (even after update)

What's stupid is that the printer shows up in my printer list!

Anyone have thoughts for a remedy?
1 - 3 of 7 Posts
Yes to all. I had previously installed the critical update from the HP site.

I may try an uninstaller program like REVO and try to re-install.

Last year the print head failed and I spent nearly 2 hours on the phone with HP (India) with a girl who didn't understand what she was reading off her script. I'm a bit of an intermediate expert on PCs and I still had to go through every bit of troubleshooting in her script even though the problem was fairly obvious.

My HP Care Pack warranty is good until next March so I may try and call them again.

However, based on everything I'm pretty much done with HP and their products. Too bad becuase I was an HP fanboy years ago.
harsh said:
Make sure the printer isn't USB connected while installing the drivers until the installation instructions explicitly demand it. If it is connected, the system can't remove and replace the drivers as it may need to do.
Did. When the instructions say 'plug in the USB' I did. At that point, the software should recognize the printer is plugged in. However, the 'next' box stays grayed out. I suppose the USB port on the printer could be bad, but the wireless connect doesn't work either.
1 - 3 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.